Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Dépannage des erreurs « Démarrage de Jamf Pro suspendu »

Aperçu

Si une mise à niveau a échoué, le message « Démarrage de Jamf Pro suspendu » apparaît. Un message d’erreur irrécupérable peut s’afficher pour les raisons suivantes :

  • Une ou plusieurs tables de base de données MySQL utilisent le moteur de stockage MyISAM
  • Erreur lors de la création du certificat de l’autorité de certification (CA)
  • Les fichiers JCE (Java Cryptography Extension) ne sont pas installés
  • Erreur lors de la mise à jour du schéma de base de données
  • Mise à niveau de Jamf Pro 9.97.x ou toute version antérieure vers la version 10.2.0 ou ultérieure
  • Mise à niveau de Jamf Pro 7.x vers une version 9.x

Ces erreurs, ainsi que les solutions correspondantes, sont décrites en détail ci-dessous.

Une ou plusieurs tables de base de données MySQL utilisent le moteur de stockage MyISAM

Cette erreur s’affiche si une ou plusieurs tables de base de données MySQL utilisent le moteur de stockage MyISAM. À partir de Jamf Pro 10.10.0, toutes les tables de base de données MySQL devront impérativement utiliser le moteur de stockage InnoDB.

Résolution

Pour corriger ce problème, vous devez convertir toutes les tables de base de données MySQL utilisant MyISAM vers InnoDB. Pour toutes instructions, lisez l’article de la Base de connaissances Conversion du moteur de stockage de base de données MySQL de MyISAM en InnoDB avec l’interface de ligne de commande des outils du serveur Jamf Pro.

Erreur lors de la création du certificat de l’autorité de certification (CA)

Cette erreur peut s’afficher si la table de base de données contient plusieurs certificats CA, si un problème est survenu lors de la génération d’un nouveau certificat CA ou si un des problèmes décrits ci-dessous s’est produit au niveau de la base de données :

  • Impossible de verrouiller la table des certificats CA
  • Impossible d’insérer le nouveau certificat CA
  • Impossible de lire le certificat CA existant

Résolution

Pour corriger ce problème, vous devez contacter le service d’assistance technique Jamf.

Les fichiers JCE (Java Cryptography Extension) ne sont pas installés

Cette erreur peut s’afficher si la base de données ne contient pas le type de chiffrement mis à disposition par JCE.

Résolution

Pour résoudre ce problème, configurez et installez Java et JCE en procédant de l’une des manières suivantes. Pour résoudre ce problème, revenez à une version antérieure de Jamf Pro. Pour plus d’informations, reportez-vous à la section Reverting to a Previous Version of Jamf Pro after a Failed Upgrade (Rétablissement d’une version antérieure de Jamf Pro après l’échec d’une à niveau).

macOS
1. Téléchargez les fichiers de stratégie juridictionnelle à portée illimitée JCE (Java Cryptography Extension) version 1.7 ou ultérieure.
Vous pouvez télécharger la dernière version de JCE (il doit s’agir de la même version que Java) à partir de :
http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
2. Copiez les fichiers suivants du dossier extrait vers /Library/Java/JavaVirtualMachines/jdk<version>.jdk/Contents/Home/jre/lib/security/ - local_policy.jar - US_export_policy.jar
3. Acceptez l’invite pour remplacer les fichiers existants.

Windows 2008
1. Téléchargez les fichiers de stratégie juridictionnelle à portée illimitée JCE (Java Cryptography Extension) version 1.7 ou 1.8.
Vous pouvez télécharger la dernière version de JCE (il doit s’agir de la même version que Java) à partir de :
http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
2. Copiez les fichiers suivants du dossier extrait vers C:\ProgramFiles\Java\jre<version>\lib\security\ - local_policy.jar - US_export_policy.jar
3. Acceptez l’invite pour remplacer les fichiers existants.

Erreur lors de la mise à jour du schéma de base de données

Cette erreur peut s’afficher lors de la mise à niveau du schéma de base de données. Cette erreur peut survenir aux étapes suivantes :

  • Modification du nom des tables
  • Modification du nom des colonnes
  • Mise à jour du codage des tables
  • Modification des tables
  • Création de nouvelles tables

Résolution

Pour corriger ce problème, vous devez contacter le service d’assistance technique Jamf. Pour résoudre ce problème, revenez à une version antérieure de Jamf Pro. Pour plus d’informations, reportez-vous à la section Reverting to a Previous Version of Jamf Pro after a Failed Upgrade (Rétablissement d’une version antérieure de Jamf Pro après l’échec d’une à niveau).

Mise à niveau de Jamf Pro 9.97.x ou toute version antérieure vers la version 10.2.0 ou ultérieure

Cette erreur s’affiche si vous essayez de mettre à niveau Jamf Pro de la version 9.97.x ou antérieure vers la version 10.2.0 ou ultérieure.

Résolution

Pour corriger ce problème, vous devez installer Jamf Pro 10.0.0, puis effectuer une mise à niveau vers Jamf Pro 10.2.0 ou une version ultérieure.

Mise à niveau de Jamf Pro 7.x vers une version 9.x

Cette erreur s’affiche si vous essayez de mettre à niveau Jamf Pro 7.x vers une version 9.x

Résolution

Pour corriger ce problème, vous devez installer la dernière version de Jamf Pro 8.x, puis effectuer une mise à niveau vers Jamf Pro 9.x.

Like Comment