Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

MB Air 10.9 waking from sleep state...black screen but can see mouse pointer.

Has anyone seen issues like mine?

Users close their laptop (sleep) and when they open to wake it up (could be 2 mins or 2 hours of sleep), they get a black screen but can see and move the mouse pointers. It can take up to 30secs to 45seconds to see the normal screen.

Also, there laptops are running EFI 2.8

Like Comment
Order by:
SOLVED Posted: 9/30/14 at 3:20 PM by jhbush1973

@Johnny.Kim I actually saw this as well on a MBP Retina, 15-inch, Late 2013 today.

Like
SOLVED Posted: 9/30/14 at 3:22 PM by bentoms

We saw this when deploying a custom screen saver. Not sure if that correlates.

Like
SOLVED Posted: 9/30/14 at 3:25 PM by mm2270

Not sure if its related, as it sounds both similar yet different, but we've seen a number of cases on a variety of MacBooks (Airs, Pros, old ones, new ones) where the Mac will boot to a black screen and not recover. The only fix is to reset the PRAM on them, which in our case is complicated by the fact that we have a Firmware password on them.

While we're not sure what has caused it yet in our case, it does seem related to bad pram settings. You may want to zap that and see if it helps.

Like
SOLVED Posted: 10/1/14 at 12:38 PM by Johnny.Kim

I don't have custom screen saver deployed.

@mm2270 The issue you are having sounds like SMC firmware upgrade 2.8 would fix.

I also was reported that some users would take closer to a minute before it would show the normal screen.

Like
SOLVED Posted: 10/1/14 at 12:41 PM by donmontalvo

@Johnny.Kim][/url where did you find the 2.8 update?

Argh...I wonder who was the genius at Apple who removed the shortcuts at the top of this KB:

EFI and SMC firmware updates for Intel-based Macs
http://support.apple.com/kb/HT1237

Like
SOLVED Posted: 10/1/14 at 12:46 PM by MikeL

Been seeing a lot of this at our organization. We're soon deploying Casper but it's happening to our macs. They share a fairly basic image with SEP, Altiris and Dell encryption... The Mac will wake up to a blank black screen and a mouse pointer. It's at the policy agreement screen but it doesn't show it. I tend to get around it by enabling voiceover (command \- F5) and navigate with VO keys to the accept button, then it starts working again. Mostly.

Like
SOLVED Posted: 10/1/14 at 12:49 PM by Johnny.Kim

@donmontalvo I forgot to mention, the firmware 2.8 is for Air's.

http://support.apple.com/kb/dl1749

Like
SOLVED Posted: 10/1/14 at 12:55 PM by mm2270

Thanks @Johnny.Kim, but if you're referring to this update, this is for specific models and even specifics year models. We're seeing this issue on a variety of Macs as I mentioned \- everything from Late 2011 MacBook Pros up to recent Airs. Its not that often, but happens often enough that we've been tracking it as a trend.
Its possibility related to our most wonderful Anti-Malware product that the company uses [/sarcasm].

Like
SOLVED Posted: 10/1/14 at 12:59 PM by Johnny.Kim

@mm2270 Mike, Yes...it is specific, failed to mentioned that haha.

I'm actually currently on hold with Apple EDU support. I'll keep you guys posted on what they said. When I called yesterday, the tech never heard of the issue I'm having except the power on from shut off state shows black screen.

Like
SOLVED Posted: 10/1/14 at 1:00 PM by MikeL

Yep I suspect it's the same issue. Can't find a common cause and it affects various Mac models, from 2011 and also the latest 2014 deployments. Started seeing it around the 10.9.2 release.

Like
SOLVED Posted: 10/1/14 at 1:03 PM by mm2270

The "power on from shut off state shows black screen" is exactly the issue we're seeing here. I'm both glad and sad that Apple support has heard of it. Glad that we're not crazy, but sad because it sounds like its not something we can directly fix. A fix may ultimately need to come from Apple. Ugh...

Like
SOLVED Posted: 10/1/14 at 1:27 PM by Johnny.Kim

Just got off the phone with Apple support.

He found a case where if Message(formally known as iMessage) is running/open, it creates the issue that I'm having.

@mm2270 does your users use Message app?

Like
SOLVED Posted: 10/1/14 at 1:41 PM by alexjdale

FYI, we have been seeing the "black screen of death" after running a 10.9 update (it's happened for every update from 10.9.2 through 10.9.5). The OS is running fine, you just have no usable display/interaction, just a cursor on a black screen after you run the OS update and reboot. Apple is aware of it and has no fix in 10.9.x (we opened a case with them starting with 10.9.2).

This is the fix we apply when it occurs:

  1. Perform a PRAM reset ( Cmd+Option+P+R ) on boot – let chime 3 times and let go
  2. Boot to Single User Mode (hold Command+S immediately after powering on)
  3. Verify and Mount the Drives \- Once in Single user mod, run the following commands: /sbin/fsck -fy /sbin/mount -uw /
  4. After the disk has mounted in step 3, run the following commands: rm -f /Library/Preferences/com.apple.loginwindow.plist rm -f /var/db/.AppleUpgrade After deleting the files, restart.
Like
SOLVED Posted: 10/1/14 at 1:44 PM by Johnny.Kim

@alexjdale Is this for black screen from powered off state?

Like
SOLVED Posted: 10/1/14 at 1:46 PM by alexjdale

@Johnny.Kim Yes, this is for the black screen when booting from power off, if it occurs after applying an OS point release update.

Like
SOLVED Posted: 10/1/14 at 1:51 PM by mm2270

This sounds very much like what we see, except that we don't get a movable cursor. Just a plain black display. That's probably because we have FV2 enabled on all our Macs, so, they are booting to a FV2 Pre-boot screen.

Our fix has been similar except we first need to boot to Recovery HD while forcing the display to an external monitor so we can see what's happening. Then remove the Firmware Password, and then reboot and zap PRAM. And finally allow it to boot normally and everything starts working again. In our case we have not needed to delete any files, but I will keep the above in mind as we look into it further. So thanks for that.

Like
SOLVED Posted: 10/1/14 at 1:59 PM by Chris

We're seeing something similar like @alexjdale
If i install a point update using softwareupdate on the command line and the display goes to sleep during installation,
we get the black screen with moving cursor when trying to wake it up.
I can still ssh in and reboot it, after that it works fine and the update is applied.

Like
SOLVED Posted: 1/17/17 at 2:50 PM by Yolan

I went through all the steps that @alexjdale explained but when I went to delete the plist file it said permission denied anyone can help ?

Like