Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.
CCT Badge CMA Badge
78

PARCC testing open discussion

Posted: 2/25/15 at 10:08 AM by Johnny.Kim

I believe there are a lot of admins here that are part of the PARCC testing. What are some issues you are seeing? What are your environments and such?

My environment is JSS 9.3 managing around 4500 \- 10.9 MacBook Air's. For the PARCC I have two policies set. One policy creates a local account at startup and the second policy creates a shortcut of Firefox (v30) on the desktop with the configuration file (I used CCK2 to create the cfg file) triggered at login with the created account.

One issue that I'm hearing from the guys (randomly and only a small percentage) are two finger scrolling stops in the middle of the exam and the clicker doesn't work on others.

78

Posted: 2/25/15 at 11:10 AM by roadrunner2348

I've been running into several issues, the big ones are...

Java settings with Safari \- Finally got this one sorted out, but in Safari you need to run Java in "Unsafe mode" for the testnav site. I was able to deploy this setting with a config profile that is working on my 10.8-10.10 clients. The short version is to set the java settings correctly on a computer, copy the safari plist, then remove everything else that you don't want set, just leave the managed plugin policy for java/parcc. Export the plist as an XML plist and import into JSS. If anyone wants it I can attach the file I uploaded to the JSS. This has been working great, provided that the computer gets the configuration profile of course.

Second is the Java update prompts, make sure they're disabled or you provide instructions for teachers/students on what to do if they get the prompt.

Third is use a new blank profile when doing testing. The first trial we had some issues with programs the students had installed popping up and kicking them out of the test.

One issue that a teacher pointed out was that if a student right clicks on the test they can bring up the dictionary lookup, but if they click on it, it bumps them out of the test. Was looking into disabling right click for the testing user but haven't had much luck yet, anyone have suggestions?

Last is a bug in the test itself, I have had a few students get kicked out of the test when clicking the tools icon or going to the next section, in some cases multiple times in 10 minute window. We did get some feedback from the state/parcc that other districts were having this problem as well. Can anyone confirm that?

Posted: 2/25/15 at 12:07 PM by emjay

We are also using a config profile in Safari, with a designated PARCC user that every student signs into. We didn't have any issues with right-clicking, as it looks like our two-finger click and control-click aren't working within TestNav at all.

We do run with a Student Restriction profile that bans executables from the /Users folder, and it appears as though this was causing issues using the in-test tools like Answer Eliminator and Line Reader. It looks like those pieces run from the /Users/CURRENTUSER/Pearson folder, so we've disabled that config and our testing seems to be going fine now, with all features accessible.

We also had students getting kicked from the test when attempting to skip questions or return to previous questions. We suspect that this is due to that restriction config profile, since once we disabled it we did not see any other issues.

I was wondering if anyone has verified that students getting kicked from the test can be traced to the automatic check-ins or inventory updates from Casper itself? Having to deal with this would gut any MDM solution out there, if these "phone-home" processes interfere with TestNav.

CCT Badge CMA Badge

Posted: 2/25/15 at 2:22 PM by Johnny.Kim

@roadrunner2348 It wasn't the right click, they just couldn't click on anything within the exam or two finger scroll.

I haven't heard any students getting kicked off in the middle of the exam.

What are some of your JSS environment like? I have around 1300 devices being planned to hit the JSS across 3 buildings with the policies waiting to push tomorrow morning. I suppose this will be a good stress test on my JSS server!

Posted: 2/26/15 at 8:48 AM by roadrunner2348

@Johnny.Kim the logoff problem has been happening during the trials, the students will try to go to the next section and they will get logged out with the 3005 error. The only thing that has seemed to help in that instance is restarting the browser and clearing the local website data, but it doesn't work in all cases. I had one teacher who had to resume the test 15 times for one student in his class because of this problem.

As far as the JSS server goes, we're only running 3-400 computers at a time \+ our faculty & staff and ours hasn't had any issues, its a VM with 2 cores and 8GB of ram and no issues so far.

CCT Badge CMA Badge

Posted: 3/3/15 at 9:13 AM by Johnny.Kim

Today was our first live testing and one common issue I am seeing is Java errors. Error 8028 which states that Java is outdated but the the laptop is up to date. I have been quitting firefox until they can.

Also, I have added the testnav site to the exception.list for Java, worked beautiful until the live testing today.

Anyone else see this?

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/3/15 at 10:56 AM by CGundersen

Possibly some info here to work with:

https://jamfnation.jamfsoftware.com/discussion.html?id=6489
*still seems to work with 8

https://derflounder.wordpress.com/2015/02/13/oracles-java-8-update-31-has-been-updated-to-java-8-update-31/

CCA Badge CCE Badge CMA Badge

Posted: 3/3/15 at 3:34 PM by Sandy

HI,
We are between windows now and running the samplers......
Uh oh! I just ran the tester and see now Java 8 update 40!!
But wait, I thought they had a release schedule and this was due on April 14 :)
EDIT: aaahhhhh, not a .pkg, a .app!!
Great timing ORACLE!!!

Java 1.8 update 31 also had a "build" update during our live window which was unique. This required an additional update: java-8-update-31-has-been-updated-to-java-8-update-31

During live testing;
When we see issues with specific users getting kicked out many times we've contacted Pearson and they have done something magical on their end to fix the student.
We also see kids get kicked out when they try to up volume and hit the iTunes function keys by mistake.

We are using Safari
I'm using a Config Profile for the Safari>Java settings, and a Composer package to add the TestNav url site to Java security exceptions.
Not giddy with anticipation for the next round...
Sandy

CCA Badge CCE Badge CMA Badge

Posted: 3/3/15 at 4:13 PM by Sandy

FYI inside the .app is a JavaAppletPlugin.pkg that appears to fulfill Pearson's java requirements, at least for us using TestNav 7.5.la.la.la

CCT Badge CMA Badge

Posted: 3/3/15 at 7:48 PM by Johnny.Kim

@Sandy, Just saw the thread for Java 8u40 after not realizing oracle went with .app installer. This is throwing me off now as I use rtrouton's script to deploy Java. As mentioned on the other thread, it doesn't work at the moment. rtrouton did comment on just a few minutes ago, so maybe he'll have an update in a few hours? haha (wishful thinking).

Looks like I'll be hosting the .pkg on my JSS and deploying it which puts a nice chunk of load on the server. Wish me luck tomorrow!!

CCT Badge CMA Badge

Posted: 3/3/15 at 7:57 PM by Johnny.Kim

@rtrouton][/url You sir, are the man!! Thank you! If you and I make it to the JNUC 2015, I will buy you a beer or 4!

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/3/15 at 8:00 PM by CGundersen

Oracle fears @rtrouton. Very nice! Ask Toolbar's got nothing.

Oh, and perhaps to deal with f8 and iTunes?

defaults write -g com.apple.keyboard.fnState -bool true

edit: approach too broad, volume would be a problem

I guess I'll test this ...

launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist
CCT Badge CMA Badge

Posted: 3/4/15 at 9:28 AM by Johnny.Kim

Just to update, today was a very smooth day with PARCC. And thanks to @rtouton script, java update took less then 15~20 seconds triggered at login.

Posted: 3/4/15 at 12:00 PM by sburrows

Sandy,

During live testing when students were getting kicked out of the test were they getting error 3005?

Any ideas what they "magically" did? Pearson support is blaming Java for crashing for our students who repeatedly get knocked out of the test.

Posted: 3/4/15 at 12:06 PM by roadrunner2348

We had two students yesterday, unable to take the test becuSe rthey were getting kicked out after everything they did. We swapped out computers, adjusted settings to no avail. Had to pull them out of the test session. Today exact same students had the exact same problem, and they were on some computers we newly setup specifically for parcc, nothing but system updates, the latest Java and flash.

Posted: 3/4/15 at 12:13 PM by sburrows

@roadrunner2348 were they getting error 3005? If so we are seeing the same thing.

Posted: 3/4/15 at 12:18 PM by roadrunner2348

Yeah, error 3005, thankfully it's been a small number that have been having problems with this.

CCA Badge CCE Badge CMA Badge

Posted: 3/4/15 at 12:21 PM by Sandy

Hi,
Prior to each test session, each computer is logged into the assessment local profile, in Safari we go to the Pearson system check page, once java loads (name and ip address filled in) we run the check, then go to the live site.
The student would get logged in and start the test and then it would shut down. In our case, we did not see any error codes. Move student to another computer, same result., get logged in , then a few questions in, kicked out.
We verified none of the obvious like iTunes F keys, other apps opening, etc. were happening.
Pearson requested logs, and lots of back and forth and then magically the student was fixed. took a few days, not good.
My list of error codes (TestNav 7) does not even have any 3000 range codes :(
Sandy

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/4/15 at 12:30 PM by CGundersen

iTunesHelper.app ... we're just going to restrict the iTunes process on PARCC Smart Groups and test.

@Sandy][https://support.assessment.pearson.com/display/TN/Error+Codes

CCA Badge CCE Badge CMA Badge

Posted: 3/4/15 at 1:38 PM by Sandy

@CGundersen, Thanks for the link! I see you're using TestNav 8, we're using 7.5 (MN)

For our assessment profile only, we are replacing the existing Loginitems.plist with one that only contains an automator app to mount our secondary save location, and Safari. This effectively removes iTunesHelper.app from login items.

If you're talking about restricting iTunesHelper.app using "Restricted Software" in the JSS, it may shut down TestNav before the restriction kills it....

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/4/15 at 1:49 PM by CGundersen

@Sandy, thanks for the info as well! iTunes is the largest complaint. We are testing, limited scope, restricting iTunes.app. Initial info is promising, but we are still reviewing info as it comes in. I did speak with a site that experienced the issue and they indicated the afternoon testing went well (w/out iTunes interruptions).

Posted: 3/5/15 at 8:45 AM by Nick_Gooch

Is anyone testing on iPads? Is ASAM working on the live test? Any feedback for iPad testing? We start testing Monday.

CCA Badge CMA Badge

Posted: 3/6/15 at 9:39 AM by msnowdon

We are also using MacBooks as well as iPads for testing. The MacBooks took a lot of tweaking regarding allowing several sites to run in Unsafe mode and the Java exception list. We found that 3005 error was being caused by the students putting Safari into full screen mode PRIOR to logging into TestNav. Just let TestNav put Safari into fullscreen mode like its designed to do and everything works much better.

Posted: 3/6/15 at 10:31 AM by sburrows

@msnowdon looks like that may have been our issue. Thanks!

Posted: 3/6/15 at 10:46 AM by roadrunner2348

Yeah, same here. I logged into the site using the test username and password and it looks like if Safari is in full screen when the test starts if you click anywhere along the top edge of the screen it bumps you out. Probably has something to do with the way the menu bar drops down when you in full screen. Thanks for that @msnowdon!

CCA Badge CMA Badge

Posted: 3/6/15 at 10:55 AM by msnowdon

That's great. Glad to be of help although I cant take all the credit. My co-workers figured this out. It wasn't happening to everyone so we tried to figure what they were doing differently than the people that were not getting the errors.

I entered a ticket with Pearson. They told me to go with a different browser. Idiots.

Posted: 3/6/15 at 11:39 AM by sburrows

Pearson was telling us to call Oracle cause Java was crashing.

Posted: 3/6/15 at 12:25 PM by musat

To echo what @msnowdon][/url said, that is what we have found as well. Our single biggest cause for the 3005 errors was students running Safari in full screen mode. Once we added that to the list of things to explain before the test, the 3005 errors were essentially eliminated.

I will also echo the comments of @msnowdon][/url and say that Pearson support are idiots who can only read from their script as if they were giving the PARCC test.

CCA Badge CCE Badge

Posted: 3/6/15 at 2:11 PM by Sterritt

In my case I have a massive and distributed environment that has never been brought fully into the managed fold; as such some of the challenges are due to misconfigured distribution points or software update servers (my netops people regularly change VLANs at our sites which necessitate changing the site server's IP addresses... but the backend in the JSS doesn't always get updated along with it.)

We also have every recent and older version of OS X to support due to requirements that our organization accepts donated devices. But it's not all that bad for OS X \- the Windows guys here are trying to block a pop-up but Pearson did some kind of update on their backend that uses a newer signed applet and they can't quash the "run this app" prompt for our end users. They got Pearson on the horn and were told, "Yes, our customers just accept that every user is going to have to click the 'Run this app' button once."

CCT Badge CMA Badge

Posted: 3/9/15 at 9:55 AM by Johnny.Kim

I tested the theory for error 3005 but wasn't able to replicate in Firefox. I agree that Pearson support are not that bright.

Had one of our guys call in to Pearson for error 3005, they requested for the logs which he submitted and we're still waiting.

Posted: 3/9/15 at 10:00 AM by sburrows

We weren't able to replicate the full screen 3005 error with Firefox either, just Safari.

Posted: 3/9/15 at 10:03 AM by roadrunner2348

Yes I tried with chrome (just found out this was supported now) and Firefox and didn't have this issue with either.

CCT Badge CCA Badge

Posted: 3/9/15 at 10:13 AM by jeremysmythe

Just started testing today and ran into the 3005 error on all our MBAs. I do think you guys are right and the issue is full screen Safari. We are doing more testing now and not seeing the issue once clear directions are given to not go into fullscreen.

Posted: 3/9/15 at 10:36 AM by SincerelyJoshin

Just about wrapped up with PARCC. Completed roughly 3,200 sessions on 1:1 MacBook Airs. Zero technical issues.

Posted: 3/9/15 at 10:40 AM by roadrunner2348

Just about wrapped up with PARCC. Completed roughly 3,200 sessions on 1:1 MacBook Airs. Zero technical issues.

You need to go buy a lottery ticket!

Posted: 3/9/15 at 10:57 AM by SincerelyJoshin

Suppose I could have gone into more detail regarding our deployment. Clients on 10.8.5 using Safari 6. Safari 6 ManagedPluginPolicies dictionary assigned via configuration profile. Java 8.31 with deployment properties configured and testnav applet cert being pushed down in system-level certificate store.

I have not been able to replicate any fullscreen issues on Mountain Lion. Assuming those affected are 10.9+ when all those wonderful additional fullscreen options were introduced.

CCA Badge CMA Badge

Posted: 3/12/15 at 7:59 AM by msnowdon

Has anyone done anything about notification pop-ups, such as notifications that updates are available?

Posted: 3/12/15 at 8:17 AM by sburrows

@msnowdon check out this thread that I started: https://jamfnation.jamfsoftware.com/discussion.html?id=13619

We were going to use that as a log in script to turn on do not disturb, but it seems like we have been fine without it.

CCT Badge CMA Badge

Posted: 3/12/15 at 9:03 AM by Johnny.Kim

@msnowdon We don't receive the update notification possibly because I have all the students laptop pointing to our NETSUS server (which isn't currently running) and it doesn't see any "new update".

Posted: 3/12/15 at 9:09 AM by roadrunner2348

@msnowdon Yeah same here, we've haven't done anything in particular to stop system notifications and it has not been a problem. I actually tried to get one to pop up while in the test software to make sure it wouldn't cause any problems. It either is showing behind the test window and not kicking you out or it is somehow enabling do not disturb.

CCA Badge CMA Badge

Posted: 3/12/15 at 9:24 AM by msnowdon

Thanks. One less thing to configure.

Posted: 3/12/15 at 9:18 PM by jagress

@Sandy @CGundersen

I've been getting some complaints about iTunes interrupting TestNav, but haven't seen it myself. Do you think this is iTunes Helper? Or something else? What did you end up doing? Thanks!

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/12/15 at 9:44 PM by CGundersen

@jagress We just ended up restricting iTunes.app (Restrict exact process name, Kill process) and scoping the restriction to our Smart Groups that have a TestNAV User Account created. Seems to be working pretty well and iTunes interruption complaints have largely gone away ... complaints that iTunes is not working are up a bit though. :)

As an aside/fyi, we pushed out a Firefox-based TestNAV user DMG this year as we had good success with it last time around. However, this year there was a select media file that would not play for sophmores ... other media files were fine. We found that those students did not experience the issue using Chrome.

Posted: 3/12/15 at 10:22 PM by SincerelyJoshin

@jagress

Maybe notification center prompting for iTunes update or media keys on keyboard?

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/12/15 at 10:46 PM by CGundersen

I'm sure F8 was occurring for us. In our case, I don't believe we were having issues with notification center, but I'm liking the thread mentioned above:

https://jamfnation.jamfsoftware.com/discussion.html?id=13619

CCT Badge CMA Badge

Posted: 3/12/15 at 11:05 PM by Johnny.Kim

Any itunes related for us has been students pressing the F8 key and that occurrence was minimal (less than 10 total students from 3rd grade to 8th) that I've heard of. We just completed the elementary and middle school today. Tomorrow starts the High school training so we'll see if they start pressing random keys.

@CGundersen when you say "Firefox-based testnav", do you mean just firefox with pre-configs (popup blockers, security exceptions, etc) ?

The media files, were they videos? There was one student that said that there was no audio while the "video" played, the tech and teacher checked it out and it states on the bottom/top "there is no audio in this slides".

CCA Badge CCE Badge CJA Badge CMA Badge

Posted: 3/13/15 at 8:02 AM by CGundersen

@Johnny.Kim That is correct. Basically a pre-configured local user account deployed via policy to designated Smart Groups. A configured/tested/Pearson-approved (for what that is worth ... ) browser placed in /Users/username/Applications

I believe the file in question was just audio and we've only experienced the issue with the one grade level. Also, no issues during prep/practice tests. Moving to Chrome (for those students) resolved the issue. Ticket with Pearson, but yeah ...

CCA Badge CCE Badge CMA Badge

Posted: 3/13/15 at 10:34 AM by Sandy

Last week Oracle released their Java 8 update 40 build 25 as a .app that tried to sneak ask.com into the mix...

After the uproar this caused, Oracle released a new Java 8 Update 40 build 26 which reversed the previous .app to a .pkg.

I am thinking I do not need to push this new one, but am not 100% on whether X-protect will recognize a build # as not up to date....
When Oracle did their last unscheduled build update, it was Oracle that was forcing the update on us.....
Anybody already sussed this out?
I do not want to send anything non-critical this close to testing......
Sandy

CCA Badge CCE Badge CMA Badge

Posted: 3/13/15 at 2:03 PM by Sandy

FYI: Oracle is now prompting to update Java 8 update 40 to Java 8 update 40...
Yippee......

Posted: 3/13/15 at 2:13 PM by rtrouton

@Sandy

Oy. It looks like the root cause is something similar to the "update Java 8 update 31 to Java 8 update 31" issue from a couple of weeks back.

CCA Badge CCE Badge CMA Badge

Posted: 3/13/15 at 2:23 PM by Sandy

For those of us in Pearson hell right now, this is no fun.
Java 1.8. update 40 build 25 becomes Java 1.8 update 40 build 26
and the only change is back to .pkg.... but now Oracle is prompting to update (which yes, started with update 31 build whatever)
Add to that the Flash Player update that arrived yesterday which most of our techs had JUST finished getting out there...
not cool x2500

CCA Badge CMA Badge

Posted: 3/13/15 at 2:53 PM by msnowdon

Im in Pearson hell but I'm not getting prompted that I have to update Java, even running TestNav. I'm still on 8 u31 on OS X 10.9.5.

CCA Badge CCE Badge CMA Badge

Posted: 3/13/15 at 3:04 PM by Sandy

@msnowdon really? I have Java check for updates unchecked and at around 1:30 today, when we opened Safari to the live TestNav site they all prompted to update Java 8 update 40 to Java 8 update 40.

Posted: 3/13/15 at 3:36 PM by rtrouton

For whatever reason, Oracle hasn't updated the update feed for Macs running Java 8 Update 31. For those Macs, Oracle's feed says Java 8 Update 31 build 13 is the latest and greatest. Any other version of Java, including Java 8 Update 40, you'll get prompted.

CCA Badge CCE Badge CMA Badge

Posted: 3/13/15 at 3:42 PM by Sandy

WHT? @rtrouton, well THAT makes perfect sense!!

Posted: 3/13/15 at 3:44 PM by rtrouton

I'm giving up sense for Lent, as it just doesn't seem to be helping in this regard.

I've written a post on the Java 8 Update 40 update situation, available from the link below:

https://derflounder.wordpress.com/2015/03/13/oracles-java-8-update-40-has-been-updated-to-java-8-update-40/

CCT Badge CMA Badge

Posted: 3/13/15 at 6:19 PM by Johnny.Kim

Yup, we got prompted for Java update but not a lot. Around 20 out of 1050 MBA's. I just flushed the policy log so they will get the update on monday.

Posted: 3/13/15 at 7:15 PM by rtrouton

For those using it, I've updated my install_latest_oracle_java_8 script to accommodate Oracle's changes today:

https://github.com/rtrouton/rtrouton_scripts/tree/master/rtrouton_scripts/install_latest_oracle_java_8

CCA Badge CMA Badge

Posted: 3/14/15 at 9:58 AM by msnowdon

And top it off, Pearson recommends NOT updating to Java 8 u40 according to their Technology Bulletin dated March 10, 2015.

my link text

CCT Badge CMA Badge

Posted: 3/16/15 at 6:51 AM by Johnny.Kim

@rtrouton Out of 75, 1 received a failed status " The upgrade failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.) "disk1" unmounted. "disk1" ejected." Would you know what would cause the installation fail?

Here is the full log...

Script result: % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 100 929 0 929 0 0 1671 0 --:--:-- --:--:-- --:--:-- 1673 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 20 58.4M 20 11.8M 0 0 6126k 0 0:00:09 0:00:01 0:00:08 11.8M 43 58.4M 43 25.5M 0 0 8746k 0 0:00:06 0:00:02 0:00:04 12.7M 70 58.4M 70 41.2M 0 0 10.3M 0 0:00:05 0:00:03 0:00:02 13.7M 98 58.4M 98 57.6M 0 0 11.5M 0 0:00:05 0:00:04 0:00:01 14.4M 100 58.4M 100 58.4M 0 0 11.5M 0 0:00:05 0:00:05 --:--:-- 14.4M /dev/disk1 GUID_partition_scheme /dev/disk1s1 Apple_HFS /private/tmp/java_eight.bR8m Mar 16 07:02:42 C17MW.local installer[10170] : Product archive /tmp/java_eight.bR8m/Java 8 Update 40.app/Contents/Resources/JavaAppletPlugin.pkg trustLevel=100 Mar 16 07:02:43 C17MW.local installer[10170] : -[IFDInstallController(Private) _buildInstallPlan]: location = file://localhost Mar 16 07:02:43 C17MW.local installer[10170] : -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/tmp/java_eight.bR8m/Java%208%20Update%2040.app/Contents/Resources/JavaAppletPlugin.pkg#javaappletplugin.pkg Mar 16 07:02:43 C17MW.local installer[10170] : Set authorization level to root for session Mar 16 07:02:43 C17MW.local installer[10170] : Will use PK session Mar 16 07:02:43 C17MW.local installer[10170] : Starting installation: Mar 16 07:02:43 C17MW.local installer[10170] : Configuring volume "Macintosh HD" Mar 16 07:02:43 C17MW.local installer[10170] : Preparing disk for local booted install. Mar 16 07:02:43 C17MW.local installer[10170] : Free space on "Macintosh HD": 53.68 GB (53678514176 bytes). Mar 16 07:02:43 C17MW.local installer[10170] : Create temporary directory "/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T//Install.10170GKu5qE" Mar 16 07:02:43 C17MW.local installer[10170] : IFPKInstallElement (1 packages) Mar 16 07:02:43 C17MW.local installer[10170] : Using authorization level of root for IFPKInstallElement Mar 16 07:02:43 C17MW.local installer[10170] : PackageKit: Enqueuing install with boosting installer: Package name is Java 8 Update 40 installer: Upgrading at base path / installer: Preparing for installation…..... installer: Preparing the disk…..... installer: Preparing Java 8 Update 40…..... installer: Waiting for other installations to complete…..... installer: Configuring the installation…..... installer: # installer: Writing files…..... # installer: Moving items into place…..... # installer: Running package scripts…..... # installer: Running package scripts…..... #Mar 16 07:02:46 C17MW.local installer[10170] : install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “JavaAppletPlugin.pkg”." UserInfo=0x7f898af6fc90 {NSFilePath=./postinstall, NSURL=file://localhost/tmp/java_eight.bR8m/Java%208%20Update%2040.app/Contents/Resources/JavaAppletPlugin.pkg#javaappletplugin.pkg, PKInstallPackageIdentifier=com.oracle.jre, NSLocalizedDescription=An error occurred while running scripts from the package “JavaAppletPlugin.pkg”.} installer: Running package scripts…..... installer: Validating packages…..... #Mar 16 07:02:47 C17MW.local installer[10170] : Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. installer: The upgrade failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.) "disk1" unmounted. "disk1" ejected.
CCT Badge CMA Badge

Posted: 3/16/15 at 8:12 AM by Johnny.Kim

Something to read with your morning coffee...

http://www.washingtonpost.com/blogs/answer-sheet/wp/2015/03/14/pearson-monitoring-social-media-for-security-breaches-during-parcc-testing/

Posted: 3/17/15 at 7:15 AM by roadrunner2348

Oh look another Java update!

1.8.40.27 just popped up.....yay......

Posted: 3/17/15 at 7:55 AM by jagress

Rather than deal with keeping Java up to date for PARCC, I tested everything with a specific version, got machines up to at least the version, and then disabled the automatic update prompts. Seems to be working well (crossing my fingers)!

Posted: 3/17/15 at 7:59 AM by roadrunner2348

Yeah, I went and started going through the release notes, probably should have done that sooner, looks like they give each version an expiration date, 8.31 and 8.40 don't expire until April 14th, so I'm staying at 31 for the time being. Not sure what the deal is with the different build numbers though. I couldn't find much on that. I just know version 31 is not prompting for update so it's staying for now.

Posted: 3/17/15 at 8:04 AM by jagress

@roadrunner2348 I learned the hard way about those expiration dates, which is why I started disabling the auto updates - at least for PARCC machines :)

Posted: 3/17/15 at 8:56 AM by rtrouton

@Johnny.Kim,

Sorry, don't know what caused that error. If it happened on only one machine out of 75, I'd recommend deleting the Java plug-in on that machine and re-running the script.

CCT Badge CMA Badge

Posted: 3/17/15 at 10:03 AM by Johnny.Kim

@roadrunner2348 @Sandy I need your help in Safari. I hit a major snag at the high school where the audio aren't being play within firefox. Tested in Safari and it works without an issue. With that being said, I'm going to have to make a last minute change and get Safari configured and have the students start using them.

What did you guys set to get xx.testnav.com to run in unsafe mode, disable popup blocker, etc and how did you deploy? I'm looking into managed preferences but I had some not so good experience (managed preferences not being removed once it was unscoped and such).

@rtrouton yeah, thats what I did. Thanks!

Thanks!!

CCA Badge CMA Badge

Posted: 3/17/15 at 10:24 AM by jacob_salmela

@Johnny.Kim I was able to use a config profile to get TestNav to run in unsafe mode and disable the pop-up blocker. You can download the .plist I used and modify it as necessary to make it into a config profile, which you may need to do as our URLs might be different.

I have also had success using a handful of scripts to change the Safari "unsafe" settings.

CCT Badge CMA Badge

Posted: 3/17/15 at 10:30 AM by Johnny.Kim

@jacob_salmela Jacob, Thanks for the plist you uploaded and your input. I just finished using composer to see the changes made within com.apple.safari.plist. I'll look at yours since its a cleaned up version and make the changes. Once modified, I'll upload to config profile and scope it to a test laptop and see how it goes. Btw, are you setting this on computer level or user level?

CCA Badge CMA Badge

Posted: 3/17/15 at 10:46 AM by jacob_salmela

@Johnny.Kim We have them set at a computer level. We just have local users and it seems to work just fine.

Here are those scripts I mentioned, which may just need some modification for the URLs

Our district ended up using a signed certificate with a DeploymentRuleset.jar, which really saved us a huge headache, but if they won't pay for one, the scripts are a decent workaround.

Good luck!

CCT Badge CMA Badge

Posted: 3/17/15 at 1:26 PM by Johnny.Kim

@jacob_salmela I went with a DMG to replace the plist file (with FUT & FEU). I already had set the Java exceptions with Firefox policy few weeks ago. Thanks again for your help!

CCT Badge CMA Badge

Posted: 4/23/15 at 6:54 AM by Johnny.Kim

Good morning all! PARCC testing has started for us this week. Anyone else?

Posted: 4/23/15 at 4:12 PM by etreglia

Yes, we had to start earlier thanks to AP testing. We found that the Java settings we'd pushed out by policy (we are using Safari on Macs running 10.8) were completely gone and rerunning the policy did not work. The website address was not even in the managed websites for Java in safari even though it had previously been there. One of our techs, Andrew, noticed that as soon as the policy would push it out, the Safari plist would instantaneously revert to the old version even if he killed the cfprefsd daemon. The only way the change would hold was to manually make the change on each laptop.

The solution he worked out was to use a configuration profile to push the plist out. In the past, we've been discouraged by other people not to use this method but it was the only way we could get it to work reliably. He tested it on one cart of laptops yesterday and it worked beautifully with no ill effects. Now we're widening the scope to the rest of our Macs.

Good luck everyone!

Emilia

CCA Badge CMA Badge

Posted: 4/27/15 at 7:48 AM by msnowdon

@etreglia ,

Do you have the policy as "ongoing"? We use a policy to push out the exception list in Java as well as the urls to run in unsafe mode in Safari and they seems to continue working even after the upgrade to 8 u45.

Mark

CCT Badge CMA Badge

Posted: 4/28/15 at 1:00 PM by Johnny.Kim

@etreglia Same here as @msnowdon. No issues with java exception list.

CCT Badge CMA Badge

Posted: 6/25/15 at 1:10 PM by Johnny.Kim

Here's some good new from PARCC...

http://parcc.pearson.com/bulletins/2015/06/16/parcc-technology-bulletin-hot-topics.html

CCA Badge CMA Badge

Posted: 11/3/15 at 8:00 AM by gregleeper

Has anyone had the chance to test out the new TestNav app for Mac?

Posted: 11/3/15 at 8:05 AM by SincerelyJoshin

Our state dumped PARCC, no TestNav for me this year. What's the app like? Browser with integrated runtime?