Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Keyboard freezes

We're having a couple oddball issues and are thinking might be JSS-related. We haven't been able to confirm though.

(1) Several users have reported that their macbook pro has a frozen keyboard. I have experienced this issue myself - I would bring my laptop home, open it up, and the keyboard would not work. I could still click things away and close programs by clicking the red circle, but for something like Google Chrome I couldn't click into the program to do a full "Quit Google Chrome" because I couldn't click on the browser to get the menu options to appear. I could go into the dock and do a right-click close.

We're not sure where this could be coming from. Maybe a 10.11.4 issue? Maybe Jamf?

(2) Sys Prefs > Security & Privacy > General > we had a Config Profile set to force "Allow apps downloaded from anywhere...but due to the frozen keyboard issue deleted that entire config profile. We still don't have access to the Require password option, nor the Allow apps feature. I could understand when they were restricted by the server that they might be grayed out - but we deleted the profile that should have been doing that. Is there another location those settings might be made?

Thanks!

Like Comment
Order by:
SOLVED Posted: by bentoms

@david.yenzer I've see 2) reset to Apple's defaults with OS updates & after about 30 or 90 days.

I think @rtrouton has a post or script on this setting being re-enabled. But I can't find it.

Like
SOLVED Posted: by EmmaV3

Hiya,

We had this happen shortly after upgrading our JSS to 9.9 and we had 6-7 or so Macbook users report that after their Macs went to sleep their keyboards were unresponsive.

Basically, the problem is being caused by one of the Configuration Profiles. If you look through your console you'll probably see some errors like this: "App:"Mail" tried to be brought forward, but isn't in fPermittedFrontApps’” So all of the apps stay in the background and can't be interacted with after being brought out of sleep.

So I turned off one of our configuration profiles which contained Energy Saver and Security payloads and we no longer have the issue. I know this has been raised with Jamf and I did mention it to Alex and it's being worked on for a later release of JSS. Hopefully the next one?

Like
SOLVED Posted: by david.yenzer

I'm going to give it some more time, but I think @EmmaV3 's response resolved this issue for us, possibly both. During a troubleshooting issue with Jamf Support last week we renewed a cert that allowed our Config Profiles to operate - we weren't using them at the time, but they were still scoped and active - so renewing the cert put them in action again. And perhaps there was something corrupt or old in those configs. Specifically, yesterday, I turned off a login window profile, and a sharing tab restriction profile. Last night and today I have verified that multiple machines have gotten back full control of the Security & Privacy area. Also, on the iMac I was testing with a frozen keyboard, it magically started working again yesterday. I did find an article that Apple had an issue with the frozen keyboard awhile ago and that putting a machine to sleep and waking up again helped temporarily resolve that.

We've had a slate of issues lately that are difficult to reproduce and difficult to verify if they're fully resolved. But I think we're making progress on this. Thanks for the tips and suggestions!

Like
SOLVED Posted: by jkb

Hello,

After finding this thread through Ben's recent article, I wanted to add to the comments for the record. We are:
- Still on 9.82
- Seeing this UI Freeze/Apps won't take focus issue intermittently with 10.10.5 (but not the handful of 10.9 machines we still have; no reports from few 10.11 users yet) on wake from sleep
- Have seen it on machines that were upgraded from 10.9 to 10.10.5 and a machine that was freshly imaged with 10.10.5
- We have two separate config profiles, one managing the Login Window and one managing Security & Privacy
- As pointed out above, the bit to look for in the system.log is “launchservicesd[xx]: Application App:"[some app]" asn:xxx pid:yyy refs=[string] tried to be brought forward, but isn't in fPermittedFrontApps"

I've been trying to figure out what was going on, but since it's an intermittent issue it's been like playing wack-a-mole.

Thanks for the heads up,
jkb

Like
SOLVED Posted: by jjones

We have started to have more issues with this recently as we updated our macs to 10.10+. What we have come to notice is our Gatekeeper/Security profile was at fault along with us having a custom profile set to require password/require at 15 seconds. We removed both and increased the Gatekeeper to require a password after 5 seconds, so far we have had positive results with everyone that has received the new settings.

Like
SOLVED Posted: by makander

We have this issue too. Keyboard being unresponsive after wake from sleep.

Edit: Removing the energy saver + security and privacy configuration profiles resolves the issue. I guess I can set those settings with defaults instead of profiles.

10.11.6 and Casper 9.96, never had an issue with it until we upgraded from 9.82 to 9.93.

Like
SOLVED Posted: by bentoms

@makander hey! Have a look at this

Like
SOLVED Posted: by makander

@bentoms I did take a look at that blogpost but I couldn't see anything wrong with the profiles. I think ultimately what resolved the issue was to remove the energy saver preferences.

Like