Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Unlock Standard User's Screensaver as Admin Broken in 10.12

Has anyone noticed when you have the edited /etc/pam.d/screensaver file in a 10.12 Mac, pressing Command Shift Enter opens up the username/password fields to unlock a standard user's screensaver but you find that you are unable to type anything in the fields?

Like Comment
SOLVED Posted: 9/23/16 at 10:34 AM by franton

Technically speaking, that's better controlled from the authorisation database rather than fooling with the pam.d configuration files. I leave that kind of thing to Centrify ;)

But yeah look for the security authorisationdb commands to do this, works a lot better. (I'm on phone so can't look at present)

Like
SOLVED Posted: 10/27/16 at 8:31 AM by carlo.anselmi

This used to work up to 10.11.6.

"With OS X Lion v10.7.3 and later, an admin user can can unlock another user's screen saver.
Unlocking a non-admin user's screen saver
Press Option-Return, then enter an administrative user's name and password."

Now in 10.12.1, if you try to unlock another user's screen saver (eg: network user) with Option-Return, you can't type into the name/psw fields and apparently get stuck there.
Is this a security feature? Am I missing something obvious?
Many thanks for your help!

Like
SOLVED Posted: 1/19/17 at 6:35 PM by true[robby]

Experiencing the same. Any keystroke entered is immediately backspaced.

Like
SOLVED Posted: 1/19/17 at 6:40 PM by true[robby]

Cross-referencing stackexchange

Like
SOLVED Posted: 1/23/17 at 4:22 AM by martinf

I hoped this may be fixed / go away in 10.12.2 but still experiencing the issue. Real pain for doing support, would love to hear if anyone has a work around or fix.

Like
SOLVED Posted: 1/23/17 at 2:13 PM by true[robby]

No fix in 10.12.3 released today.

Like
SOLVED Posted: 2/23/17 at 10:48 AM by maser

I can not say if this is addressed in the public beta of 10.12.4 b3. But you might try it there... ;-)

Like
SOLVED Posted: 2/23/17 at 6:58 PM by true[robby]

Very nice.

Like
SOLVED Posted: 3/28/17 at 6:06 PM by john.black

This appears to be working in 10.12.4

Like
SOLVED Posted: 3/28/17 at 6:10 PM by johnklimeck

Confirmed, working once again in 10.12.4

I know Robby is happy!

j

Like