Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Jamf Pro Release 9.97 - Status & Updates

We have identified an issue that is causing Jamf Pro 9.97 to read the FileVault 2 encryption status incorrectly. Due to the impact of this product issue, we pulled the 9.97 installers from Jamf Nation.

The symptoms of this issue include:

  1. Smart Groups could have incorrect membership based on encryption status.
  2. Encryption status on an inventory record would show a blank page or timeout.
  3. Enrollment of machines that were encrypted would error out on re-enrollment, although they would enroll into Jamf Pro.

We understand that FileVault is a widely used feature among our customer base and take any issues with Smart Group membership changes very seriously. We are working diligently to get an update out as soon as possible.

More information will follow as soon as the new release is available.

Like Comment
Order by:
SOLVED Posted: by tnielsen

Good. Thanks.

Like
SOLVED Posted: by donmontalvo

Good catch, thanks for posting this! :D

Like
SOLVED Posted: by leegalan

Thanks

Like
SOLVED Posted: by rcorbin

A fix has been released. Version 9.97.1482356336 We have installed it. Seems to have resolved the issue.

Like
SOLVED Posted: by joe.bloom

Yes, indeed. Casper Suite 9.97.1482356336 is now available and resolves the issues related to FileVault and device communication outlined here.

Thank you all for your patience as we worked through the issue. If you are on the original 9.97, we recommend that you upgrade. We will be working through upgrades for standard cloud hosted customers over the following days.

Like
SOLVED Posted: by russ.fagan

Installing this breaks your keystore and certificate. At least it did mine. Rekeying it with my cert again now.

Like
SOLVED Posted: by were.wulff

@russ.fagan

If your JSS is running on Linux and you use the installer (as opposed to the manual installation method), this is a known issue and you can simply move the missing files back from /usr/local/jss/backups/ to their appropriate places in /usr/local/jss/tomcat/.

If you're seeing this behavior on a Windows or OS X JSS install, please get in touch with your TAM if you haven't already.

Thanks!
Amanda Wulff
Jamf Support

Like
SOLVED Posted: by Nick_Gooch

Running windows and had to restore keystore from backup as well. DMZ would not connect to internal and wouldn't give me the options to change the database prior to restoring keystore and server.xml from backups.

Like
SOLVED Posted: by Sandy

Praise be to jamf!
Just did the JSS 9.97.1482356336 update and look at this happy new feature!!!!

Merry Christmas to ME!!!


Like

Jamf wants to hear your feedback around Jamf Pro: LDAP Servers and Reports!