Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Cinema 4D R17 Installation Solved

I wanted to give something back to the group since everyone has been so helpful to me. Thank you all.

I was having trouble creating a package for the Maxon Cinema 4D installation of which we are currently on the R17 release. I reached out to Maxon and they told there is no silent install for Cinema 4D but once installed you can move the Maxon folder to whatever machine you need it on, that is minus the license file of course. Here is what I did.

On a clean system I installed Cinema 4d and entered in all of the License and server information that was needed. I also started it up to make sure it was working correctly. I then ran any updates inside Cinema 4D that were needed. Once that was all done and I ran it again after updating to make sure it ran correctly one more time I quit Cinema 4D.

I opened the finder and went into the user account in which I installed Cinema 4D on and in the "/UserAccount/Library/Preferences" folder I moved the file "17mca" to the root "/Library/Preferences" folder. This file contains the License number. The server info is contained elsewhere in the MAXON folder system.

This is directly from from Maxon concerning the server "license.ini" file:
The file used to connect to the License Server is called license.ini; it's automatically generated on installation if you check the "Use License Server" checkbox when asked for a serial number. If you didn't do that, that's fine, I've attached a sample license.ini file. All you need to do is open it up in Notepad or TextEdit and in the "server = " line, add the IP address or network name of the license server machine, then save it to your Cinema 4D installation folder's root (C:\Program Files\MAXON\Cinema4D on Windows, "Applications/MAXON/Cinema4D" on Mac). This file will work for all machines so you only need the one.

In Composer I dragged the folder "/Applications/MAXON", I also dragged the file I just moved "/Library/Preferences/17mca" into Composer.

I did a package create, dumped it to Casper Admin, made settings changes for our environment and Casper Remote'd it to a Test system which worked fine from Yosemite up to Sierra.

I hope this helps and thank you everyone for coming to my add many times.

Have a very great day today!

Like Comment
Order by:
SOLVED Posted: by rory

Hi, I just followed your instructions to Package R18 which appears similar.

I had to make 2 packages, one for each elemnt dragged into composer.

May i ask is this what you did? or can you include the 17mca in the first package.

Thanks for any help and for posting

Like
SOLVED Posted: by skinford

@rory I dragged the the 17mca file into composer after moving it to the /Library/Preferences and packaged them all together. Should be 18mca as all other versions followed that same licensing sequence.

Like
SOLVED Posted: by iaml

Just a small optimization: you should not need to move the 17mca (or ##mca) file from ~/Library/Preferences to /Library/Preferences if you specify that you are installing for "All Users" rather than "Current User" when creating your master. In that instance, the ##mca file should be created in the correct location automatically; you just need to include it in your package in addition to the /Applications/MAXON folder.

Thanks for giving back, @skinford.

Anthony Reimer

Like
SOLVED Posted: by jwojda

Thank you for this.

It seems that R18 calls everything Demo... does that auto-change when it's licensed?

UPDATE: Another question, we aren't using a server, and I don't have a 18cma or whatever that /Library/Preferences folder was. I assume once I register the product it will be there. However, I don't really wish to distribute a licensed copy, I'd much rather deploy it unlicensed and then have the user(s) put in the licenses info...

Like
SOLVED Posted: by mconners

Hello @jwojda and @skinford have either of you found a way to disable auto updates for Cinema 4D? I am new to packaging this application and while it appears to be rather straightforward, I am having a tough time being able to disable this function. We don't have local admins on our computers in the student labs so we don't want to be causing angst when people can't update C4D. Thank you.

Like
SOLVED Posted: by allanp81

As far as I can tell, on R16 and then when we upgraded to R20, the file you want is "Cinema 4D.prf" which lives in ~/Library/Preferences/Maxon/Cinema 4D xxxxxxx/prefs

When I add that to the template and log in as a different user it has remembered to not check for updates. Annoyingly they store the prf file in a custom format so can't easily be checked/updated.

Like
SOLVED Posted: by mconners

Thank you @allanp81 for your reply. I was able to get this working, finally. I was so used to looking for .plist files and Cinema 4D doesn't use them.

Like
SOLVED Posted: by allanp81

@mconners Do you mean my post helped you?

Like
SOLVED Posted: by mconners

Yes it did @allanp81. I was stumbling around trying to find the preference file location. I read various things online and each time I attempted to move the file(s) around, it resulted in different outcome then I expected. Seeing your replied confirmed my suspicions and now all is well.

Like