Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. If you like what you see, join us in person at the ninth annual Jamf Nation User Conference (JNUC) this October for three days of learning, laughter and IT love.

Web service not working after hot fix 9.97.1488392992

We upgraded to 9.97.1488392992. Once the install was complete, the web service quit working and we haven't been able to make it work. Log shows web service is closing all attempts to connect. Has anyone experienced this?

Like Comment
Order by:
SOLVED Posted: by chriscollins

@officeit if you used the Linux installer it's most likely because of an issue with the installer not moving your SSL keystore back into the appropriate spot. So basically the JSS is running but can't serve https connections. The fix is simple though.

Go into /use/local/jss/backups and navigate to the latest backup the installer made and go into the tomcat folder and copy the backup of your keystore file back into /usr/local/JSS/tomcat/ and restart tomcat. It should load up now.

Like
SOLVED Posted: by officeit

Thanks @chriscollins This ended up being a certificate issue. As we have our own cert instead of the JAMF issued one, things got a bit screwed up during the upgrade. But we figured it out. Thanks for the reply!!!!

Like