Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Unable to install CC 2017 apps via self service

Hello all, currently experiencing an issue trying to install CC apps via self service.

Procedure:

Package app with Adobe Creative Cloud Packager (AAM v10.0.0.49)
License Type: Named (we do not have a license key, we assign licensed based on users, and add/remove licenses from them this way)
App: Photoshop/Indesign etc, doesn't really matter
Click create

When this is done - drag package into composer, select convert to source > hit build as package

Drag this package into Casper admin, configure man. account and some other settings, save

Open up JSS, new policy, package, select package, scoping and everything else, and select make available in self service

Package shows up in self service, I hit install....and the progress bar runs through the installer, and says completed

But nothing is ever installed....not CC Desktop, Not photoshop or anything

has anyone else experienced this? Any idea?

Like Comment
SOLVED Posted: 7/17/17 at 8:42 AM by ebalen

Instead of dragging the Adobe package into Composer, have you tried creating a snapshot and installing the package? Another thing to try would be caching the package then installing from cache. Usually Adobe products like to be installed from cache.

Like
SOLVED Posted: 7/17/17 at 8:44 AM by Backoffice

@ebalen HI yes I did try this a whaleback, but the install encountered errors and couldn't finish. I had a brief google around and while EVERYONE complained that Adobe gives them trouble, no-one had quite had my problem.

I am not sure if caching is the best bet for me - I have a fleet of machines built, and I will know pretty much on the day, if someone who will be taking the machine will require photoshop

Like
SOLVED Posted: 7/17/17 at 9:01 AM by SeanA

Why are you building the Adobe pkg into Composer when Adobe Creative Cloud Packager (CCP) is already spitting out a pkg ?
You should be able to skip the Composer step and use the pkg that Adobe CCP gives you.

Other troubleshooting steps:
Check logs on the client computer to see where the computer thinks it is being installed (e.g., /var/log/install.log, /var/log/system.log, /var/log/jamf.log).
You could always give the policy a custom trigger (e.g., george) and run the policy via Terminal (e.g., jamf policy -event george) and see if the Terminal output provides any additional clues.

Like
SOLVED Posted: 7/17/17 at 9:46 AM by jhuls

I think I've seen this happen before for software that the installer detects as not compatible or if you have compatibility set to specific OS's within the packages section of JSS or Casper Admin and the OS you're deploying to doesn't support the software. The logs for your self service policy you created will reveal this.

Also, I don't understand either why you're dropping the pkg into Composer and seemingly rebuilding the package. This isn't necessary unless you're making a change to it. If you are, I'm curious what changes you're making.

Like
SOLVED Posted: 7/17/17 at 10:45 AM by kowsar.ahmed

Why are you using composer? Create the package using Adobe's CC Packager then drag that installer straight into casper admin. Before I had to wrap it in a DMG and using a script to install post-caching. Now (perhaps adobe tweaked the .pkg files) I simply add it straight on and use a cache policy then a smart group to install cached.

Like
SOLVED Posted: 7/17/17 at 11:58 AM by donmontalvo

Why are you using Composer?

(Sorry couldn't resist)

Are your DPs migrated? If so your Adobe CC packages (which are actually folders) are ZIPd. If not, then not surprised your Adobe installs are failing.

Like