Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

JSS Conduit w/ SIS Importer not adding classes to proper site.

I still use the JSS Conduit w/ SIS Importer and it has been working great up until Jamf Pro v. 9.100
Now when sending the classes it does not add the classes to the proper site. The class gets created, adds all the students and teachers but does not set the site properly. Can anyone help on this? Has anything changed?

Like Comment
SOLVED Posted: 9/14/17 at 3:32 PM by dan.kubley

Hi Ryan,
Sorry to hear of the problem with the SIS Importer. We have recently found that the current version of the importer does not properly read the new JSS version schema. It translates 9.100.0 as 9.1, and reverts to an older ruleset that does not use sites and also takes longer to delete classes. We can see this in the SIS Importer logs, especially if they are in Debug mode.

We are working on publishing a new version of the SIS Importer, but that will be a little while yet, due to rebranding and documentation for the upcoming Jamf Pro 10. In the meantime, please email me at dan.kubley@jamf.com, and I will get you a link to download a hotfix of the SIS Importer. It is a zip file that contains a JAR file, so we cannot send it via email.

Dan Kubley
Jamf Support

Like