Skip to main content
Jamf Nation, hosted by Jamf, is a dynamic and knowledgeable community of Apple-focused IT admins and Jamf Pro users. Join us in person, in October, for the annual Jamf Nation User Conference (JNUC) to discover new and better ways to manage Apple devices.

How to use mac prestage enrollment?

We're just getting started with jamf.

The guy that came and helped set us up didn't cover anything about mac prestage enrollment.

We have computers purchased via DEP, and we created a new PreStage enrollment.

Under scope we have checked off one of the computers as a test.

During the setup assistant, the computer doesn't get enrolled into our jamf.

I have read through the documentation, but it sounds like it's supposed to "just work"...

What are we missing???

EDIT: I reformatted the new computer and installed High Sierra. It enrolled successfully during the setup assistant.

Like Comment
SOLVED Posted: 10/12/17 at 1:57 PM by cpdecker

There is a sort of bug? that can occur when running through a Pre-Stage enrollment on Mac with Sierra and below. After you connect to Wi-Fi, it may completely skip enrollment. We often have to walk back to the Wi-Fi selection and then forward again in order for the PreStage enrollment window to appear, sometimes more than once. That could be what you saw. There is supposed to be a window that says "XYZ organization is going to manage your Mac" or something similar. You might say, "what's the point of pre-staging if it doesn't work consistently?" I don't disagree.

There was also a glitch where some Macs would be slow on installing the JAMF binary and Self Service, sometimes never completing the enrollment even. For those we would run the QuickAdd package but we'd get a popup saying that the device can be enrolled via DEP and we'd still have to complete that process later, otherwise it drives the end user insane cause its kind of relentless.

I am guessing Pre-Staging will be a little cleaner in High Sierra. Hope this covers what you might be seeing.

Like
CCA Badge CCE Badge
SOLVED Posted: 10/12/17 at 3:07 PM by Look

It is supposed to just work.
But it is also dependent on network conditions being right, if your behind any kind of security layer you might it is not reaching something at apple or one of their geocaching partners that it needs.
It also uses certificates for security so depending on how your JSS certificates are configured you may need to set this to "not during enrollment".

Like
CCT Badge CCA Badge CCE Badge
SOLVED Posted: 10/12/17 at 4:19 PM by BostonMac

Are the computers plugged in to Ethernet or are you using Wi-Fi? What settings have you configured to run upon enrollment?

Are you at least getting the screen the "Configuration Available" Screen?

Like