Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Package failed to upload

Hi Nation, I am receiving the following message when trying to upload a package to Jamf Cloud:
Package failed to upload

The package has only 64 KB, I was able to upload other packages before, not really sure about what is going on...

Has anyone been through the same issue ?

Thanks you

Like Comment
Order by:
SOLVED Posted: by dmuncey

Were you able to figure this out? I've had package upload problems, to our JAMF Cloud, for months. I've submitted several tickets about it, but nobody has been able to resolve the issue.

It happens with small files, medium files, large files, packages I create, packages straight from the vendor, through the JSS web interface, through JAMF/Casper Admin. Sometimes it will show in JAMF/Casper Admin that it is uploaded successfully, then a short time later show as "missing" causing my policies to fail because it can't find the package on the server. I cannot find any rhyme or reason to why packages fail to upload, but it's driving me crazy.

I'm to the point where I absolutely hate Patching through JAMF because it takes me days just to get packages uploaded so I can push them out. My environment is small enough, it's almost not worth using JAMF to patch.

Like
SOLVED Posted: by msmith80

I have this problem as well. I have had multiple conversations with JAMF on this. It doesn't matter what size it is either. Their solution was just keep trying. It might eventually work. I was told they pretty much don't know what the problem is and not sure if and when they can fix it. So much for this "great" cloud solution we were talked into.

Like
SOLVED Posted: by tgoodpaster

Having this problem also with High Sierra right now. Had issues with Office updates. But they just started working yesterday. (Largest one there was just over 1 GB)

Submitted a help request to JAMF and really all they have said to do is;

  1. Retry - I have tried to upload HS multiple times now
  2. Get another distribution point like Amazon. - Not possible
  3. Let is sit there after error 408 and it will "work" - still shows up as missing even after letting it sit there overnight once

None of these options have worked and I have been very disappointed in their customer service. I noticed also this only started happening after the last update.

Like
SOLVED Posted: by aalberty

I also am trying to get a High Sierra package up on the Jamf Cloud Distribution Point. I've tried going through Jamf Admin, got a 408 and package was missing. Tried through JSS, and got a "Package failed to upload". I made several packages last week and had no issues getting them to upload (slack, gotomeeting, etc). My HS package is 3.27GB and I have it as a DMG... considering changing it to a PKG and seeing if that allows it to work for some reason. I'll report back if I get anything working.

Edit: Built as a .pkg, and it uploaded directly to JSS with no issues. I'm not entirely clear on the ramifications of it being a pkg instead of a dmg, but there's some documentation, and I'll be doing some testing... Hopefully nothing breaks.

Edit 2: .pkg seemed to upload on the surface, but when I looked at Jamf Admin, I realized that it actually did not successfully upload... Can't seem to get a High Sierra package of any kind to upload. Has anyone successfully done this yet?

Like
SOLVED Posted: by tackittj

We see the same thing on a regular basis. We're new to jamf and this issue is getting old real quick.

Like
SOLVED Posted: by bennumo

Im dealing with the same issue. Support has been lackluster. I initially had a problem with pkg files pending for more than a day. Then, after I'd delete and reupload, the same file would fail time and time again. I still have one pkg that isnt working even though the file itself installs software just fine. This is frustrating and I'm starting to regret bothering with jamf... given the price we paid.

Like
SOLVED Posted: by doylema

This problem still exists...

I have tried the following...

  1. Set the master dp to Jamf Cloud
  2. Upload through the web GUI
  3. Results = Availability Pending ... sometimes for days ... Upload Failed
  4. Upload through Admin and it still fails!
  5. Set the master dp to the local File Server
  6. Replicate to the cloud...
  7. 10 hours later and many files failed to replicate!!!

I'm not having any luck using JAMF cloud. Occasionally I'll get a file to upload the way it should.

Like
SOLVED Posted: by rhooper

I spoke to JAMF and they said that the cloud instance is limited to 5GB file size. High Sierra is 6.08GB.

Not sure if that may be the issue or not

Like
SOLVED Posted: by dmuncey

A quick update on our issue.

I struggled with this issue until the recent upgrade to JAMF Pro 10.5.0. Now it appears to be working. I haven't (knowingly) changed any of my workflows, so I wonder if something was fixed in the 10.5.0 release.

Like
SOLVED Posted: by coev

I was able to upload a 5.2G package a few weeks back. Now I am having this error uploading a 214K package. We are on Cloud ver 10.6

Like
SOLVED Posted: by Maven-IT

Running on Cloud, and I've been uploading packages without any issues until they upgraded to 10.10. It forced me to upgrade my Jamf Pro apps and now I get that error every time I've uploaded. Different sized packages. Even tried uploaded directly through Cloud but got errors also. Waiting to see what support comes back with, but seems like something with latest version.

Like
SOLVED Posted: by Garrett

I am having the same issue. Never have had this problem before. I have a .pkg that I am trying to upload to the cloud and then replicate to each of my two file share distribution points. The .pkg will not load onto the cloud server. I keep getting the following error message.

There was a problem uploading the package to Jamf Cloud. Connection failure: "The operation couldn’t be completed. ( error 504.)"

Like
SOLVED Posted: by brettw

I'm having this issue right now as well. Been working fine all day and then all of a sudden nothing will upload. I have experienced this in the past. After attempting to upload a very small .pkg file, it finally uploaded after about 8-10 minutes of retrys. This issue seems to resolve itself. It seems network related.

Like
SOLVED Posted: by jamesjan

Had this issue all day.
Anything over 3-ish GB fails.
Jamf just went to version 10.11.1
Last week while Jamf was still 10.10.1, it accepted the macOS Mojave 6GB pkg file without a hitch. Something must've broken with the latest update.

Like
SOLVED Posted: by Robert.Lavender

Same issue here on Jamf Version 10.11.1 Package failed to upload.
Also some Packages fail to install from Self Service.

Like
SOLVED Posted: by wveale

Having same issue. Just trying to upload a 80mb dmg. Nothing special. It worked earlier this morning but I haven't been able to get it to go for hours now.

Like
SOLVED Posted: by Steven5342

I am having the same issue. Error '504'. On version 10.11.0 and 10.11.1. Uploading a 5.2 GB package. Had no issues before these updates.

Like
SOLVED Posted: by gistrate

I am having the same problem. Trying to upload Mojave 10.14.5 installer, packaged as .PKG with Composer, almost 6GB in size. The upload seems to finish OK, but the package then says "Upload failed". No reason displayed

Like
SOLVED Posted: by Stephen.Conger

I am experiencing the same issue of not being able to upload a .pkg of Mojave 10.14.5. I get the following error: There was a problem uploading the package to Jamf Cloud. Connection Failure: "The network connection was lost." The upload hits 80% and fails. Any ideas or solutions to upload a 6 gig file?

Like
SOLVED Posted: by urchant

I am now having this issue as well. It's a 31.3MB file. It gets about 2MB in and fails.

Like
SOLVED Posted: by Chris_Hafner

I'm in the same boat here, but am opening a ticket.

Like
SOLVED Posted: by liut

I've had issues with jamfcloud before, as well - try a different browser/update browser?

Firefox is my main browser, but uploads constantly fail with some files. I've had to switch to Chrome, and I haven't had an upload fail since switching.

Like
SOLVED Posted: by cainehorr

I'm seeing this error when running

sudo jamf recon -verbose

So it's not just limited to a web browser.

Like
SOLVED Posted: by tanton

I had been having the same issue. Reached out to Jamf support and they suggested that because it had failed one time the failed instance may still be cached. They had me remove all instances of the failed uploads, rename the package and then upload again. I used Safari to upload and it worked!

Like
SOLVED Posted: by MacleayIT

I am having the same issue too. I can upload the packages using Jamf admin application, but I wont let me attached uploaded packages to any policies. It doesn't even give out an error! I just get the spinning circle of death and then it signs me out.

Like

Jamf wants to hear your feedback around Peripherals and Jamf Connect settings configuration