Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

high sierra smb and spotlight

On our 10.13 macs, multiple machines, we're having a new SMB issue with search results. The files are listed as results, but the icons blank out to generic. For a second you see the real icon, but then they blank out. The results are also now inaccessible. You can't copy or open from the results window. and getting info shows the regular info but no file path.

see screenshots that compare afp results to smb results and the get info box.

Anyone know? I've been searching but haven't seen any mention of it.



Like Comment
Order by:
SOLVED Posted: by ssavarese

Is no one else seeing this? I can reproduce this on any mac with a fresh clean install of 10.13.

Like
SOLVED Posted: by osxadmin

I'm on 10.13.1 I don't see any problems on displaying icons/image...
what setting do you have in Finder>View>Show View Options ?

Like
SOLVED Posted: by ssavarese

Its only in search results on SMB volumes. Regular folders local or AFP are normal and fine. I found an apple support page with others having the same issue.

https://discussions.apple.com/message/32344438#32344438

Like
SOLVED Posted: by osxadmin

interesting...I haven't run into that issue.

Like
SOLVED Posted: by kkono

I'm seeing a similar problems searching Isilon shares mounted via SMB on 10.13.2. Did you ever find a work-around?

Like
SOLVED Posted: by ssavarese

Hi @kkono sorry for the late response, I never got the email notification.

anyway, no we never found a solution. It's an issue with all of our High Sierra macs and our windows servers. Sierra doesnt have an issue. We've taken to using a third party app called EasyFind instead. Its not a great solution, but it works.

Like
SOLVED Posted: by ssavarese

Actually, I just updated to 10.13.4 and it fixed the problem!

Like