Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Package could not be mounted - No mountable file system

I'm pushing out the installer for High Sierra with a policy. It's in a DMG to later be executed with startosinstall from Self Service.

Anyway I'm getting this error on a handful of machines and re-occuring over and over on some of the machines it's pushed to.

Downloading https://MYJAMFSERVER/Packages/Install%20macOS%20High%20Sierra.dmg... Verifying DMG... Verifying package integrity... Installing Install macOS High Sierra.dmg... Error: The package "Install macOS High Sierra.dmg" could not be mounted (no mountable file systems).

A lot of machines received it no problem, but a handful haven't with this error reoccurring. I thought maybe the connection was getting interrupted but it doesn't seem like that, if I SSH into a machine and execute the policy from the terminal I'll still see the error and never get booted from the SSH session. I don't believe I've ever seen this with other policies and packages before.

Like Comment
Order by:
SOLVED Posted: 1/12/18 at 3:01 PM by bwiessner

@boberito

From what I have seen and tested this happens when you create packages on a APFS system like a HighSierra machine - and then deploy them to a computer that is not APFS or highSierra.

Like
SOLVED Posted: 1/12/18 at 5:10 PM by ocla&&09

I'll second that, was driving me crazy until I though to recreate the package in question on a non APFS/High Sierra machine.

The problem immediately went away.

Like
SOLVED Posted: 1/12/18 at 5:39 PM by boberito

You might be onto something. It looks like it's failing on machines that are 10.12.3 or lower. It's cached perfectly on 10.12.4 and up machines. Instead of re-pushing the package I think I'll just force these machines to update.

Like
SOLVED Posted: 1/13/18 at 7:15 PM by boberito

Confirmed it. I updated a machine to 10.12.6 and it worked perfectly. So ya, something in 10.12.4 makes it work.

Like
SOLVED Posted: 1/13/18 at 11:19 PM by chris.kemp

10.12.4 was when they introduced APFS capabilities.

Like