Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

NetSUS 4.2.1 configuration problems


I'm having some issue to setup a local netsus server and get my clients to update from there, and update only what I have "approved"...

We have a very simple setup of Netsus OVA version, which was used to host a netinstall image so far.
I wanted to utalize the SUS part of the server so I have configured a branch "highSierra" and set it as root, and did a manual sync. (It has synced 149Gig). I can see the packages in the branch details, I can select whatever I want and save it.
The clients have no internet access, but via proxy wich requires user auth.
I set the
sudo softwareupdate --set-catalog "http://netsus.localdomain/content/catalogs/index_highSierra.sucatalog"

sudo softwareupdate -l

Software Update Tool

Finding available software
Can’t connect to the Software Update server (netsus.localdomain), because you are not connected to the Internet.

The client can resolve the domain name for netsus just fine, also paste the catalog path into a browser on the client will show me the XML file content.
But I have noticed inside that xml file all entry points to
rather than to my netsus server.. I have tried manually edit this file on the server, but still the same result... Also strange the connection error comes instantly in no time.. doesn't seems to wait for any fail over time or something...
I the netsus settings I don't see any special thing apart from the "Ensure that computers install software updates from the NetBoot/SUS/LDAP Proxy server instead of downloading and installing them from Apple's software update server" setting which was orinigally ticked but I have tried on on/off state and try to add/remove other packages in the branch... but no effect... I have creted new branches, they does the same.. all the content folder accessible and readable from the client...if I replace the apple server address to my netsus server, in a browser it offers me to download the package...

Could you help me what am I doing wrong?

The main goal in here, we have an installer image which has some built in programs and settings for 13.1 but I have found some problems so I wanted to update them to 13.2 as it seems to solve my problem, and also would be nice to enstablish an update path. I couldn't manage to replicate the netinstaller settings to match the existing 13.1 (but this is a different story)....


Like Comment
Order by:
SOLVED Posted: by MacSysAdmin

Have you create the redirection rules?

SOLVED Posted: by tamaspataki


I've seen in some topics there was a mention of redirection, but I wasn't sure what exactly they mean?
Should I redirect the DNS?


SOLVED Posted: by itupshot

I'm having an issue where it's not keeping the network settings.

When I type in the IP address and network mask, and click "Save," it appends a 192.168.x.x address to the IP address, and the Netmask field reads: "scripts/ line 28: 2424/8: syntax error in expression (error token is"

The message is truncated at "is" so I don't know what the full error is.

When I try to upload a boot image using the button in the Netboot Server area, I get:

Anyway, does anyone know how I can make it keep only the stuff I typed in?

EDIT May 3, 2018: I was able to fix this. The software installs a virtual bridge in /etc/sysconfig/network-scripts/ that I needed to disable. Once I did that and rebooted, the network was fine, and I was able to get Netboot to work.