Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Why is my VPP "Content not available to assign to mobile devices"?

Dear Experts,

I 'bought' some licenses of a free app via VPP. I made sure the app is 'device-assignable'. I added the app to the Mobile Device Apps, I have set it to 'Install automatically'. But in the VPP pane it always tells me "Content not available to assign to mobile devices".

I have made sure there is no user assignment for this app, 'Site' is set to 'None', so what else might make this content unavailable for device assignment?

I also tried to assign it to a device in scope, but the result is that the user is asked to sign in to iTunes for the installation - this is exactly what I want to avoid.

Any hints are welcome.

Like Comment
Order by:
SOLVED Posted: by Chotipradit

Hi mschroder,

Do you have your VPP account and token associated with your JAMF instance?

Like
SOLVED Posted: by nvandam

Do you have more than one VPP account? I just did this today and couldn't figure out why I wasn't seeing the licenses show up as assignable. "Bought" them on the wrong account...

Like
SOLVED Posted: by mbracco

We see the same behaviour, but have only one VPP account. Not sure if the apps are device-assignable .... maybe only user-assignable ?
i asked support and wait for answer... in our case Microsoft Word, Excel, ....

Like
SOLVED Posted: by mschroder

Thanks for all the feedback. We only use one VPP account, and it is associated to the JSS instance in question. I do see the correct number of licenses in the JSS. I just can not assign them to devices.

Like
SOLVED Posted: by Macsburg

Make sure you VPP is not set to a site, this will cause any app that isn't assigned to that site to give this message.

Like
SOLVED Posted: by jamesandre

I think the VPP and Apps need to match. If your VPP is set to a site, then set each App to the same site. If your VPP is not set to a site, then don't set your Apps to a site.

Like
SOLVED Posted: by mschroder

The VPP is set to to site None, whereas the apps are all set to a site. I will need to do a bit more reading here. What is the recommendation: use one VPP and have all apps in site None (is that possible at all?), or use one VPP instance per site?

Like
SOLVED Posted: by tommrkr

i had a brief freakout with a similar issue yesterday. As I was creating the Mobile Device App in JAMF, I'd click the VPP tab and get the same "Content not available to assign to mobile devices" error. However, when I saved the Mobile Device App, and re-opened it to edit, the VPP content info appeared.

So for me, the workflow become create app in jamf, save, then re-open to scope and add vpp content.

Like
SOLVED Posted: by orlando.cantu

tommrkr, I shared the same experience. I almost feel as if I didn't give enough time for Apple to communicate with jamf.

Like
SOLVED Posted: by mschroder

I am coming back to this old thread since I made a new observation today. I have been buying a bunch of more apps, and there where again two for which I could not do a device assignment, despite the fact the were marked as device assignable. And in fact these two apps where in a Site other than 'None'. Changing that back to 'None' made these two apps device assignable. But what is really strange is this: three of the five apps for which the assignment worked from the beginning are assigned to a 'Site' other than 'None'.

Conclusion: the behaviour is not consistent, some apps can be in a 'Site' and still be device assigned, others can not.

In any case toggling the 'Site' can change whether or not an app can be device assigned.

Like
SOLVED Posted: by afej

Noticed the same here. My experience: The VPP account I have been using is also in ASM. Which it has always been without issue until today. However I noticed that I needed a "server token" shown at the bottom of the(https://school.apple.com/#main/settings/appsandbooks) Screen. I downloaded the server token and uploaded it in the JSS > Settings>Global Management> VPP Accounts> Server ASM account (no Apple ID). I then went to VPP Device assignment and was able to select the Server ASM account. Seems Apple is making changes with regards to ASM/JAMF integration and we are seeing the initial signs.

Like