Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Macs getting stuck in boot loop

Hello Everyone,

Sporadically, we are seeing some of our Macs getting stuck in a boot loop. This manifests itself after the Mac has run some OS updates. In the latest case, the updates appear to be the security update 2018-001, iTunes, Safari updates. I have seen this before and I just don't understand what is causing this.

In all cases, disk utility doesn't find a problem. Reinstalling the OS doesn't remedy it either.

The only way we can recover from this is to wipe the drive and image it over.

Anyone else seeing this? If you have, do you have a fix or something else I can try? Very frustrating to have this occur and we have to backup the drive, wipe the internal drive, install the OS, applications and settings and recover from the backup.

Seems like something is amiss, I just don't know what it is.

Like Comment
Order by:
SOLVED Posted: by jwojda

have you looked at this?

Like
SOLVED Posted: by howie_isaacks

How are these Macs getting their software updates? It sounds like the update packages are getting corrupted. It's likely that the security update is the issue since iTunes and Safari don't require a reboot. I recently had a user with this problem. I booted her Mac off of an external boot drive, and I was able to go into the internal hard drive and remove the offending update files. After that, the system booted up normally.

Like
SOLVED Posted: by mconners

Thank you for the quick responses @jwojda and @howie_isaacks. I do believe it is the security update.

As for us, we are simply issuing a command, software update -i -a and this has worked flawlessly in the past. I have not had any success with re-installing the OS. In all of our cases, we had to backup, reimage and restore to get the Mac back to booting.

Let me ask. We use a firmware password on all of our Macs. I wonder if this could be interfering in some way, doubtful, just curious if you are using firmware passwords too? We also have Avast installed. Perhaps Avast is interfering with things?

Like
SOLVED Posted: by mconners

Hey @howie_isaacks when you mentioned, remove the offending files, how would you find those files? What folder would I look into for these? I believe it was the security update that did it, but I want to make sure where I would look for those files. Thanks again!!

Like
SOLVED Posted: by Look

We have had a few machines get stuck in an update loop.
The fix was to hold option on boot and manually select the boot drive again while holding control to set it as default (they were endlessly booting of an update image file, failing to update and rebooting of the image file again).
Re-applying the update afterwards worked fine as well so no idea as to the original cause, this was particularly bad with the 10.13.2 supplemental update.

Like