Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Self Service (iOS) Asking for iTunes Login

I'm getting very close to a true zero-touch deployment solution for our iPads, and I'm hoping the community can pull me across the finish line on a strange issue I'm having with managed apps.

My test iPad enrolls via DEP/Prestage Enrollment fine, but the ensuing automatic install of the Self Service app is asking for iTunes credentials (I'd like this to not happen). In what might be a related issue, VPP apps set to "make app managed when possible" are not doing so, despite this option being enabled.

Getting this working would be a great to have for an upcoming hardware refresh, and I appreciate all the help in advance.

Like Comment
Order by:
SOLVED Posted: by ejculpepper

@ardrake In your Jamf console, under Settings --> Device Management --> Self Service, do you have it set to install automatically?

If so, you may try setting it to "Neither (Manual Installation)", then purchasing licenses for the Self Service app through your VPP portal and deploying it like a VPP app. This is how we were advised to handle deploying the Self Service app in a device-based deployment.

Like
SOLVED Posted: by ardrake

That was the last thing I tried. The app installed, but only get "The required managed settings were not received from the server".

Follow-up search for that on JN came up with an article from 2015 that looks like something that should be more... polished by now! :)

https://www.jamf.com/jamf-nation/articles/370/manually-deploying-jamf-self-service-for-ios

That worked, so I think we're almost there. The pre-installed apps (iWorks, iTunes U, etc.) are still showing as "Unmanaged" so it looks like I have some work to do with that, but this is a good step in the right direction. Many thanks!

Like
SOLVED Posted: by johnstone

Those pre-installed apps were a nightmare. We thought we had everything AppleID free.... Then had to remove config profiles for all students and delete those apps then re-lock down (Did not allow to delete apps). I ended up just wiping all the excess iPads to prevent this from the future. The iPads I tested out deployments with were wiped a few times so I never caught this with the students iPads.

Like
SOLVED Posted: by memurrayedu

@ardrake any luck with this since? We appear to be encountering similar issues after our migration to our cloud instance...

Like
SOLVED Posted: by Thomaswoos

@ardrake did u manage? I have the same problem unfortunately. If you find any info could you let me know?
Thanks

Like
SOLVED Posted: by ben.hertenstein

@Thomaswoos @memurrayedu Either of you get this figured out? My issue also crept up after a migration to the cloud. I did get self service to install once using the manual method her https://www.jamf.com/jamf-nation/articles/370/manually-deploying-jamf-self-service-for-ios.

However since wiping that device I have yet to get self service to reinstall again like I did the first time. Although the pop up did go away about needing to log into an itunes account.

Update: Was able to get it to install again and again. Added the app to the 'Mobile Device Apps' after getting several licenses from VPP for the Jamf Self Service App using the directions from the manual method. Then went back to the iOS self service in settings and changed the install method to automatically. I have wiped the device several times now and the self service app installs. Catch is its not the self service app from the 'Mobile Device Apps' page, but the one from the settings pages. It is like the two work together to make the issue of signing into itunes go away. It works so I'm happy. Hope you got your figured out. This post made me feel better about what I did.

Like
SOLVED Posted: by Krbonus

Good day fellow JAMF people! We're in the process of migration as well but I'm worried about those iPads that accepted VPP invitation in the past. Will this cause the iTunes account sign in to show up?

Like
SOLVED Posted: by jeffrey.lennon

i have the same issue of jss asking for itunes login to install self service. i followed the solution above but this hasnt worked for any new ipads that have yet to install self service, but now we have both the self service webclip and self service app on existing ipads, so i will need to undo this as it has not solved the problem. i have logged it as a support call

Like
SOLVED Posted: by christina_luis

Do you have the app configuration part filled out? Our Self - Service auto installs on ALL of our iPads. It is set to all mobile devices. But we had to put some code into the app configuration. We do not get prompted for am iTunes login.

Like
SOLVED Posted: by mfalk

@christina_luis What type of code is in the App Configuration section?

I assume it's bypassing the App Store sign-in or signing in for you?

Like
SOLVED Posted: by jeffrey.lennon

@christina_luis & @mfalk yes i have added the configuration as per the link below. im still dealing with jamf support on this. there are so many different threads with this same issue but none seem to be resolved

https://www.jamf.com/jamf-nation/articles/370/manually-deploying-jamf-self-service-for-ios

Like
SOLVED Posted: by RLR

Suddenly started getting this issue after deploying iPads and apps for several years. We're having to swap out a lot of iPads due to the lease ending. We started off with staff which went fine. The following week we started students and now everyone keeps getting asked to sign into their Apple ID after each app installation from Self Service. You can click cancel and use the app but it's frustrating for the user to do this withe every app they install from self service.

This is affecting all new devices. We've been deploying self service via the app catalogue for a couple years now so I don't think this is the issue. All our apps in the app catalogue have licenses spare so can't see it being a license issue. It's odd the message appears after an app has finished installing from Self Service. I could understand the message appearing if there was a pending app waiting to be installed which wasn't scoped via device licenses.

Edit: I updated the test iPad to 12.3.1 (currently the latest IOS) and it seems to have resolved the issue. I don't understand why the IOS version would matter for device licenses? The device was on 12.2 before the update so not a big difference.

Like