Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. If you like what you see, join us in person at the ninth annual Jamf Nation User Conference (JNUC) this October for three days of learning, laughter and IT love.

Jamf Pro 10.3.1 Maintenance Release Now Available

A maintenance release of Jamf Pro is now available. Jamf Pro 10.3.1 fixes an issue that caused mobile devices to remain in a failed MDM loop when using the Jamf Pro "Update iOS Version" remote command to push iOS 11.3 updates to devices due to changes with the MDM Software Update workflow. Any devices in a failed loop state will have their MDM communication restored after upgrading to Jamf Pro 10.3.1 or later.

You can download updated installers from Jamf Nation in the "My Assets" section. Cloud instances will be upgraded starting April 13th to the 14th, depending on your hosted region. A separate email details when your instance will be upgraded. If you have any questions about this release, or anything else, please do not hesitate to reach out. For more information about Jamf Pro 10.3.1, please review the release notes.

Like Comment
Order by:
SOLVED Posted: by bpavlov

Not asking on my behalf, but I figured others are going to ask. Is there going to be a patch for customers on v9.101? An official answer would probably be appreciated by customers.

I'm going to guess the answer is no. I'm perfectly fine with that since we're on v10 already and it makes less sense to dedicate software engineering resources to backtrack changes to a previous version of a product.

Like
SOLVED Posted: by jwojda

and the special characters bug for imaging is not addressed either?

Like
SOLVED Posted: by jwojda

I saw that it wasn't listed, I was asking again for formal clarification.

Like
SOLVED Posted: by dukedan

We really would like to know if the Imaging issue (authentication / invitation) is fixed. This is really a significant problem.

Dan

Like
SOLVED Posted: by Kmartin

Considering imaging is a major component of the software that is broken, I sure hope it was fixed and not JUST an IOS issue.

Like
SOLVED Posted: by boberito

Awesome to hear I'm not alone with imaging being broken and finding that excruciatingly annoying.

Like
SOLVED Posted: by mojo21221

I haven't tested 10.3.1 yet to see if imaging has been fixed. But my current work around for 10.3 is to make a standard account with a password that is only characters and numbers. Then share that to the team doing imaging for a temporary workaround.

example username = imaging
example password = 1234qwer

Like
SOLVED Posted: by nstrauss
Not asking on my behalf, but I figured others are going to ask. Is there going to be a patch for customers on v9.101? An official answer would probably be appreciated by customers.

@bpavlov No. Jamf has made it clear to me they will not be doing further development work on version 9. I've been through denial, anger, bargaining, depression, and, finally, acceptance. We're updating to Jamf Pro 10.3.1 this Thursday for better or worse. Initial testing has been positive. Fingers crossed!

Like
SOLVED Posted: by egill

@mojo21221 That is what we did for a work around as well. It works, but it certainly isn't the best solution. I was really hoping that the update would fix the issue.

Like
SOLVED Posted: by rcorbin

We are still running 10.2.2. Will be interested to hear from anyone running 10.3.1 to see how well it works for them. It sounds like the imaging thing can be worked around with an imaging password with no special characters. I'm not sure I've heard about any other issues.

Like
SOLVED Posted: by d_koleg2217

Looks like I am not the only one with Imaging "invitation" issues. I hope it will be fixed soon.

Like
SOLVED Posted: by gabe2385


Just updated this morning on our development server to 10.3.1 and as you can see the Jamf Imaging issue has not been resolved for. I Also noticed when opening the Jamf Imaging app and when it goes into the authenticate box to the Jamf Pro Server, the username and password boxes don't show the cursor, you can type but then when you tab it doesn't go to the next line you actually have to click on the password box to go to the next one. I only saw it on Jamf Imaging the other apps seems fine. I tried it on multiple machines etc. etc. Still up in the air if we are going to update and do the work around of creating a standard user for imaging.

Like
SOLVED Posted: by edgardeveij

I tried to download the latest version. Somehow I keep getting 10.3.0-t1521825567 instead of the announced version. Tried the root.war file in the Apple installer and the root.war file from the manual install.

I'm puzzled?!

edit: After some backtracking: I did download the latest version and that is the 10.3.1 version. In my installation environment I forgot to update the version number so the old warfile got installed. No panic, all's well :-)

Like
SOLVED Posted: by chris.miller

Thanks for the update. Facing this issue currently.

Like
SOLVED Posted: by chris.miller

My db server has been blowing up ever since running this update. Normally, CPU is around 4% - 10% and InnoDB hovers around 60%. It's been pushing data all night. Have a ticket in but wondering if anyone else has seen this?

- Nothing else in the environment appears to have changed. My environment variables for Tomcat appear to be untouched.

Like
SOLVED Posted: by kmorrow

Sorry I'm a newbie, what does it mean to remain in a failed MDM loop?

Like
SOLVED Posted: by maclabsadmin

@kmorrow Basically, the iOS devices trapped in the loop wouldn't/couldn't report inventory back to the JSS. So, if the JSS (the MDM), can't read-out the devices' state it can't manage it. If the device can't/won't report it's state, it can't be managed - in so far as new MDM commands are issued. ...the device just loops on it's last executed command and is "stuck" until the report of it's state is sent/received.

Like
SOLVED Posted: by lashomb

@gabe2385 On that dev server if you run 'truncate enrollment_inviations;' on the jamfsoftware db, and the restart Tomcat, do you see the same error? With backups if you need them before of course.

I ask because when I upgrade to 10.3, mine fails due to failure to migrate enrollment invitations. The workaround in support was to truncate that table. Just tested imaging in my dev instance, and it works fine.

Like
SOLVED Posted: by lashomb

@chris.miller I definitely noticed 10.3.1 being slower than 10.3 in my testing. Are you seeing that in an upgrade from 10.3 to 10.3.1? Or from an earlier version than that?

Like
SOLVED Posted: by rcorbin

@chris.miller Did you get a response to your ticket ? I was thinking of updating but your post isn't instilling me with confidence.

Like
SOLVED Posted: by gabe2385

@lashomb , I tried to run the 'truncate table enrollment_invitations;' command and it did not work for me. Maybe I will reach out to support next week and they have something else up there selves.

Like
SOLVED Posted: by mkosigi

@gabe2385
if username or password contains any special characters you will receive that error.

Like
SOLVED Posted: by lashomb

@gabe2385 We are seeing this too now unfortunately. We're just working around it using local account for imaging.

Like
SOLVED Posted: by wesley.bresson

@chris.miller What are you using to monitor in that screenshot?

Like
SOLVED Posted: by RCoS

I've had some major problems with 10.3.1 composer, I cannot delete sources or even folders within sources. I get a pop up saying do I want to delete folder but clicking Cancel or Delete does nothing and I need to force quit.

Anyone in a similar boat?

Like
SOLVED Posted: by tjhall

I've been having major issues since the 10.3.1 upgrade. Camera's now working due to a name change in security config, Imaging not working due to LDAP password policy and can't delete items in Composer.
Desperate for the 10.4 update and not sure if I'm alone with the issues I'm having with 10.3.1 but it's not good.

Like
SOLVED Posted: by erich.proudfit

Updated to 10.3.1.

Issues: The mac camera is disabled via Privacy & Security configuration profile (Where it is NOT defined)
Had to create a whole Restrictions configuration profile to enable the camera. When looking at the
Restrictions device profile (in system preferences -> profiles) it has not reference to the camera.

This needs to be remediated immediately. I should not have to create a separate Restrictions profile
just to enable the camera.

Like
SOLVED Posted: by ssrussell

Hey @erich.proudfit part of the method for creating deployable configuration profiles @mm2270 created has you download the profile created by the JSS and converting it to a readable format. Chances are the jamfPro server is including a Restrictions payload. You can confirm that by following these instructions: https://www.jamf.com/jamf-nation/discussions/23349/can-you-package-a-configuration-profile#responseChild141447 I'd be interested to see what you find. Thanks.

Like
SOLVED Posted: by chris.hansen

@RCoS Composer won't edit? Check if you have any external volumes mounted and dismount them.

I found that tip at https://www.jamf.com/jamf-nation/discussions/27363/composer-10-2-1-not-working

Like