Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Imaging with ASR in High Sierra 10.13.4 - Something changed!!!

What's up everybody!

Ever since High Sierras inception, we've been imaging using the following commands in Terminal. And its been working great for us! To create the image we would use:

hdiutil create -srcdevice disk2 -format UDZO /Volumes/ExternalDiskNameHere/ImageNameHere.dmg

and to restore the image if not scanned, we would use:

asr restore --source /Volumes/ExternalDiskNameHere/ImageNameHere.dmg --target /dev/disk2 --erase --noverify

And if the image was scanned:

asr restore --source /Volumes/ExternalDiskNameHere/ImageNameHere.dmg --target /dev/disk2 –erase

Now that 10.13.4 was released, the hdiutil command to create the .dmg still works, but the asr restore command does not. When we try to restore with ASR, we get:

Couldn't find container disk for Image "image .dmg path" on the external drive, and Couldn't attach source image "image path to .dmg". Could not validate source - Invalid Argument

We've searched high and low with no avail. Anyone familiar with ASR and can maybe help us out? What the heck changed that we can't image like this anymore?!?! Thanks a bunch!

Like Comment
Order by:
SOLVED Posted: 4/14/18 at 10:09 PM by Nix4Life

Still works for me. This was on the 3/29 release of 10.13.4. I have not tried the 4/5 release of 10.13.4 . Same command but over http:
'asr restore --source http://192.168.0.1:8080/restore/10.13.4.apfs.dmg --target /dev/disk0s2 –erase '. However I am really starting to like Google's restor. This is mainly for redeloying hardware. For new hardware its bootstrappr and quickadd.pkg or munki bootstrap/firstboot.pkg

Like
SOLVED Posted: 4/15/18 at 10:11 AM by monaronyc

@Nix4Life Thanks man! Could it be the way the .dmg is maybe being created? I have the string pointing to disk2:

hdiutil create -srcdevice disk2 -format UDZO /Volumes/ExternalDiskNameHere/ImageNameHere.dmg

Yet when we run the ASR string we get:

Validating target... done
Validating source...
Couldn't find container disk for image "/Volumes/Untitled/10134.dmg"
Couldn't attach source image "/Volumes/Untitled/10134.dmg"
Could not validate source - Invalid Argument

Strange?!?

Like
SOLVED Posted: 4/15/18 at 12:22 PM by Nix4Life

@monaronyc my apologies, I just realized you were not using AutoDMG. There was a change and it should be reflected in the upcoming AutoDMG release. I am currently working with a pre-release that addresses this issue. One last thing, all devices in the chain are running High Sierra, correct?

Like
SOLVED Posted: 4/15/18 at 8:52 PM by monaronyc

@Nix4Life That's correct. All devices are now High Sierra. 10.13.4 to be exact.

Like
SOLVED Posted: Yesterday at 11:03 PM by j.tanudjaja

@monaronyc we're on the same boat, interested if you managed to get it working??

Like