Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Sophos 9.6.7 Managed by Enterprise Console Installation fails on High Sierra

Hi, I browsed through several forums before posting this. I created a dmg file that contains the Sophos Installer.app & Sophos Installer Components folder.

My policy places the dmg at to /private/tmp/Sophos.
Then a script runs to install it:
/private/tmp/Sophos/Sophos\ Installer.app/Contents/MacOS/tools/InstallationDeployer --install

It would constantly fail on High Sierra. I came across the article regarding how Deploy Studio changes the permissions on the Library folder, so I fixed that by added a script to fix the permissions at the end of my workflow.

That works fine.

I also have a Configuration Profile which allows Sophos as an allowed Approved Kernel Extension.

Everything seemed fine until Sophos 9.6.7.

Now after all of that it fails with:
Error writing: (/usr/local/bin/SophosUpdate) "The file SophosUpdate couldnt be saved in the folder "bin"."

I even tried adding these lines to my install script:
sudo chmod a+x /private/tmp/Sophos/Sophos\ Installer.app/Contents/MacOS/Installer
sudo chmod a+x /private/tmp/Sophos/Sophos\ Installer.app/Contents/MacOS/tools/InstallationDeployer

which I saw in an article 120570 relating to Sophos Central.

Nothing seems to work. Should I pre-create the folder it is looking for? Has anyone else encountered this?

Thanks

Mark

Like Comment
Order by:
SOLVED Posted: by asegura

@msnowdon I'm running into the same issue. If anybody has a fix would love to hear it.

Like
SOLVED Posted: by msnowdon

Still having this issue. I even recreated the package but it always fails with: Error writing: (/usr/local/bin/SophosUpdate) "The file SophosUpdate couldnt be saved in the folder "bin"."

Like

Jamf wants to hear your feedback around Peripherals and Jamf Connect settings configuration