Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

How do I remove pre-installed iOS apps in favor of VPP versions?

How do I remove the pre-installed iOS apps (like GarageBand, iMovie, Pages, etc) in favor of the VPP versions? Checking the box to make the app "managed if currently installed as unmanaged" doesn't seem to work.

I know I can remote wipe the device and reapply the payloads, but I don't want to have to touch all the devices again.

Like Comment
Order by:
SOLVED Posted: by Hugonaut

Misread post---! wipe the device!

Like
SOLVED Posted: by Laurent.Garinot

Unfortunately Apple has to use an Apple ID for its pre-installed Apps. the only way is to remove these apps and push them through the MDM. If possible the wipe is effective

Like
SOLVED Posted: by acalomeni

How do I upload an appropriate script to the device? Sorry, still learning about this...

Like
SOLVED Posted: by jyergatian

We erase all content and settings, or update/restore using configurator before each new deployment to ensure the pre-installed apps are removed. If you've already distributed the devices, you have two options:

  1. Remote wipe each device. You can do this in bulk via the action button, in bulk via the API, or individually within each devices inventory.
  2. Ask the user to manually delete each app

Once the above is done, the VPP licenses will deploy. Before attempting point 1, make sure you have DEP and a Prestage setup for automatic re-enrollment.

Like
SOLVED Posted: by galionschools

We did #2 on @jyergatian list with our recent deployment which contained fresh out of the box 6th gen iPads. We listed the apps out they had to delete and they were reinstalled either automatically or via Self Service. I did go the extra step with one of our younger grades by restoring them in bulk using Configurator just to avoid any unnecessary screen tapping.

Like
SOLVED Posted: by joshjohnson

Would reinstalling through the Self Service App work instead of wiping the device? Anyone tried this?

Like
SOLVED Posted: by Sandy

As I understand it, the "managed if currently installed as unmanaged" works,
but is broken in some operating systems and/or jamf versions. iOS 11.3, the version my new iPads shipped with....broken.
I had "planned" on it working... DOH

If that box being checked is not working for you, the only fix for devices not using Apple IDs is to delete the apps and re-add them from jamf.
trying to install over the top will not work, and if you have them scoped but also installed from the factory, you may also be seeing tons of looping install attempts/fails that may be dragging your jamf server down...

I currently am holding back iOS 12 and am not yet at jamf Pro 10.7x , so I am stuck for the time being with this issue.
Thankfully it is only two grade levels that got new iPads AND don't use Apple IDs so it is not a huge deal here...yet

Like
SOLVED Posted: by jared_f

Just curious why you guys prefer using VPP for these apps? Even if the apps are already installed, I believe if you “re-push” the app it will become managed.

Like
SOLVED Posted: by jamf_sam

@Sandy - I believe you are correct. I just tested this feature with iOS 12 and Jamf 10.7 and I was able to ‘manage’ a stock installed app. I did have to upgrade my devices from iOS 11 but can verify that once I was on iOS 12, it worked.

Like
SOLVED Posted: by Malcolm

force the app to be managed, give it a few weeks for all the devices to check in to get this setting, and then remove the associated smart group.

Like
SOLVED Posted: by galionschools

@jared_f The pre-installed versions aren't fully baked and require an Apple ID to use. It's sort of like the app store adoption of the Apple apps on macOS. You may ask why they didn't just sign into an Apple ID. Well we haven't distributed Managed Apple ID's to our students yet so the Apple ID portion of the setup was skipped. Additionally we have a high turn over rate so allowing students to use personal Apple ID's is a non starter because they never sign out of it if they were to withdraw.

Like
SOLVED Posted: by kfbbt

@Sandy, I haven't seen making them managed fully fix it ever, but in the past you could make them managed, then exclude those same devices from the scope to pull the bs versions, then remove the exclusion to push the fresh good VPP version. This is the least touch method that I've seen, though I haven't tested it for a while.

Like
SOLVED Posted: by Sandy

@kfbbt since I am dead in the water at my current versions, I cannot say. Making them managed in order to remove them and then re-add would be fine.
Currently, the iPads in question are in young learners' hands and so they also cannot delete apps. There is a bit of monkey business needed to remove the restriction profile, delete the apps and re-add the profile. Sounds straightforward except for the ones that do not conform, and there are ALWAYS iPads that do not conform :)

Like
SOLVED Posted: by Tolandese

We are seeing this issue rise again with apps reverting to wanting the AppleID after resolving this 2 years back by doing the install twice on every device. My second report from another school and grade is seeing this on Pages and iMovie. No app updates for them since middle of September. The apps show up in inventory as managed. We just had to purge all of our "make app managed" settings because of the bug.

Like
SOLVED Posted: by christina_luis

We had this issue right after school started. Normally we just unbox, add into jamf and go. But this year for some reason the iLife apps would not manage at all. We ended up hiding them because now that they are in student hands the only way to manage them is to remove them, Which means that 2 of us have to go and physically touch 400 devices to accomplish this. My recommendation, as soon as you get a new shipment of iPads, wipe them first before you do anything. This will allow your vpp versions of the apps to be installed.

The make managed checkbox only causes problems, Jamf had me uncheck them all, and when they saw how many they needed up running a script to turn it off. I now only use it as needed and immediately turn it off.

This whole situation was a learning lesson, and frustrating to say the least.

Like
SOLVED Posted: by antdarlow

We deploy iPads over many sites with different instances and different MDMs. The problem is common across all and as some have mentioned an 'Apple thing'. Short of wiping the device / removing the apps and then re-pushing the only thing that you can hope for is that the current version of the app is new than the one installed on the device.

It seems like this 'update' process does enforce the 'make managed' command but you can't rely on updated apps for every deployment

Like
SOLVED Posted: by tdilossi

Thanks everyone for all of your feedback on this issue! It is good to know I'm not the only one experiencing these issues with the 'make managed' not working. I hope 10.8 fixes our issues!

Like

Jamf wants to hear your feedback around Peripherals and Jamf Connect settings configuration