Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

GlobalProtect Login

I am installing GlobalProtect during our initial imaging process and it installs just fine. However when I try to test it the application never prompts for the login credentials. After I uninstall it and install it manually the login credential window pops up like it should. Anyone have any thoughts on what might be going on? To create the package I just dragged the .pkg housed within the .dmg downloaded from PA website into Jamf Admin. I am wondering if perhaps I need to set some kind of file ownership back to the logged-in user or change the way I create the package but I am really not sure.

Like Comment
Order by:
SOLVED Posted: by jalbert

Probably a little late, but we encountered this as well and it needed to be allowed in Security & Privacy. We created a PPPC to allow this.

Like
SOLVED Posted: by ccsben

From the recent testing, I think GlobalProtect credential is stored in keychain as the application password login. However the account name is recorded as "login". The actual username is recorded in the com.paloaltonetworks.GlobalProtect.plist file under ~/Library/Preferences. There is also a com.paloaltonetworks.GlobalProtect.settings.plist file, in which under the Setting/portal, the attribute DisplayWelcome can be configured to disable the welcome popup window.

Like
SOLVED Posted: by bruth85

We got a new version of GP and when i created the package I built it as a DMG and made sure to fill FUT and FUE and everything works as it should now. I just made sure to get rid of all of the non GP stuff from the source package in composer.

Like