Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

NoMAD shares

Hi All,

New to Macs, Jamf and NoMAD.

I have NoMAD up and running on a test machine and all is fine. It's logging in and I can launch the home folder etc. However, I can't get the NoMAD menu shares to work. It looks right to me but something is wrong.

First question, is the HomeMount option necessary if the "Show Home Folder" option is already enabled?

Second, do I need to explicitly define a LocalMount point?

There's only one share I want to include but it's not showing up.

I've tried adding the plist file to ~/Library/Preferences and have also pushed it out as a configuration profile through Jamf. Neither method has worked.

Any help would be appreciated.

Thanks.
d.

Like Comment
Order by:
SOLVED Posted: by PerryK

Personally, we don't specify the HomeMount option in our "menu.nomad.shares" configuration profile and can tick the option for this manually if we anyone wants this functionality. Generally speaking in our environment the AD profile home folder isn't actually all that usable although I am sure many other places will actually want this.

You don't need to specify a LocalMount point.

Otherwise, your file looks ok to me and looks to match the reference plist given here:
https://nomad.menu/help/nomad-shares-menu/

From a terminal run "log stream | grep -i nomad" then click on the NoMAD icon, perhaps this will give some further details.

There are more details on troubleshooting and running in a verbose mode here:
https://nomad.menu/help/troubleshooting-nomad/

It is also worth noting is I'm not a member of "Domain Users" group according to the NoMAD instance I have on my computer so perhaps that is the issue ?

I've been using a group which encompasses everyone in the organisation for shares which are for everyone, rather than using "Domain Users".

Like
SOLVED Posted: by dgard

Thanks, PerryK. It turns out it was the "Domain Users" throwing it off. Once I changed it to another user group, it started working.

Much appreciated.

d.

Like
SOLVED Posted: by PerryK

Great, good to hear you are up and running with it now.

Like
SOLVED Posted: by JoshStephens

Any suggestions for getting the shares to mount to the desktop and/or (preferably and) show up in the Finder sidebar? We want to make the shares as simple to find as possible for all of our users.

Thanks!

Like