Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

FileMaker Pro 17 Advanced packaging

Have anyone has any success of packaging FileMaker Pro with license key?

I've manage to follow https://www.jamf.com/jamf-nation/discussions/28127/managed-installation-of-filemaker-pro-16 but when I push it to a new machine it install as a trial version. The assistant text file has been edited with our volume license key and company name.

Any suggestion?

Like Comment
Order by:
SOLVED Posted: by marktaylor

I followed this and it works perfectly installing via policy or users installing via Self Service.

Once the ARD package is created just drop it into Jamf Admin...

https://fmhelp.filemaker.com/docs/17/en/fmpnisg/index.html#install-filemaker-pro-macos_install-apple-remote-desktop-macos

Like
SOLVED Posted: by bmee

Thank you, it works.

Like
SOLVED Posted: by tcam

Thanks for the link

for me the steps were
download fmp

download ARD deployment script from filemkaer
https://www.filemaker.com/support/product/documentation.html > Filemaker Pro 17 Advanced > Apple Remote Desktop Deployment script for FileMaker Pro

mkdir ~/Desktop/fmp
open ~/Downloads/fms_17.0.2.252.dmg
cp /Volumes/FileMaker\ Pro\ 17\ Advanced/FileMaker\ Pro\ 17\ Advanced.pkg ~/Desktop/fmp/FileMaker\ Pro\ 17\ Advanced.pkg
cp /Volumes/FileMaker\ Pro\ 17\ Advanced/License\ Agreements ~/Desktop/fmp/License\ Agreements
cp /Volumes/FileMaker\ Pro\ 17\ Advanced/Assisted\ Install.txt ~/Desktop/fmp/Assisted\ Install.txt
cp /Volumes/FileMaker\ Pro\ 17\ Advanced/Registration.app ~/Desktop/fmp/Registration.app
Open ~/Desktop/fmp/Assisted\ Install.txt

AI_LICENSE_ACCEPTED=1
AI_USERNAME=(put company name here)
AI_LICENSEKEY=(put SN here)
AI_NONEWDATABASES=0
AI_REGISTRATION=0
AI_SKIPDIALOG=1
AI_DISABLEUPDATENOTIFY=0
AI_DISABLEVERSIONNOTIFY=0
AI_DISABLEPLUGINS=0
AI_DISABLEXDBC=0
AI_DISABLEIWP=0
AI_DISABLEADVANCEDTOOLS=0

save changes

open ~/Downloads/fmp_osx_deployment.zip
chmod +x ~/Downloads/AppleRemoteDesktopDeployment.sh
~/Downloads/AppleRemoteDesktopDeployment.sh ~/Desktop/fmp/

open ~/Desktop/fmp

copy the create pkg to the jss

Like
SOLVED Posted: by jcarr

Our solution was pretty simple. I just built a composer package to deploy the FileMaker package and Assisted Install.txt file to /private/tmp and then used a post install script to run the installer and remove the temporary tidbits.

#!/bin/sh
## postinstall

pathToScript=$0
pathToPackage=$1
targetLocation=$2
targetVolume=$3


/usr/sbin/installer -pkg /private/tmp/FMP17/FileMaker\ Pro\ 17\ Advanced.pkg -target /

rm -fP /private/tmp/FMP17/Assisted\ Install.txt
rm -Rf /private/tmp/FMP17/


exit 0      ## Success
exit 1      ## Failure
Like
SOLVED Posted: by dwaterbury

So I am able to package up the original 17.0.2 version using composer, but having trouble packaging and installing the 17.0.3 and 17.0.4 updates. I tried taking the .pkg and uploading it to JAMF Pro directly as well as using composer snapshots after installing each individually on my MacBook Air. But when it goes to install to the computers it fails. With v16 I believe I was able to just copy the original .pkg from filemaker’s downloads page and it installed fine. I did find I had to install each update (ie. 16.0.3, then 16.0.4, then 16.0.5) for it to work, but was able to put them back to back in the same policy. It wouldn’t work if I just went from 16.0.2 to 16.0.5.

Curious how everyone else has solved this. Thank you!

Like
SOLVED Posted: by dwaterbury

Nevermind. I was successful when I re-attempted to upload the 2 .pkg files directly after downloading them from the FileMaker downloads page for 17.0.3 and 17.0.4. I put each as a separate policy and triggered 1 to install after another. I initially had both packages in the same policy and 17.0.4 must have been running before 17.0.3 finished.

Like

Jamf wants to hear your feedback around Peripherals and Jamf Connect settings configuration