Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Error trying to push a package


We created a snapshot using composer to create a .dmg file to push to the computer using via policy. The policy is set to trigger at recurring check-in, execution frequency is set to ongoing, and we have a smart computer group set to exclude any machine with the installer present or the software already installed on the machine. My team is new to using Jamf so we don't quite know the ins and outs of the system, yet. Any help is appreciated.

Like Comment
Order by:
SOLVED Posted: by kowsar.ahmed

Are you trying to do an in place upgrade via the DMG you deployed?

Like
SOLVED Posted: by tak10

If you need to perform In-place OS upgrade, I would recommend using this: https://github.com/kc9wwh/macOSUpgrade

Like
SOLVED Posted: by asher.wilkinson

We just switched to the script at that URL, which is working out much better for us. The problem we're running into there is that if we aren't running the self-service from the local admin account, the user using their network account gets prompted for admin credentials. We want our users to be able to run the upgrade autonomously. Is there a way to edit the script, or a setting in Jamf to allow this for our users?

Like