Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Furiously frustrated with Jamf. Mojave upgrade issue.

Hi all,

Let me shake my fist to the heavens for a moment: Jamf is an expensive product that touts it's zero day preparedness. When support consists of a series of techs clearly not reading the full details of the information you provided and then referring you to Jamf message boards and githubs as a possible solution (things you already done, "Hey there zero day experts, I know how to read and google, ok guys? Thanks!)

sigh

Here's my issue: we have mac labs, I want to upgrade them to Mojave (in place upgrade, nothing fancy, just good old fashioned upgrade, I don't want end users to have to work about it or deal with it, I want them to come in the next morning and log in and see that they are now on Mojave--nothing crazy, right?)

I used DEP and package and download to get Mojave on the machines. I've used ARD and Jamf Policy to run this command on Macs: /Applications/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --agreetolicense --nointeraction

I also went through the upgrade process manually logged in as an administrator, exact same issue**

The Mac goes through the upgrade process and shows the Mojave desktop with login. The first user to login (whoever they are) sees another black screen come up saying 13 minutes remaining. After that process completes then they can login to Mojave.

This is unacceptable for all the obvious reasons.

I have exchanged 15 messages and had two phone conversations with Jamf support, I've submitted two sets of different logs, and after two weeks I hear back that according to their in-house Mojave expert, this is expected behavior.

I am beyond frustrated, not only that but there have been at least 3 other issues of a simple nature that they either took forever to get back to me on or were simply unable to resolve.

If anyone out there has an answer or a simple way to accomplish upgrading Mojave, please, please let me know. :)

Munki is free and you know what if I need to spend time on message boards and use third party solutions and dig around github for solutions, why am I paying Jamf?????

Like Comment
Order by:
SOLVED Posted: by allanp81

@psherotov I'm faced with the exact same issue and I think the blame lies with Apple, not Jamf.

Like
SOLVED Posted: by lynnaj

I believe this isn't a JAMF issue. Instead it's the way Apple applies this update to machines. I have no idea why this Apple install waits to the first login to complete but I have see this same behavior whether I use JAMF or not to update systems to High Sierra and/or Mojave.

Like
SOLVED Posted: by allanp81

It's a pain in the bum to be honest as to the end user it looks like we don't know what we're doing!

Like
SOLVED Posted: by sshort
The Mac goes through the upgrade process and shows the Mojave desktop with login. The first user to login (whoever they are) sees another black screen come up saying 13 minutes remaining. After that process completes then they can login to Mojave.

I've seen reports of this behavior on the MacAdmins Slack across multiple MDM services (or even without MDM, just double-clicking the macOS Installer from /Applications to run the update). I agree it's frustrating, but Apple needs to resolve this issue.

Like
SOLVED Posted: by psherotov

A colleague of mine who is an admin at an all mac school who is using Munki said he has not seen that issue on any Macs he has upgraded? And if this is an issue originating with Apple, for the purposes of not sticking end users with 13 minutes of downtime, isn't there some auto login script that could be pushed out so the install would finish? I've googled and gone through the message boards here and have not found a solution/work around along those lines.

Like
SOLVED Posted: by allanp81

I would presume part of the issue is that Apple have decided that a user needs to be logged in to initiate the upgrade.

Like
SOLVED Posted: by allanp81
A colleague of mine who is an admin at an all mac school who is using Munki said he has not seen that issue on any Macs he has upgraded? And if this is an issue originating with Apple, for the purposes of not sticking end users with 13 minutes of downtime, isn't there some auto login script that could be pushed out so the install would finish? I've googled and gone through the message boards here and have not found a solution/work around along those lines.

I will put it to the test to see by just installing Sierra/High Sierra from USB and then double click the installer and see what happens.

Like
SOLVED Posted: by lynnaj

You may want to test how this is different on macs with and without SSD drives keeping in mind that only SSD drives are auto-magically formatted to APFS during the upgrade to High Sierra and above. Perhaps the friend that uses Munki and doesn't see this has only HDD drives?

Also you can test rebooting the computer when it's at that first login screen to see if that kicks off the "wait 13 minutes more, please" process.

Like
SOLVED Posted: by Hugonaut

Jamf is not to blame here. Committing 100% to a Free alternatives isn't the answer either. The answer to solve these problems are "JAMF plus All other tools available to use as MacAdmins." ex. Jamf & Munki & etc.

The blame lies with Apple. Quite frankly as much as I love Jamf, Apple should really offer a 1st Party MDM Solution.

Like
SOLVED Posted: by allanp81

@lynnaj All of my Macs I've tested the upgrade process on are SSDs and I see the extra 13 minutes behaviour on all of them.

Like
SOLVED Posted: by lynnaj

@allanp81 --- I too have seen this on all the SSD macs I upgraded last summer from Sierra to High Sierra. However, I have not seen this extra time when taking a mac from High Sierra to Mojave. I wonder, therefore, if the "wait 13 minutes more, please" is the APFS reformat process ???

Like
SOLVED Posted: by mark.mahabir

Here's the original thread on this.

Like
SOLVED Posted: by boberito

I've heard of this when the currently logged in user is not an admin like if they run it through Self Service. But if an admin user runs it through Self Service it works great. So maybe that's a piece of the puzzle.

Like
SOLVED Posted: by kroberts1

@lynnaj i dont think this its the reformatting to APFS. I've had devices which i've install both HDD and SSD formatted as APFS for High Sierra. When i trigger the Mojave update and it reboots im still getting that 13 minutes crap.

Like
SOLVED Posted: by allanp81

@lynnaj You may be right as you can SSH in to a device while the progress bar is shown and the only obvious task doing anything is mdworker I think.

Like
SOLVED Posted: by kroberts1

@boberito i've seen this in threads but that a real stupid way of managing student labs. if i execute this command in a script " /Applications/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --agreetolicense --nointeraction " i'm automatically triggering as root so why would i need to make the current user an admin to trigger an update flawlessly. That's a really poor design by Apple.

Like
SOLVED Posted: by SGill

We have 100's of macs that don't have JAMF on them and we saw this behavior on 10.13 and 10.14 if you attempted to log back in quickly after the upgrade. If you waited a day or so to log back in, the issue was gone, so if you can arrange a bigger window of downtime for your upgrades, it's easier.

Like
SOLVED Posted: by kroberts1

@SGill

idk, i cannot schedule an upgrade today in an organization then tell employees they cannot login until the following day. I believe for now the best way is to auto login with a service account have it complete then disable auto login. But it also surprises me that JAMF does not have a solution for this because every post for upgrades has this issue.

Like
SOLVED Posted: by SGill

I didn't test how little time after the completed upgrade you needed to wait, but it was longer than you might think on most macs. Any attempt to log in within, say, 2 hours of 'upgrade complete' got the additional progress bars on login for sure. I was also using a mass-login to finish them until I realized that all I really had to do (for computer labs at least) was wait.

Like
SOLVED Posted: by psherotov

Just to summarize responses to some of what people have posted so far:

Even manually triggering it logged in with an admin account still causes the same behavior (13 additional minutes). So admin rights doesn't seem to be the issue.

The behavior occurs even on mac that are already formatted APFS--so the conversion doesn't seem to be the issue either.

I am intrigued about there being a period of time that has to elapse before the installation completes after it completes and if end users wait they won't experience the additional installation period.

Circling back to my frustration with Jamf, why don't they have some of this information readily available to mac admins in documentation or via tech support? Zero Day? Mojave has been out how long? 4-5 months? Also, as a work around, a script that automatically logs in a local user?

Thank you everyone for contributing your experiences, I've gotten farther in 30 minutes than I have in two weeks, at least in having some options or possibilities. Keep the information and ideas coming please! :)

Like
SOLVED Posted: by psherotov

I also want to add that my colleague has SSDs and HDD Macs and has not experienced the behavior at all.

Like
SOLVED Posted: by MTFMRCO

Echoing what some others have said.

On a Mac I have at home, saw this exact thing. No MDM component there, just a plain old (2012) laptop. We have also seen it on some devices here when running an in-place upgrade from HS to Mojave through Self Service. On some devices, if we logged in immediately after the final reboot of the upgrade, this happened. If the device sat for 2-3 hours after the upgrade, did not see it. Certainly seemed to be more prevalent on the older devices but all models have done it from time to time.

Like
SOLVED Posted: by psherotov

I'm going to run an upgrade on a Mac and let it sit overnight and see what happens tomorrow morning. Stay tuned :)

Thanks again to everyone who contributed their knowledge and experiences. If anyone has something to add please share!

Like
SOLVED Posted: by kroberts1

Joining you with that as well @psherotov . My test will be on a Fusion drive. This should cover all types of drives we've experience this scenario.

Like
SOLVED Posted: by Captainamerica

I also have seen this, but even it stands a 15 minutes or thereabout it only takes only 3-5 minutes and it is done as the minutes goes Down very fast But Strange apple Cannot get rid of this. I have same issue on clean mac without any Jamf at all installed

Like
SOLVED Posted: by mmcallister

I have also seen this, and speculated it was connected to FileVault as all the machines I've seen the issue on were using FV2. Wild speculation FTW ;)

Like
SOLVED Posted: by john-hsu

I have seen this issue as well - whether it is platter drives or SSDs, and as an administrator. I've seen this issue on both FileVault and non-FileVault systems. The systems I've been testing on are an iMac (Late 2015) w/SSD, an iMac (Late 2012) w/HDD, and a MacBook Pro (Late 2012) w/SSD (FileVaulted). It's a real mixed bag. I blame it on Apple, not jamf.

Like
SOLVED Posted: by allanp81

Interestingly I tried upgrading a laptop from Sierra to Mojave without any Jamf installed on it and it just logged straight in following the upgrade, I wasn't presented with the loading screen upon logging in following the upgrade...

I will do some more tests but based on this single test it appears that it could be a Jamf issue.

Like
SOLVED Posted: by kroberts1

Hey Guys,

Im back with my results. My test bench triggered the upgrade from High Sierra to Mojave at 9pm 3/14/29 last evening and i came into the office and logged in at 9am 3/15/19. This was a 12 hr wait and the results are the same. As i logged in i received the famous 13 minutes to complete progress bar.

Like
SOLVED Posted: by jrwilcox

We are seeing this in our MDM and we are not using JAMF, We think this is an Apple Issue. Its a shame JAMF support is not helping to drive to a solution with Apple.

Like
SOLVED Posted: by boberito

@jrwilcox who says they aren't? Just because they aren't publicly putting it out there behind the scenes they may be raising holy hell.

I wonder if it maybe has something to do with a firmware update or some kind of update being missing?

Stub installer vs Full installer?

Like
SOLVED Posted: by jrwilcox

This thread would be a great place to let us know thy are working on it with Apple. I sure did not see anything like that.

Like
SOLVED Posted: by psherotov

Hi everyone,

I upgraded a computer yesterday around 4PM and today at around 9:15AM when the user logged in for the first time, the screen flash to black for 1-2 seconds and came back to the login screen with the credentials empty, after re-entering their credentials they logged in.

This is a mac that has an SSD and came with High Sierra installed. I used a package of Mojave of the full installer that I made in Composer and under Files and Processes had Run:

/Applications/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --agreetolicense --nointeraction

The 1-2 second screen flash and having to enter credentials twice is a mild annoyance but doesn't have the impact of having the first user to sign in have to wait several minutes.

In addition, my colleague imaged two SSD macs in his environment--one using Munki and one through the manual download and install process. In neither case has he experienced that second installation window after logging in.

My issue with Jamf is that tech support (zero day experts) did not know or offer this solution (waiting a period of time before logging in). Also, since my last email detailing my frustrations with their responses, no one from support has reached out in any way--customer service has not been impressive. To the point of it being an "Apple issue" part of customer service is having timely responses for customers that provide information and work arounds, Jamf charges way too much for such shoddy service. Just letting customers know that you're actively working on it or trying to find out the source of the problem, is better than nothing, or generic links to githubs and threads.

Like
SOLVED Posted: by allanp81

I see various timings, for instance I've just done it and seen it come up with the Apple logo and say 13 minutes remaining but in actuality it probably took closer to 2 minutes. A look at the processes running really doesn't help as it honestly looks like nothing is happening.

Like
SOLVED Posted: by kroberts1

@psherotov

Do you mind sharing your colleague that is using munki for the deployment workflow. I want to understand how they are prepping and what commands they are using to complete the upgrade. Idk how much help this is but it may shed something i believe.

Like
SOLVED Posted: by macmanmk

We have experienced similar problems when upgrading MacBook Airs to High Sierra. The upgrade appears to complete and the user logs in and everything is fine...except the USB Ethernet adapter isn't recognized. Log the user out and log into a management account with admin rights and boom...it shows that an additional 23 minutes is required to install who knows what. After those components installed, the Ethernet adapter started functioning again.

Like
SOLVED Posted: by tnielsen

I agree with OP to a point but it's clear you haven't done enough testing or research. I agree that we pay JAMF to help simplify the tedious scripts and management of Apple products. The gotcha here is that Apple doesn't care about enterprise. They design their upgrade process for home users.

10.12.6 was the last OS that allowed easy management from fruit to nuts. High Sierra started the change to more user intervention due to the Security boogeymen. Now Mojave has taken things way too far imo, so far we discuss not buying Apple products anymore. What are the benefits? OSX? That's not going to be a good reason forever.

OP, you can script give your users admin rights and then run the installer, or have them initiate the installation through self service. Take away the admin rights after the OS has completely the upgrade. My process works, granted I did have to do a bit of work to make it work. About a week of testing. If you need help just call me, 212.251.1211.

Like
SOLVED Posted: by RobbieG

FWIW - I don't bother to try to automatically complete the whole upgrade process using Jamf anymore as every solution to get it "working" since 10.12.x has required more work than it saves in our environment - but every install type I do here - even manually downloading and doing the install sitting at the machine requires a 2nd authentication somewhere between 10 or 15 minutes after the install starts. Basically it always goes get package to machine - initiate install with creds - install runs for awhile - installer asks for creds again.

Like
SOLVED Posted: by jkaigler

I just tested an upgrade from 10.12.6 to 10.14.3, after the reboot I let it set for 30 minutes then logged in. The setup continued with the 13 minutes remaining screen, but finished in 3 minutes.

Like
SOLVED Posted: by psherotov

Hi everyone,

Here's an update: This morning I checked on a teacher computer that I set to upgrade overnight, however, since the computer was asleep it didn't run. After manually running it, it took 34 minutes to complete the upgrade. After logging in I got the same "About 13 minutes remaining" (It only took about 3-4 minutes though, the last few minutes counting down in seconds.) After that it went back to the login screen with the password field empty.

An additional point of concern is that the same process has occurred when doing a within version upgrade 10.14.2 to 10.14.3 (I'm doing some more testing on this and will report back.)

@tnielsen Thanks for offering to help, very nice of you! Over a two week period I tried installing the upgrade through two different packages and policies, through VPP and policy, as standard user doing a manual download and install, and as a local admin user doing a manual download and install. I also tried on HDD, Fusion Drive, and SSD macs. In addition, I googled extensively on the issue, consulted colleagues, search Jamf Nation for discussion threads, and of course called Jamf support and provided them with logs from several different Macs. I feel satisfied with my due diligence :)

Speaking of Jamf support, I do want to add to the record that my account rep called me and we had a really positive discussion and the lead technician emailed me about the support process I had experienced so far. At this point, I am happy with their support and responsiveness. I used to manage a helpdesk and am sensitive to the challenges of offering support and am not quick to complain, I also understand that we are all (hopefully) always looking to learn and grow and do better, myself included.

@kroberts1 My colleague who has not seen this issue at all uses Munki and simply did the following for his upgrade: Munki import and then entered the path to specifying the location to the .app file and made it available through Managed Software Center.

Like
SOLVED Posted: by bramstedtb

Something I've noticed this morning is that the login followed by "X minutes remaining" problem only seems to happen for me when a user was logged in since the last reboot. I have a reboot policy setup to run between 3am and 5am, and then a startup triggered policy to run the update during the same window, and the whole process completed without needing to login. I haven't tested with a High Sierra to Mojave upgrade yet, but in a 10.14.3 to 10.14.4 update, the reboot/startup triggered policies skipped the login issue, but running the update through Self-Service did not.

Edit: The trick didn't work going from 10.13 to 10.14

Like
SOLVED Posted: by allanp81

I've just been experimenting with the 10.14.4 installer and so far not seeing the 2nd progress bar following the upgrade...

Like
SOLVED Posted: by jkaigler

The combo upgrade did not have the second progress bar.

Like
SOLVED Posted: by Neil_Kitt

Is this possibly the difference between Macs that have FileVault enabled and Macs that do not? Maybe the FileVault login screen is preventing the OS from being able to complete the required installs because it is halting the loading and decrypting of the hard drive? Just a thought.

Like
SOLVED Posted: by jkaigler

I do not have filevault enabled on any of my systems that test with and I see the 13 minute progress bar when upgrading from earlier OS

Like
SOLVED Posted: by a.simmons

I'm seeing the second progress bar upgrading from 10.13.6 to 10.14.4. I don't have file vault enabled either.

Like
SOLVED Posted: by s.gaynor

Still seeing this with 10.14.6 upgrades.

Like
SOLVED Posted: by rcsaladin

I didn't read through all the responses for this, just most of them. Not sure if someone already mentioned this, but what I have done as a workaround is:
I create a auto-login user and deploy that with the download of Mojave or high sierra installer dmg. I kick off the install with Startosinstall command and parameters as mentioned above.

Then I have another policy scoped to a smart group "machines with auto login user" With a script that checks to see if the current user logged in is the auto-login user, if it is, it deletes that user then reboots the computer. I set that policy to on-going, frequency is reoccurring check in, scope it to that group as well as limit it to the auto-login user.

This allows the "installation completing: 13 mins remaining" continue with no issue or interaction by a user.

This is just a workaround I have currently to make the in-place upgrade "automated".

Like
SOLVED Posted: by amitpatel

@rcsaladin Cool workaround! Do you mind posting your script or pointing me to your github page? Thanks

Like