Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

32bit Warnings

So it turns out Mojave likes to warn users when they fire up a 32bit application (or a 64bit app that has a 32bit component somewhere inside).
Does anybody know if JAMF can be used to silence these warnings but only for specific applications.
I dont want to advise staff "oh just ignore that" as people will become complacent.
But on the flip side we have a small selection of apps that we know are 32bit but dont need to be telling our end-users about it.

Like Comment
Order by:
SOLVED Posted: by lkrasno
Like
SOLVED Posted: by allanp81

I was using this profile fine until 10.14.4 where I'm not seeing some warnings but not all. For instance on logins I'm getting Adobe warnings (CC suite is installed) but not other things. It was working flawlessly up to and including 10.14.3.

Like
SOLVED Posted: by crbeck

Yeah something changed in 10.14.4, they cranked up the amount of warnings. The only warnings I'm seeing coming through the profile linked above appear to be the 32 bit components, regardless if the app itself is 64 bit. So it's difficult to even know specifically what the software is that is causing the warning to pop. Google Earth appears to be causing one of the warnings I'm getting (forgot what the warning said the name of the software actually was).

Like
SOLVED Posted: by allanp81

Yes I've only seen 1 new popup which is Adobe related, 32 bit apps themselves aren't warning but it's very annoying.

Like
SOLVED Posted: by bearzooka

We tried to implement the Config Profile to avoid the notifications coming from Kaspersky and it's not working on 10.14.4
In fact, it seems that it's not possible to install it as-it-is on 10.14.4

Like
SOLVED Posted: by allanp81

Ok so I'm not the only one then. Apple have clearly changed the preference in 10.14.4 or introduced an annoying bug! It looks like if it's already installed then it's semi-ok but otherwise installing from fresh is broken.

Like
SOLVED Posted: by donmontalvo

@allanp81 yeap, its a different Configuration Profile setting for 10.13.x vs 10.14.x.

From @rtrouton's blog:

10.13

10.14

Like
SOLVED Posted: by allanp81

@donmontalvo Yes I knew that but it seems that 10.14.4 changed something as it was working fine on everything before that.

Like