Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Deploying solstice

Has anybody tried deploying solstice? I've tried the Autopkgr deployments and copying the app from a working machine into composer and every time I deploy to another machine, the icon has a line through it saying it's "Not supported on this type of Mac"

Like Comment
Order by:
SOLVED Posted: by pitcherj

I get the same behavior via autopkg and composer.

Thought it may have been our antivirus messing with it (either in packaging or deployment) but even without it in the picture the issue persists.

Like
SOLVED Posted: by jwojda

I reached out to Mersive today and they provided me a direct download link to the current client version which worked. I went back and asked for a more general link to download for future versions but I haven't heard back yet. Also, don't mention jamf/mdm deployments.

Like
SOLVED Posted: by hdsreid

You have to modify permissions in my experience. Use the stub installer to download the full .app, put it in a custom package to install in /Applications/Solstice.app and have the post install script do a chown to current user and run a chmod -R 755 on it to be safe. This will at least allow any user to read/launch the app, which I have found to be the issue in the past when packaging for deployment. I am not worried too much about the permissions in my environment, as we have one user per computer, and everyone is authorized to use solstice within our environment.

Also......you don't NEED the solstice app in my experience, you can just airplay to connect to the solstice hub...

Like