Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

IP in menu bar package behavior

I install the "IP in menubar" app on our Macs to show the computer name and its IP address in the menubar (https://www.monkeybreadsoftware.de/Software/IPinmenubar.shtml).

For this deployment I use Composer to simply capture the app in the Applications folder, and then build a .pkg.

Here is what is stumping me: If I run that package on another computer with the same user account name as the Mac I created the .pkg in, it functions as expected. However, if I try to install the package on a Mac with a different user account name, the package installs, but behaves differently. Check out the screenshots below:

Install with same user account name as the computer where the .pkg was made with Composer. Notice the desired behavior of no icon in the dock, and how the application icon displays as expected:


-
Next, the install on a Mac with a different user account name. Notice how there is a dock icon now showing (the application is not hidden), and how the application icon itself is a generic default graphic:

-
Please note that the ONLY thing I captured with composer is the IP in menu bar.app file in the Applications folder.

Does anyone have any guesses as to what is causing this behavior? I'd really like to figure it out.

Thanks!

Like Comment
Order by:
SOLVED Posted: by iMatthewCM

Since the username seems to be the catalyst for different behaviors, I'm going to guess something in the package has the original username hardcoded, somewhere, maybe. Would it be possible to see a screenshot of the Composer package just for verification? Also, can you check if there are any pre/post-install scripts?

Like
SOLVED Posted: by mahughe

Why not use the config profile option under the login window payload?

Like
SOLVED Posted: by iMatthewCM

@mahughe That'd just show it when logging in to the computer, once you're logged in it's no longer visible.

Like
SOLVED Posted: by dtmille2

Issue resolved! The permissions within composer were incorrect. They were only giving permission for the user account I was logged into when running composer.

The permissions were this:

I changed them to this:

I then made sure that all files in the app bundle had the same permissions by applying to all.

I'll have to keep an eye on these Composer permissions from now on.

Like
SOLVED Posted: by marklamont

That's a standard issue with composer. If you dragged an app from applications chances are it always has the owner set as the user that installed the app. Use this option to fix easily.

doesn't change the permissions, which should be correct, but does set the owner and group to the correct values

Like