Skip to main content
Jamf Nation, hosted by Jamf, is a dynamic and knowledgeable community of Apple-focused IT admins and Jamf Pro users. Join us in person, in October, for the annual Jamf Nation User Conference (JNUC) to discover new and better ways to manage Apple devices.

OSX Configuration Profiles Opt-In Message

Do we have any way to stop this message from popping up? I don't want users to determine whether they opt-in or not.

Like Comment
CCA Badge JAMFBadge
SOLVED Posted: 2/15/12 at 1:41 PM by ryan.yohnk

Hi Matt,

For the most part OS X config profiles should be transparent to the end user. Do you happen to have a screenshot of the behavior you are seeing? Are you seeing this while deploying profiles through the JSS via the OS X Configuration Profiles section? And is this with all config profiles or just some that you are seeing a dialog be presented to the users?

Thanks,
Ryan

Like
SOLVED Posted: 2/15/12 at 3:50 PM by Matt

It happens at the Loginwindow. It sends a message asking to enroll or not enroll.

Like
CCA Badge CJA Badge
SOLVED Posted: 2/22/12 at 2:27 PM by quedayone

I am getting it as well. It looks like this:

external image link

I am seeing this while deploying profiles through the JSS via the OS X Configuration Profiles section. I only have one Profile. Tested only on one computer so far.

Like
CCA Badge
SOLVED Posted: 6/26/12 at 3:15 PM by AdamH

I'm seeing this behavior as well. But it only shows up for people who are local admins. But I would really love to remove this message!

Like
SOLVED Posted: 6/26/12 at 6:08 PM by gregneagle

In classic MCX, this is a setting in the "com.apple.loginwindow" domain:

"AdminMayDisableMCX" -- if set to false, admin users cannot elect to disable management at login.

I'd imagine you can set this with profiles as well.

Like
CCA Badge CCE Badge
SOLVED Posted: 9/26/12 at 10:30 PM by tkimpton

Or just don't give users admin rights :)

Like
CCA Badge CJA Badge JAMFBadge
SOLVED Posted: 9/27/12 at 1:03 AM by lance.ogletree

If you are receiving the message about disabling management when logging in,
check your Configuration Profiles . The Login Window payload has this option
under the Options tab. See if it's checked off.
You may also want to check if it's configured under Managed Preferences as well.

Like