Skip to main content
Jamf Nation, hosted by Jamf, is a dynamic and knowledgeable community of Apple-focused IT admins and Jamf Pro users. Join us in person, in October, for the annual Jamf Nation User Conference (JNUC) to discover new and better ways to manage Apple devices.

iLife '11 Installer Expired Certificate

Apple's iLife '11 Installer has the same March 23, 2012 certificate expiration problem as the updates downloaded for local SUS. Our iLife '11 policy began failing on March 23. We now see that the Apple Software Installer Update 1.0 released on March 19 (zzz041-4801) must be installed to enable the iLife '11 Installer. The update is for all 10.6.8 users.

Like Comment
CCA Badge CCE Badge CUG Badge Integrator Badge
SOLVED Posted: 4/4/12 at 3:40 PM by bentoms

i've repacked my iLife installer using

This also turns it into a flat pkg, stopping the cert issue.

SOLVED Posted: 4/4/12 at 3:50 PM by awimmer

Thanks, that's a great help. I'll give it a try.

CCA Badge CCE Badge CUG Badge Integrator Badge
SOLVED Posted: 4/4/12 at 3:53 PM by bentoms

Np.. someone else pointed it out to me .. so just spreading the knowledge!

CCA Badge CMA Badge
SOLVED Posted: 4/5/12 at 11:29 AM by cdaley

Hi Guys.

I also found this when I had the same issue.

On offer is 2 python scripts &, which work great and save having to download apple packages again.

CCA Badge CCE Badge CMA Badge CUG Badge
SOLVED Posted: 6/21/12 at 2:49 PM by donmontalvo

Wow, I finally got a chance to try this and the PKG was created in roughly 15 min.

Any gotcha's to deploying this with a fresh 10.7.4 image? The iLife '11 Install DVD is from early 2011.

I presume better practice would be to go with Apple App Store applications (Garage Band, iMovie and iPhoto) and package/deploy those instead? I mean you can't even buy iLife '11 from Apple anymore (just the 3 separate apps).



CCA Badge CCE Badge CJA Badge CMA Badge
SOLVED Posted: 6/21/12 at 3:37 PM by jhbush1973

I used the python script that gives you a repackaged flat file installer. So far that has worked well for us. I left all of the default apps in there as some of our users treat their Macs like their own and make movies, etc... on them.

CCA Badge CCE Badge CMA Badge CUG Badge
SOLVED Posted: 6/21/12 at 8:40 PM by donmontalvo

@rtrouton, @jhbush1973 Thanks, happy the script worked so well, sorry I waited so long to try. :)

I guess my main concern now is whether we really need to be packaging the suite from the disc, since it's no longer sold...or if we should be following the Apple App Store distribution best practices for the 3 applications that constitute the iLife suite?

My guess is packaigng the individual apps would be easier, and distribution would be more legal than distributing a PKG made from a disc that is no longer sold?


SOLVED Posted: 6/21/12 at 8:48 PM by rockpapergoat

for what it's worth, i setup a smart group of machines that should have shipped with ilife '11 or were at least released after a specific date and only allow self service installs for those hosts. anyone else will need to purchase the apps another way.

SOLVED Posted: 6/24/12 at 2:25 PM by Deegle

Could someone please take me by the hand and explain me exactly how to use this python script? I spent so many days looking up for a tutorial and the only one I've found leads me to a "SyntaxError"... This is what I was trying to do:

First you have to take the script and save it as a text document and then change the extension to .py (Python Script). In this case . Save it on your desktop. From there you have to give the script executable permissions by opening up the terminal and running the command: sudo chmod a+x \~/Desktop/ From there it should promt you for your password. Enter it and continue. Now comes time to execute the script. From terminal: sudo python \~/Desktop/ \~/Desktop/iLife11.dmg \~/Desktop/iLife11_fixed.dmg

When I press enter, this error appears:

File "/Users/deegle/Desktop/", line 1 {\rtf1\ansi\ansicpg1252\cocoartf1038\cocoasubrtf360 ^ SyntaxError: unexpected character after line continuation character Macintosh:\~ deegle$

The ^ is pointing to the zero on "...cocoasubrtf360"
What am I doing wrong?

PS: I know almost NOTHING about these scripting, programming, terminal things!

CCT Badge CCA Badge
SOLVED Posted: 6/25/12 at 12:33 AM by karthikeyan.mac


This error is due to formatting added by Text Editors. While pasting a script in textedit in rtf format, extra formatting adds to the document. Script will throw you an error.

User Plain Text option in Text Editor or can try TextWrangler to work on this script...


SOLVED Posted: 6/25/12 at 1:51 AM by Deegle

Thanks A LOT!!!

I needed to finish some portfolio stuff on GarageBand. So, you sir (along with the script creator of course), basically granted me a job interview this week!

Thank you!