Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Location data not updating when reconing macs

Hi All,

Since updating our JSS to the release candidate of8.5 location data is not being updated when reconing macs, we have since upgraded to 8.51 & still we have the issue.

If I run:

sudo jamf recon -realname Ben

On any managed mac, the real name does not get updated in the JSS. JAMF support have confirmed this issue when restoring a backup of my DB.

Anyone else seeing this?

Also, (& possibly related) advanced searches have not worked for us since 8.5.. i have been advised that these will work come 8.52.. but wondering if anyone else on 8.51 is having the issue if they can run the above command & see if it works for them.

TIA!

Like Comment
Order by:
SOLVED Posted: by bentoms

Guess it's just me?

Location data can be manually updated in MySQL, just not through recon.. i.e. running the below will not update the location data on a client.

sudo jamf recon -endUsername loggedInUser -realname userRealname -email userEmail -position userPosition -phone userPhone -department userDepartment
Like
SOLVED Posted: by rlandgraf

We also stumbled on this today! We are trying to find a way to get users to register their computers without running the recon.app. It seems to work with the assetTag verb, but that seems to be the only one that works.

Any ideas on how to do this?

Like
SOLVED Posted: by bentoms

Sadly not, I do have a defect ID for this though: D-002843.

Our JSS is on a Mac 10.7 server, we 1st saw this issue @ 8.5 & am still seeing it @ 8.52.

Please contact support to have them test.

Like
SOLVED Posted: by bentoms

Just heard back from support.. seems to be an issue with our NW segments..

do you have an all encompassing segment?

Like
SOLVED Posted: by bentoms

nvm the above.. it's actually when overriding departments/buildings via network segments.

Like
SOLVED Posted: by bentoms

received this update last night from JAMF support:

So the defect \# has changed to D-002867 as a couple more have seen it and another support specialist documented how to get it to "break" from scratch. So, keep an eye out for that in release notes.
Like
SOLVED Posted: by ClassicII

any update on this ?

From what you guys are saying you can not manually update the info with recon. Is that true? Or is this still a defect in 8.52

Like
SOLVED Posted: by jescala

We're also having this problem. Is an interim fix available or do we need to wait for the next release?

Like