Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.
15

NetBoot appliance - Kernel Panic

Posted: 9/3/12 at 12:24 PM by georgecm12

I just got the NetBoot appliance up and running. Everything looks good from the appliance side of things; subnets are setup right, the image is uploaded (and named without a space in it), but I'm getting a kernel panic every time I try and boot a Mac from the server.

Any ideas?

15
CCT Badge CCA Badge CJA Badge CMA Badge

Posted: 9/3/12 at 2:19 PM by talkingmoose

Is your NetBoot image compatible with the hardware you're trying to boot?

Newer machines such as the MacBook laptops often ship with an OS version that's unique to their hardware. Until Apple releases a cumulative update such as Mac OS X 10.7.5 or higher then you'll need to create your NetBoot image using the OS that ships with the machine.

Posted: 9/3/12 at 5:50 PM by georgecm12

Yes. Sorry, I meant to include that. The disk image was created on the very machine I then tried to netboot. The OS is 10.7.4, fully updated, and it is intended to boot our fleet of iMac11,2 (Mid 2010) machines.

I saw a reference to someone who had a similar issue with the appliance, but theirs was an option being set on their Linux-based DHCP server that they had to comment out of the dhcpd.conf file. We're running a Windows 2008 r2 DHCP server, I believe, so that doesn't seem to apply here.

CCA Badge CCE Badge CMA Badge

Posted: 11/12/12 at 10:50 AM by Mike_Meyers

This is just something to check, but I saw this on a new NetBoot I had created to point to a Snow Leopard server. I used to run the HTTP service on my server and had the old 10.6.8 NetBoot working. The new one was working until I turned off HTTP. By default, any new NBI added to the Snow Leopard server is configured to use HTTP. I got a kernal panic when trying to use the new NetBoot. I thought it was my NBI, so I recreated it. That was the point when I noticed that my working one was configured for NFS instead of HTTP. I set the new one to NFS and it works fine.

Now, I'm just having an issue imaging more that 3 Macs at a time.

Posted: 5/15/13 at 4:10 PM by georgecm12

Whoah! Really old thread bump!

I finally had a chance to get back to playing around with this. I'm still getting kernel panics, but I have additional information.

Mike_Meyers, the image should be an NFS image, not HTTP, but thanks for your suggestion.

To troubleshoot the issue, I'm tailing /var/log/syslog on the server as I boot a client machine. It looks like at the very moment the client machine panics, I see the log entry:
May 15 15:12:11 NetSUS mountd[769]: authenticated mount request from <IP>:1023 for /srv/NetBoot/NetBootSP0 (/srv/NetBoot/NetBootSP0)

Any further thoughts as to what would cause the client machines to panic when it attempts to do the NFS mount?

SOLVED Posted: 5/15/13 at 8:48 PM by georgecm12

And finally I have an answer: the netboot images being produced by DeployStudio were creating .sparseImage files, and it seems that those do not get along at all with the appliance. Converting the image to a normal compressed DMG resolves the issue.

Posted: 6/24/13 at 4:45 PM by ebonweaver

I'm seeing this issue as well, but the image was created with SIU not DeployStudio so I'm not sure of the correlation if any (it makes a .dmg in the .nbi not a .sparsebundle). The image works on this hardware locally, it's completely compatible, it just won't work netboot. On one piece of hardware it won't even start the netboot process, the globe spins forever. On another it starts to boot then kernel panics, and the only thing I notice that seems interesting is "os version not yet set".

Since the NetSUS appliance has zero settings compared to a Mac server for configuring the netboot image there are a ton of questions here. Where is the diskless option? If there is no option, provided it actually worked, is it diskless booting? Where are the hardware model filters? I'm guessing that could be something that would result in the above message... I see a lot of things in the apache2 log relating to missing files in /var/www/webadmin/scripts/ relating to netboot, seems the appliance may have some issues? Is there another log that might show more server side as to why this is failing?

Posted: 6/18/14 at 8:58 AM by clifhirtle

Thanks for posting this up @georgecm12. Seeing the exact same thing with System Image Utility-created NetBoot image like you @ebonweaver. Did you ever get any farther on this issue? The odd thing here is that NetInstall works, but NetBoot does not (?!).

The only difference I can see is the size of the kernelcache, but I have also tried running the kernel-slimming scripts of @Lotusshaney over at: https://jamfnation.jamfsoftware.com/discussion.html?id=9836 and I am still getting the kernelpanic and reboot.

Here's my exact error log from tailing the syslog on the NetSUS:

Jun 18 09:42:36 NetSUS dhcpd: DHCPINFORM from 10.110.200.253 via eth0
Jun 18 09:42:36 NetSUS dhcpd: JAMF-DHCP change
Jun 18 09:42:36 NetSUS dhcpd: N Key or encapsulated
Jun 18 09:42:36 NetSUS dhcpd: 68
Jun 18 09:42:36 NetSUS dhcpd: DHCPACK to 10.110.200.253 (00:50:56:98:42:4f) via eth0
Jun 18 09:45:03 NetSUS mountd[1167]: authenticated mount request from 10.102.81.54:1022 for /srv/NetBoot/NetBootSP0 (/srv/NetBoot/NetBootSP0)
Jun 18 09:49:33 NetSUS in.tftpd[29201]: tftp: client does not accept options
Jun 18 09:49:37 NetSUS in.tftpd[29207]: tftp: client does not accept options
Jun 18 09:53:47 NetSUS mountd[1167]: authenticated mount request from 10.102.81.54:1022 for /srv/NetBoot/NetBootSP0 (/srv/NetBoot/NetBootSP0)

So far recreated about a 1/2 dozen different images, same effect. This is also a NB image created from the very drive of the Mac I'm trying to NetBoot (MacBookPro7,1) so I know it is not an OS compatibility issue.

I will try recompressing the NetBoot.dmg file now, but as it was created with SIU it seems odd there would be a sparse image issue happening here.

Posted: 6/18/14 at 9:29 AM by ebonweaver

Nope, I finally gave up on the appliance as non functional and unsupported unfortunately. I was wondering if it had updated and corrected this issue but your post tells me no.

CJA Badge

Posted: 6/19/14 at 4:48 AM by Lotusshaney

Hi All,

I have just build a 10.9.3 netboot image from scratch, made a slimline kernalcache as the original was 36MB and it boots fine on all my test Macs

Posted: 6/19/14 at 9:14 AM by clifhirtle

Thanks @Lotusshaney. I would really like to get to the bottom of what is happening with our environment and comparing notes with others on the forums seems one of the few ways to unlock the black magic of NetBooting.

  • Can you clarify what model Macs are working in your environment?
  • Also are you NetSUS'ing with the same subnet or across subnets/VLANs?

So far I am seen failures on 10.9.2, 10.9.3 (with combo update run), and the following hardware models (which I used to build the image \+ then attempt NetBoot to):

  • MacBookAir4,2
  • MacBookPro7,1
  • MacBookPro10,1
CJA Badge

Posted: 6/19/14 at 9:18 AM by Lotusshaney

Hi, Im testing netboot on :

MacBookPro10,1
iMac12,1
MacBookAir4,2

Im going across Vlans but I'm using an IPhelper to go across the vlans.

I have tested this on netsus 3.0.1 but My production netboot server is Mac OS X 10.7.5

Posted: 6/19/14 at 9:23 AM by clifhirtle

Thanks @Lotusshaney. Since you are using similar HW and NetSUS version that helps me narrow it down a bit (I heard talk of issues with 2010 laptops).

Would you mind posting back the bless command you are using? Also, assuming your NetBoot image OS is 10.9.3?

Here's mine:

bless --verbose --netboot --booter tftp://xxx.xxx.xxx.xxx/NB-1093-MB71.nbi/i386/booter --kernelcache tftp://xxx.xxx.xxx.xxx/NB-1093-MB71.nbi/i386/x86_64/kernelcache --options 'rp=nfs:xxx.xxx.xxx.xxx:/srv/NetBoot/NetBootSP0:NB-1093-MB71.nbi/NetBoot.dmg' --nextonly

Posted: 1/14/15 at 12:58 PM by McLeod

@georgecm12 Just wondering how did you get the values for options 66 and 67 on your Windows DHCP server? Also are you NetBooting across subnets?

Thanks

CCA Badge CJA Badge CMA Badge

Posted: 7/19/15 at 7:23 AM by michaelhusar

Hi
I am using NetSUS 3.0.2 and was hoping to use DeployStudio 1.6.15 .NBI.
I followed the solution and compressed the .sparebundle
So far so good - machines are booting - workflows starting.
Very nice.
BUT the Utilities from the Menu are broken .. so no Terminal, StartupDisk, etc.
Any idea how to bring them back ?

Posted: 7/20/15 at 10:05 AM by mattware

@michaelhusar That may be a problem with your image. If you host it from OSX, does it work as expected?