Skip to main content
Jamf Nation, hosted by Jamf, is a dynamic and knowledgeable community of Apple-focused IT admins and Jamf Pro users. Join us in person, in October, for the annual Jamf Nation User Conference (JNUC) to discover new and better ways to manage Apple devices.
CCA Badge

Mavericks Dropping Network connection on test Mac Mini server

Hi JamfNation.

I am working on setting up a Casper 9.22 test server. Mid 2012 Mac Mini, 10.9.1, Server app 3.0.2. I have been round and round with my networking team and for some unknown reason my ethernet connection keeps dropping every 15-20 minutes. I've rebuilt the server from scratch once but the issue still exists. I made sure all of my energy saver settings were setup to never and even went as far as making ethernet the only network interface. I ruled out it being a hardware issue by hooking up a new Macbook pro with 10.9.1 to my port and it even dropped the connection. I check Apple forums and a lot of people seem to be having issues with Mavericks and staying connected. I was just curious is anyone else out there have run into any issues like this.

Like Comment
CCA Badge CCE Badge CUG Badge Integrator Badge
SOLVED Posted: 1/29/14 at 12:31 AM by bentoms

I have 11 Mac Mini servers globally deployed & none have this issue.

Neither do my 10.9 clients.

Does sound a bit like an issue with that port/switch.

Like
CCA Badge
SOLVED Posted: 1/29/14 at 8:45 AM by dkagle

Thanks bentoms. Sadly, my internal network admins refuse to believe it's a networking side issue since a PC plugged into the same port with the same static IP and DNS name doesn't have a problem. Oh the woes of being a Mac admin is a windows world.

Like
SOLVED Posted: 1/29/14 at 12:15 PM by evarona

Can't say I've seen this issue but the only other thing that comes to mind is to check that the network service order sets your wired connection to the highest ordered connection. For some stupid reason, Apple sets Bluetooth DUN highest.

You can check this with

/usr/sbin/networksetup -listnetworkserviceorder
and set with
sudo /usr/sbin/networksetup -ordernetworkservices <service1> <service2> <service3> <...>
or from the main Network SysPref pane (the gear on the lower left side)

Good luck and hope this helps

Like
CCA Badge CCE Badge CMA Badge
SOLVED Posted: 1/29/14 at 7:31 PM by dlondon

As it's a test machine, can't you plug it in somewhere else to see if it works anywhere? If it does work then you have your evidence of some weird interaction with that particular switch. However if it still acts up you can send it back to Apple :)

Like
CCA Badge
SOLVED Posted: 1/30/14 at 3:16 AM by Mauricio

We have found network issues from our Macs that were upgraded to 10.9.
There is a new security feature in Mavericks, 'ARP Validation'.
The blog from Citrix explaining it in more details.
http://blogs.citrix.com/2013/10/31/citrix-on-osx-10-9-mavericks/
Hope this can help you.
Regards
Mauricio

Like
CCA Badge
SOLVED Posted: 1/30/14 at 6:35 AM by dkagle

Thanks everyone for the replies. I changed the service order and I confirmed it was fine plugged in elsewhere. The article Mauricio linked me is almost identical to my issue, a Mac mini running 10.9 plugged into a Cisco core and it's dropping connection. I will try the fix in the article and reply if it fixes it. Thanks again fellow Jamf Nation members for the help!!!!

Like
CCA Badge
SOLVED Posted: 1/30/14 at 8:18 AM by dkagle

Unfortunately disabling the ARP didn't help my issue. Off to the Apple Store I go.

Like
SOLVED Posted: 1/30/14 at 3:28 PM by jmercier

hi

im having the same issue on mac pro server 10.9.1...

AND now on my other mac mini server that i just upgraded to 10.9.1...

none of my other 10.8 or 10.7 server doing that... looks really problem with 10.9.1 !!!

Like
CCA Badge
SOLVED Posted: 4/1/14 at 8:46 AM by tanderson

I just started seeing this late last week on my 10.9 Mac mini server. It had been running fine for weeks and just started up. I see network disconnect errors in the logs and have noticed that user sessions aren't getting disconnected when it happens (they hang around in the Connected Users tab). Threads on Apple support discussions about it too. Upgraded to 10.9.2 and no change.

Like
CCA Badge
SOLVED Posted: 4/7/14 at 7:59 AM by dkagle

I had to put my Mac mini server back on 10.8.5 for now. I setup a NetBoot/SUS appliance to handle managing updates for 10.9 clients. I am waiting for the 10.9.3 GM seed and then crossing my fingers.

Like
SOLVED Posted: 4/16/14 at 4:44 PM by taugust04

Just wanted to add some more information here:

I'm also seeing this connectivity issue on a Mac Mini Server running 10.9.2, where I'm seeing periodic dropped packets from just standard pinging from the Network Utility. Tried running the script provided by Citrix, and I'm still seeing the same issue. However, I have a feeling this is not just a software issue. I have an Xserve also running 10.9.2 and I'm not seeing any connectivity issues at all, so this might be related to the NIC and or the NIC driver for the Ethernet hardware built into the Mac Mini and or Mac Pro. Both the Xserve and the Mini I tested on are connected directly to Cisco cores.

Like
SOLVED Posted: 4/25/14 at 10:36 AM by nick1313

I am also having this issue with a couple of mac mini servers. I've tried the fixes mentioned in this thread, none have worked.

I have contacted AppleCare support but this issue is too high level for them so I will be contacted enterprise level support as well, as soon as we have an agreement in place.

In the meantime has anyone found anymore information on this? We have HP procurve core switches that the apple servers are plugged into and are on their own vlan (same one as about 150 other servers, various windows/linux, that aren't having this issue). We are also attacking this from an HP switch angle, we have an open case with them in an effort to see if they can find something.

A couple oddities that we have found.

  1. If the servers are statically assigned to our local subnet (not in a vlan) they don't have this issue, which I think might rule out the hardware issue.
  2. The servers still seem to be transmitting data when they drop pings/packets.

We are looking to, potentially, buy a bunch more of these servers to help manage our ipads/macbooks, so hopefully this issue will get resolved.

I will report back anything I get from enterprise support.

Like
CCA Badge CMA Badge
SOLVED Posted: 4/25/14 at 12:02 PM by cbrewer

Seeing very similar issues with a couple of Mac Minis connected to Cisco 3560X switches running 12.2(53)SE2. I've reproduced the issue on both 10.9.2 and 10.9.3(Build 13D45a) with a current gen Mac Mini as well as a mid 2012 MacBook Pro.

Like
SOLVED Posted: 4/25/14 at 12:16 PM by jmercier

hi

same here... 2 different machines... mac mini and mac pro... all on 10.9.2. They all work everywhere else on our VLAN but not in this VLAN

everything is pointing out to the version our Cisco switches are running their OS... Its the only place using old version of OS on cisco...

All our other servers running 10.8 and before is working fine...

10.9.3 did not solve the issue for us with beta testing...

Like
CCA Badge
SOLVED Posted: 4/25/14 at 12:21 PM by tanderson

Cisco switches here as well but I'd have to check with our network team on models and software versions. I've been working on another project that will wrap up next week, after that I plan to submit a ticket to AppleCare Enterprise support as well.

Like
SOLVED Posted: 4/25/14 at 12:22 PM by jmercier

as far as my network team told me... the only place in our huge network we have problems is equipped with OS i think version 12...

all other places is recent version... we might get into upgrading our stack this summer

Like
SOLVED Posted: 4/25/14 at 1:02 PM by nick1313

The 1st level support (applecare) guy I talked to said he never heard of any of this, I even linked him to this thread. Maybe if more people contact them it will become a little higher priority for them, because it's obviously happening to more people.

He basically said there wasn't much he could do, since it was more high level, but also because I was the first person that he heard it from. Also since it's happening on multiple brands of switches/networks/etc it's gotta be something with the new OS.

Like
SOLVED Posted: 4/25/14 at 1:09 PM by jmercier

I know it has to do with ARP Inspection and redundancy protocols used on managed switches environment....

He can't say he doesn't know... many threads only reports this problem... weird...

Like
SOLVED Posted: 4/25/14 at 1:15 PM by nick1313

Yea, maybe that was just his way of deflecting the issue to enterprise support or maybe at the enterprise level they have a fix but want you to pay for it, I don't know.

I would think if it were a bug in the software, which it definitely seems to be, they should send out an update to fix the issue and not make you pay for enterprise support.

I'll be honest though, I don't know next to nothing about how switches are setup and what ARP Inspection and redundancy protocols are, we have two network guys that do that stuff. However they aren't here today.

Like
SOLVED Posted: 4/28/14 at 12:08 PM by mapurcel

we are also seeing this issue with Cisco gear using Gateway Load Balancing Protocol (with Mavericks clients), this Apple article describes the issue and the script has worked for us so far in a few tests.

Article: https://discussions.apple.com/thread/5483424?start=0&tstart=0
Script: https://github.com/MacMiniVault/Mac-Scripts/tree/master/unicastarp

Like
SOLVED Posted: 4/28/14 at 12:11 PM by jmercier

Tried this patch multiple times and multiple systems 10.9.... not working at all for us... very bad situation

Like
SOLVED Posted: 4/30/14 at 3:25 PM by nick1313

I wanted to throw out an update on this and I think taugust04 is on to something. One of our network guys had the bright idea of trying out a usb to ethernet adapter and we haven't had any time outs for the last 2 hours. I'm going to keep monitoring it for the next day.

Like
SOLVED Posted: 4/30/14 at 3:43 PM by jmercier

Hi

Se tried thunder to ethernet and we had same problems

Like
CCT Badge CCA Badge CJA Badge
SOLVED Posted: 4/30/14 at 9:04 PM by mpermann

@nick1313, did you use an Apple USB to Ethernet adapter or a third party adapter? If it's a third party adapter, do you mind sharing the specifics of the adapter you are testing?

Like
SOLVED Posted: 4/30/14 at 9:05 PM by jmercier

hi

same comment here... i tried thunderbolt to ethernet... same problem... do you think usb to ethernet would be different ?

Like
CCA Badge
SOLVED Posted: 5/1/14 at 12:01 AM by Sonic84

I'm also seeing a similar issue. I have 4 Mac Minis (out of \~15 globally) which go "offline" every now and again. I've escalated this issue to both Apple enterprise support and McAfee enterprise support. No resolution so far. Two of the servers are plugged into Cisco Nexus core switches (US) and a third is plugged into a catalyst 3750 (Europe). I'm not sure what the 4th is plugged into since this server is a special case... All servers are running 10.9.2. The issue started when the servers still had 10.8 loaded on them. The only difference is when they went "offline" they also stopped recurring any logs. Now that we are on 10.9, the logs continue, but fill up with errors by the kernel.

Like
SOLVED Posted: 5/1/14 at 9:15 AM by nick1313

One adapter I am using is an Apple one and the other is a Cisco adapter. Only problem with these two particular adapters is that they are 100mb max, but for troubleshooting they'll work for now.

Those of you that tried Tbolt adapters, maybe try a USB one.

Like
CCA Badge CMA Badge
SOLVED Posted: 5/1/14 at 9:44 AM by cbrewer

No problem so far for me while using an Apple USB ethernet adapter.

Like
SOLVED Posted: 5/1/14 at 3:22 PM by jmercier

hi

situation a lot more stable with usb adapter.... but god its too slow to be used in production...

our solution will be to update the OS of our cisco core... or move the server to other ip range on updated switches....

Like
SOLVED Posted: 5/22/14 at 6:28 AM by sburrows

We are seeing this issue with one of our brand new Mac Mini's (10.9.3) connected to a Cisco 2960G switch. Has anyone narrowed down the issue?

Like
SOLVED Posted: 5/22/14 at 7:29 AM by nick1313

I'm working with enterprise support from Apple and have been sending them logs and what not but still no solution. I just updated the servers to 10.9.3 and it's still happening.

One odd thing is the tech wanted me to grab some packet captures of the server while it was doing it and then run a sysdiagnose, however it won't ever drop pings while I'm running the packet capture. As soon as I stop capturing packets it will drop connection again. This is getting very frustrating.

Like
SOLVED Posted: 5/22/14 at 9:32 AM by jmercier

hi

i have 2 situations...

situation 1 : cisco switch stack with 2 server with 10.9.X, with old Cisco OS : i have tons of network drops...

Situation 2 : cisco switch stack (same model as situation 1) with 2 same server 10.9.X as situation 1 with updated Cisco OS : No more drops...

So we are planning of doing the upgrade of the cisco os on the defective Stack this summer...

edit : on other thing... apple specialist told us that disabling the ARP inspection scan on the cisco switches would fix the problem... but we prefer doing the update...

Like
CCA Badge CMA Badge
SOLVED Posted: 5/22/14 at 9:54 AM by cbrewer

@jmercier Can you find out exactly what 2 Cisco OS versions you did your tests with?

Like
CCA Badge
SOLVED Posted: 5/22/14 at 10:00 AM by Sonic84

By any chance, are you seeing any of these errors in your System.log?

May 15 11:58:11 mac-01 kernel[0]: AppleBCM5701Ethernet [en0]:        8      5ea LimitMinFragSize: Unable to realloc packet

or

Mar 18 19:41:05 mac-01 kernel[0]: ctl_enqueuedata: m_allocpacket_internal(1072) failed
Like
SOLVED Posted: 5/22/14 at 10:02 AM by jmercier

@cbrewer :

Cisco version not working : 12.2(55) SE1

Cisco version working fine : 15.0(2)SE5

Like
SOLVED Posted: 5/22/14 at 10:13 AM by sburrows

Hey jmercier do you know what model Cisco switches and the OS that they are running where you aren't haven't any issues? I checked with Cisco and they have a newer OS for my 2960G switch, but they are now recommending the use of version 12 instead of 15. Seems a bit weird.

After doing some testing this morning I plugged our Mini in to an un-managed D-link switch that is plugged in to our Cisco 2960G and we had no network loss. I currently have it plugged in to a 2960S and have noticed a few pings timeout. I confirmed that neither switch has ARP inspection on.

Like
SOLVED Posted: 5/22/14 at 10:16 AM by jmercier

Hi

switch not working ; WS-C3750E : version 12.2

switch working : WS-C3750X \- version 15.0

Like
SOLVED Posted: 5/30/14 at 1:28 PM by ryan_w

We are seeing these issues too on a couple of Mac Minis connected to our Dell switches. Glad to see I'm not the only one. I hope they release a fix soon, but will start testing a workaround using USB adapters or unmanaged go between switches.

Like
SOLVED Posted: 5/30/14 at 11:32 PM by ryan_w

On the Mac Mini's ethernet port I set the hardware settings to Manual > 1000 Base-T > Full Duplex, Flow Control > Standard MTU > Unchecked AVB/EAV Mode and things seem to be much better so far.

Never mind on this one, it only worked good for about an hour and then started doing the same thing.

Like
SOLVED Posted: 6/3/14 at 7:29 AM by ryan_w

Not sure if this will help anyone else, but wanted to post just incase. I noticed one of our Mac Minis was not affected by the issue. The only thing different on it was it was on a different VLAN. So, I moved our other Mac Minis to VLANs other than VLAN1 and things are working great now.

Like
CCA Badge CMA Badge
SOLVED Posted: 6/4/14 at 9:44 AM by cbrewer

We updated our Cisco switch from 12.2 to 15.0 and it did not resolve the problem for us.

Like
SOLVED Posted: 6/4/14 at 9:48 AM by jmercier

what model of switch do you have ?

Like
CCA Badge CMA Badge
SOLVED Posted: 6/4/14 at 9:53 AM by cbrewer

@jmercier

Cisco WS-C3560X-48 running 15.0(2)SE6

Like
SOLVED Posted: 6/4/14 at 9:55 AM by jmercier

hummm thats weird... we got it working on switches 3750X with 15.0 SE5....

Like
SOLVED Posted: 6/5/14 at 7:48 PM by bandersaurus

The next time you speak with someone from Apple, just tell them that it's been affecting access to iTunes. THAT will get them to care!

Like
SOLVED Posted: 6/12/14 at 4:23 PM by dyossi

Any news on this issue, it's driving us crazy. We have tried upgrading our Cisco 3750 switches, but this did not work. We are also experiencing the issue on HP 2920. We did find out that if we plug into a Cisco 2960S the problem goes away.

Like
SOLVED Posted: 6/12/14 at 5:54 PM by jmercier

We will have news pretty soon... we are planning on putting the update on our switch stack

Like
SOLVED Posted: 6/12/14 at 7:11 PM by sburrows

We are still seeing it on our 3750 and 2960G with upgraded software.

Like
CCT Badge CMA Badge
SOLVED Posted: 6/12/14 at 9:27 PM by gburgess

I'm seeing this on new mac mini's as well. I've set up a new server with 10.9.3 and Server software. JSS version 9.32. I have the JSS on one mini and a DP set up on another mac mini that is running 10.9.3 as well. I have an xServe that is running a share on 10.6.8 Server as another DP.

When imaging machines today, I noticed that the mini running the DP lost it's ethernet connection for about a minute. This had caused one of the imaging machines to restart due to a timeout with the DP. Interestingly, other machines imaging from that DP did not restart due to a time out. Machines imaging from the xServe did not lose any connection.

From talking to the network admin here, the servers are not connected to Cisco switches. He had mentioned that they are on 3COM switches. If needed, I will find out which versions of switches they are.

I figured I would add my info here since I am seeing the same issues here, but with different hardware. I was going to look at updating the xServe to 10.9 as well, but with these issues showing on the minis...

Like
SOLVED Posted: 6/25/14 at 8:07 PM by BAndrews

When we noticed that thunderbolt to ethernet adapters don't work but the USB to ethernet adapters do work we looked into what chipset they use and they're both made by Broadcom. The fact that non Broadcom chips appear to not have the issue even on Mavericks suggest to me that it's probably an issue with the Maverick's Broadcom device driver.

Like
CCA Badge CMA Badge
SOLVED Posted: 6/25/14 at 11:52 PM by loceee

Not at work, but my media centre / home macmini 2011 i5 that drives my house has been dropping ethernet intermittently, and very frustratingly.

It's plugged direct into TP-Link home router running gargoyle-router.com. I thought I had failing hardware, but this makes me think otherwise. Watching with interest.

Like
SOLVED Posted: 6/26/14 at 1:27 AM by KevReid

I too have the same issue \- Mini (2013) connected to Vlan with wireless MacBook Pro Retina (late 2012) both latest Mavericks.
Connection keeps dropping \- repeated messages on macbook screen about lack of connection. Use Finder \- reconnect and all is well for a while then it disconnects and messages start appearing again.
I have been having trouble with my MacBook using a TimeMachine disk on the server \- I suspect it is the dropouts that is the issue with that too. Large transfers to the server disks take forever and only finish if I keep the connection alive.

Like
CCA Badge
SOLVED Posted: 6/26/14 at 1:56 AM by nessts

the wifi issue could be if you are using bluetooth keyboard and mouse at the same time, there is a bandwidth issue where bluetooth devices will steal bandwidth from the wireless portion of the chip causing the wifi network to go up and down, or switch G band instead of N band. Apple should choose a better wifi chipset to address this issue, happens on a bunch of cheap windows laptops too.

Like
CCA Badge CMA Badge
SOLVED Posted: 7/1/14 at 11:50 AM by cbrewer

It's too early to say for sure, but I'm not currently seeing this issue after upgrading to 10.9.4. Anyone else?

Like
SOLVED Posted: 7/1/14 at 2:08 PM by jmercier

i can confirm your expectations.... im not seeing the issue either anymore...

over 10000 ping without a drop... before i use to have about 10% drop...

anyone else ?

Like
SOLVED Posted: 7/1/14 at 2:16 PM by sburrows

So far so good on 10.9.4 here, but it's only been a few hours since I've upgraded our 2 problematic minis.

Like
SOLVED Posted: 7/2/14 at 5:52 AM by jmercier

update on 10.9.4 !!!

62000 ping... no drop !!!!! think Apple finally fixed that one...

any updates from everyone ?

Like
CCA Badge CMA Badge
SOLVED Posted: 7/21/14 at 8:17 AM by sullivanj

Issue returned for us after about 2 weeks on 10.9.4...I have a case open with Apple. The USB to Ethernet adapters do seem to resolve the issue though, but it needs to be fixed by Apple.

Like
CCA Badge
SOLVED Posted: 7/21/14 at 8:21 AM by Sonic84

I've been watching my 18 Minis since the 10.9.4 upgrade. so far none have dropped their network connection. I really hope this issue wasn't just delayed with the 10.9.4 install.

Like
CCA Badge CMA Badge
SOLVED Posted: 7/21/14 at 8:32 AM by sullivanj

I hope we are the exception and it does indeed stay resolved for you. The response I received from Apple was less than adequate...basically they said that the fix is scheduled for release with Yosemite and kept urging me to try the Developer Release to see if it resolved the issue(it seemed to fix it). IMHO, that is completely irrelevant to our current situation though. I have 172 machines that are currently running Mavericks(iMacs and MBP) that are affected by this issue. The way I see it is that the "feature" wasn't present in 10.8.x, they added it into 10.9.x, then fixed it in 10.10 so either back port the fix to 10.9 or remove it completely as in 10.8. I've also spoken with Cisco regarding this and Cisco's response was "that Cisco devices will NOT reply to UNICAST ARP REQUESTS and we will not support this in the future either."

Like
SOLVED Posted: 7/22/14 at 8:27 AM by sburrows

We are still noticing this issue on 2 of our 10.9.4 mini's.

Like
SOLVED Posted: 7/23/14 at 4:51 AM by rseward

We suddenly started experiencing this problem on our two Mac Mini Servers (10.9.3 and 10.9.4) last week.
Some time ago we also had the Unicast ARP problem to our CISCO switches, which was resolved with net.link.ether.inet.arp_unicast_lim: 5 -> 0

Using a USB Ethernet adapter stopped the ping loss, but does restrict the connection to 100Mb. A Thunderbolt Ethernet adapter did not fix the problem.

For a permanent fix we did this:
• In System Preferences select your Ethernet connection that has ping errors and then choose 'Duplicate Service'
• Check the duplicate is a lower priority in 'Service Order' • Change the IP address on the duplicate to anything else. (I just selected DHCP)

I would do the above when at the console as the first time I did it when I change the IP address on the duplicate the server stopped answering to pings completely so consequently also lost RDP connection. Second time I did it form the console, deleted the duplicate, did it again with it working perfectly. No idea why it works, but we have since had 0% packet loss.

Credit to Ben Bass : https://groups.google.com/forum/#!topic/macenterprise/3gEKaZ7SBLk

Like
SOLVED Posted: 7/30/14 at 3:34 PM by vip1234

I think this issue is very simple. The following was very helpful:
Posted 4/1/14 at 8:46 AM by tanderson
I just started seeing this late last week on my 10.9 Mac mini server. It had been running fine for weeks and just started up. I see network disconnect errors in the logs and have noticed that user sessions aren't getting disconnected when it happens (they hang around in the Connected Users tab). Threads on Apple support discussions about it too. Upgraded to 10.9.2 and no change.

I discovered this with a simple file share on a network application. App was continually getting a license error on one machine for a specific network application (too many user error or license already used). Server was OS 10.9.4 and the machine was OS 10.9.4. User was a laptop and she would pick up and take laptop home each night. By doing this, the server was disconnected but the server did not drop the connection. She would come in the morning, connect to server again, and the "Server" app would list her name twice under the "Connected Users" tab of File Sharing. Manually disconnecting the phantom user (the one that was idle for almost 20 hours) solved the problem. However, any network drop (forced or unforced) seems to cause this exact issue.

Very buggy stuff from Apple.

In reading other posts, I forgot to check the network adapter but I am assuming it is thunderbolt. Would be interesting to test with simple disconnects to on board Ethernet versus an adaptor.

Like
CCA Badge
SOLVED Posted: 7/30/14 at 4:28 PM by Jedberg

You may want to enable AFP Idle Disconnect. I believe it is turned off by default to allow for AFP Network Shares to reconnect automagically.

We made the following changes:
sudo serveradmin settings afp:idleDisconnectOnOff=1
sudo serveradmin settings afp:idleDisconnectTime=120

Like
SOLVED Posted: 8/11/14 at 4:04 PM by macstadium

Hey just to let you know that we have been tracking this for about 9 months... a full write-up is here on our blog here: http://www.macstadium.com/blog/osx-10-9-mavericks-bugs/

A couple days ago, one of our subscribers who happens to also be an Apple employee put us directly in touch with the CoreOS at Apple developers in Cupertino, CA. This was really exciting news because we have been trying to get an escalation at Apple via the support and beta communities for a very, very long time with no traction.

Apple has since validated the issue via a lab we setup for them here at Macstadium.com, and they are now looking at a driver stack problem being the main issue. The biggest clue was the Apple USB <> Ethernet adapter not presenting the problem on the exact same host as the internal Gigabit Ethernet adapter \- on the same network \- at the same time.

They are moving very quickly, so we are very optimistic for a patch for 10.9.x as well as the solution being rolled into the next 10.10 beta release. We'll keep everybody posted in coming days.

Like
CCA Badge CSE Badge CMA Badge
SOLVED Posted: 8/12/14 at 8:52 PM by gskibum

Not much to offer other than a "me too."

rseward's NIC duplication trick has so far worked for me after applying it today.

I thought it was an issue with the Netgear switches so I put in some loaner Cisco Sg-300 switches I keep on hand. That worked for about 5-6 days. But today it started again.

Like
CCA Badge CMA Badge
SOLVED Posted: 8/15/14 at 8:58 AM by sullivanj

Macstadium,

I too have a case open with Apple regarding this issue and asked about the validity of the statement you made and this is the response I received:

"Hello Jerry.

Good morning. Just wanted to touch base and provide you an update to the information you provided. There has not been any validation to this being implemented into 10.9.x and or any updates that it would be. However, we do know that this is fixed in a future release, which you have already tested and validated. What I can do at this time is mark the case pending Future Release and if any updates that come up that I can share with you I will do so promptly at that time."

I was just wondering if you had any update from your end as this could simply be a case of right hand/left hand. The mentioned fix that is mentioned above is regarding Yosemite, but this is not a feasible option for us and I'm sure quite a few others. Thanks in advance.

Like
SOLVED Posted: 8/20/14 at 6:30 PM by bitgeeky

I had similar issues with my MacBook Pro (late 2013) and explored a lot into this problem. Here[0] is a detailed explanation and solution.
http://pankajmalhotra.com/ARP-and-ethernet-issues-with-osx-mavericks/

Hope you find it useful.

Cheers !
Bitgeeky

Like
CCA Badge CCE Badge CJA Badge
SOLVED Posted: 8/20/14 at 10:39 PM by RobertHammen

Running this script from the MacMiniVault folks completely resolved the issue on a 10.9.4/Casper Suite 9.32 install at a school district I've been working at:

https://github.com/MacMiniVault/Mac-Scripts/blob/master/unicastarp/unicastarp-README.md

Like
CCA Badge CSE Badge CMA Badge
SOLVED Posted: 8/21/14 at 8:46 PM by gskibum

RobertHammen, do you know how would this would be reversible should things hit the fan? Or if-when Apple released their fix? I want to try this ASAP on one system.

Thanks!

Edit: Wow they wrote that script back on November 8. And Apple still hasn't released the patch.

Like
CCA Badge CMA Badge
SOLVED Posted: 8/22/14 at 6:56 AM by sullivanj

gskibum, reversing the script would be removing the line from /etc/sysctl.conf and rebooting.

Like
CCA Badge CSE Badge CMA Badge
SOLVED Posted: 8/22/14 at 9:54 AM by gskibum

Ahh I see that script creates the file in the first place. I suppose besides editing the file it could be removed altogether?

Like
CCA Badge CMA Badge
SOLVED Posted: 8/22/14 at 10:02 AM by sullivanj

You are correct, the file is only a container for commands so presence makes no difference.

Like
SOLVED Posted: 9/8/14 at 6:04 PM by ElvisII

I bought a USB3 to Giga Ethernet Adapter from Cable Matters ($20.00 Amazon) that fixed the problem using AX88179 driver. All Macs with Mavericks 10.9 to 10.9.4 have the same problem at work, with Wireless, Cable, USB to Ethernet, Thunderbolt to Ethernet. Have contacted Apple Care with no luck

Like
SOLVED Posted: 9/21/14 at 5:22 PM by Oldskuulteky

It seems to be that it is an embedded hardware issue that is random thru each unit produced. A necessary evil. But embedding always causes some type of lobotomy somewhere if it isn't mapped out correctly.

Like
SOLVED Posted: 9/25/14 at 12:05 PM by wonfuji

Hi, I ran across this list doing some googling for reports of Filemaker Server 13 on Mavericks (2 brand new MacMini's running 10.9.2 and 10.9.3) having connections issues \- dropping clients, seemingly falling of the network. Also occurring on a MacPro running 10.9.3. I will note right away is that I an a db programmer, specifically Filemaker, and rarely rarely use Terminal. Sometimes Console to look for things I can't find. A recent thread of the Filemaker Experts list has suggested that IPv6 might be part of the issue.

In Console which logs should I investigate and what strings might I look for that indicate network drop-offs?

Thanks in advance.

Stephen.

Like
SOLVED Posted: 10/24/14 at 3:29 AM by Jayant371

We also are trying to roll out a couple of mac mini servers with Mavericks but we also experience serious connection drops. We tried the following:

\- Connect the server to a Cisco 3750 with IOS 15.0 (SE6)
\- Change serviceorder, Ethernet on top.
\- Thunderbolt --> ethernet adapter
\- USB --> ethernet adapter
\- Disable ARP validation

None succeeded in a stable network connection except the USB --> ethernet adapter solution. This resulted in a stable connection.

Also found out that the problem doesn't occur when capturing network traffic on the server side cause whireshark puts the NIC in promiscuous mode.

We now updated one server to Yosemite and the connection is stable now for 20 minutes.

Is there any news on the problem from contact with Apple?? Is there a NIC driver patch coming for Mavericks?? Cause the initial plan was to also update all Mac clients to 10.9...

Like
SOLVED Posted: 10/24/14 at 9:30 AM by GaToRAiD

@Jayant371, I feel your pain here, we are experiencing the same issues. Here are the two solutions that we have found to work for ours.

1) create a script that does a ping request then stops and waits, then does it again(our networking didn't want us to do a continuous ping to other internal servers.
2) Switch to USB to Ethernet adapter. (we choose not to do this option as it would take our bandwidth down from 1 gig to 100m.

Hope this helps.

Like
SOLVED Posted: 10/24/14 at 9:35 AM by jmercier

hi

i confirm we are having the same problems of drop ping with Yosemite...

Like
CCA Badge CSE Badge CMA Badge
SOLVED Posted: 10/24/14 at 9:37 AM by gskibum

@GaToRAiD, have you tried any 10/100/1000 USB 3 ethernet adapters?

Like
SOLVED Posted: 10/24/14 at 9:43 AM by GaToRAiD

@gskibum, no I haven't, but that will be bought on monday.

Like
SOLVED Posted: 10/24/14 at 9:51 AM by Jayant371

Hmmmm hate to hear the problem still exists in Yosemite because we were just so happy with the poing, which I kinda forgot, but resulted in:

Ping statistics for x.x.x.173: Packets: Sent = 21514, Received = 21480, Lost = 34 (0% loss),
Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 50ms, Average = 0ms

We continue to test Yosemite on monday cause today is not as busy as normal on the network. The USB --> ethernet solves to problem but is not really an option for 100 or somewhat clients...next to the 100 mbit connection..

@GaToRAiD: how does the script solve the connection drops in production??

@macstadium and @sullivanj, is there any news from your contact with Apple about the fact that USB --> ethernet works and the normal NIC doesn't??

Like
SOLVED Posted: 10/24/14 at 10:09 AM by Jayant371

Also, it looks like it's a hardware problem of not all/some Mac mini's....because not everyone is experiencing this issue plus in the test where we put the Mac Mini server to the 3750 Cisco we also connected two other Mac mini servers of the same model (late 2012) to the 3750 and they didn't have the network drops like our test machine. When there were dropped pings with the other two machines, there were every time just 4-6 pings lost....they recovered fast and our Mac mini with the network issue experienced serious network interruptions.

We might consult 'The Geniuses' next week on this issue our self. Hope we'll get some info on the subject and move it to a higher priority with Apple

Like
CCA Badge CMA Badge
SOLVED Posted: 10/24/14 at 10:14 AM by sullivanj

@Jayant371 My ticket with Apple was closed on Oct. 11 2014 with the following comments:

STATUS: Thank you for the reply, much appreciated. I wasn't sure if that step had been done, since I hadn't mention it before and just recently was presented that it needed to be hardcoded. As far as any updates to the report I submitted on your behalf, it is has been related to a similar report and will be in a future release. I understand this is not what you were hoping for, but this is what engineering has presented. When we first submitted, I mention there were no guarantees that it would be implemented in the current release, but I wanted to go the extra miles on your behalf and see if it would possibly be. Have a great day. End of Comments / Instructions

I wasn't able to get an actual answer to why the USB dongles fix the issue, but I would guess that it has to do with bypassing the affected network stack. We ended up purchasing 300 Belkin 100mbps USB to Ethernet adapters because in our environment we utilize applications that require constant connections for licensing and normal functionality (Citrix). It's not the best solution, but it is a working solution and with Apple telling us we were SOL we had no other choice.

Like
SOLVED Posted: 10/24/14 at 7:06 PM by zwolfe1

I recently purchased a 2014 27-inch iMac, running Mavericks. I'm having issues with the network connection timing out, whether I use wifi or plug directly into the modem with an ethernet cable. I had no such issues with my 2011 21.5-inch running Mountain Lion. This issue is the closest to my own I have found; might the USB to Ethernet adapter fix my problem?

Like
SOLVED Posted: 10/25/14 at 11:10 AM by GaToRAiD

@Jayant371 the script basically is a keep alive, which doesn't allow for the packets to drop. We are currently using this in production and haven't noticed any problems since we have implemented this.

Like
CCA Badge
SOLVED Posted: 10/28/14 at 8:16 PM by dkagle

My post from back in March :I had to put my Mac mini server back on 10.8.5 for now. I setup a NetBoot/SUS appliance to handle managing updates for 10.9 clients. I am waiting for the 10.9.3 GM seed and then crossing my fingers.

As you all are well aware from your own experiences, updating didn't fix my issue either. My servers are still stuck on 10.8.5 and I'm running NetSUS appliances for ASUS and netbooting. Has anyone had luck with updating to 10.10?

I updated my test server to 10.10 on Monday and I've seen a random drop here and there but nothing consistent like before. After a full test JSS setup, I'm hoping I can move forward.

@GaToRAiD I'll be using a keep alive script if the issue persists or be getting the USB 3.0 gigabit dongles. While my network admin wasn't very helpful with trying to update our Cisco switches, he is more than happy to help with me with a keep alive script.

Thanks to everyone who commented on my original post earlier in the year. Helped me keep my sanity knowing I wasn't alone. JAMF Nation Rules!!!

Like
CCA Badge CMA Badge
SOLVED Posted: 10/28/14 at 10:05 PM by cbrewer

This issue appears to be unchanged in 10.10. Hugely disappointing.

edit: It's been a couple months now on 10.10 and I have not seen the issue in quite a while.

Like
CCT Badge CCA Badge
SOLVED Posted: 11/6/14 at 3:11 PM by jbutler47

Seeing same issue with:

Mac OS X 10.9.5
JSS 9.32
Mac Pro 2014 (x2)

Initial resolution was Apple USB to Ethernet, as it stopped lost/dropped packets. Awaiting delivery of USB 3.0 to GigaBit Ethernet, let you know how it goes. Yes, we get throttled down, but better to be slow than constant drop-out.

Tried all other solutions mentioned here to no avail. So far, the USB option worked, but time will tell.

Like
SOLVED Posted: 11/26/14 at 6:52 AM by sburrows

@jbutler135 How did those USB 3 to gig adapters work for you? Which ones did you end up going with?

Like
SOLVED Posted: 12/18/14 at 2:33 PM by wonfuji

Wondering if anyone has tried Ethernet to Thunderbolt for this issue?

Like
CCA Badge CMA Badge
SOLVED Posted: 12/18/14 at 2:34 PM by cbrewer

Knock on wood, but I haven't seen this issue since moving my Mac Minis to 10.10.

Like
CCT Badge CCA Badge
SOLVED Posted: 12/18/14 at 4:43 PM by jbutler47

Much success here.

Had used a HiRO H50224 USB 3.0 10/100/1000 Gigabit Ethernet Adapter with my Mac Pros, worked like a charm, all issues went away. You will need to download their driver, works for 10.9.x.

JSS never freezes, communication to/from separate MySQL server resolved instantly with the USB adapters.

BTW, Thunder-2-Ethernet did not work at all, all ports, no joy. YMMV.

Like
SOLVED Posted: 12/18/14 at 5:10 PM by wonfuji

James

That sounds promising. Just amazoned two of them. I'll report back.

Stephen

Like
SOLVED Posted: 1/6/15 at 2:30 PM by sburrows

We ended up getting some Linksys USB 3.0 gig adapters and so far so good. We've had them installed for a good 2 weeks now. We have one Mac Mini on Mavericks and another on Yosemite.

Like
SOLVED Posted: 2/2/15 at 8:48 PM by vonkas

read this blog with interest. Have had TCP/IP timeout issues with running VMs (Fusion & Vbox) between late 2014 iMacs & 2014 mini \- all running 10.9.5 ws or server. No matter which way, it appears the ethernet I/F goes to sleep after 10-20 secs no activity. WHen it finally dawned on me I got a ping-forever going on the server mini/Vbox PC command console pinging any of the other VM. This fixed it! The load on the network traffic is not measurable. So for now this will do. I bet \- as mentioned before \- ping between 2 Macs will do the the same.

Like
CCT Badge CCA Badge CCE Badge
SOLVED Posted: 4/10/15 at 9:30 AM by CypherCookie

it sounds like this. http://www.macstadium.com/blog/osx-10-9-mavericks-bugs/

Like
SOLVED Posted: 9/14/15 at 10:27 AM by FelloWizard

Man I'm glad that I've finally found this thread! I've been searching High and Low for a resolution. I have a 2011 Mac Mini Server 10.7.5, 2014 Mac Mini 10.10 and 3 (late 2014) Macbook Pros 10.10 that are having the exact problem on our LAN. I'm going to try the USB 3.0 to ethernet fix first and if that doesn't work I will give the bash script a try.

I'll keep you guys posted on my results.

Like
SOLVED Posted: 9/14/15 at 1:36 PM by rviets

I had the same issue with a M2011 Mini Server running 10.9.5 and a Filemaker database we use for inventory. Sometimes it was 3 minutes, sometimes it was 3 hours, but our clients always dropped their connection. USB to ethernet was the only thing that worked. Solid for a month now.

This thread saved me! Thanks guys

Like