Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. If you like what you see, join us in person at the ninth annual Jamf Nation User Conference (JNUC) this October for three days of learning, laughter and IT love.

Enable Wi-Fi on device locked with passcode

I had a teacher come in today with an iPad that had a passcode on it. The device was not on Wi-Fi so I could not remotely clear the passcode. Is there a way to enable Wi-Fi without being able to access the settings? I tried sliding up for the control center (or whatever it's called) and had no luck. I'll probably have to wipe it but we'd like to access some data on the device first if we can. Thanks.

Like Comment
Order by:
SOLVED Posted: by jesseshipley

Is wifi actually turned off or is it just not connecting to the network? If wifi is switched to off I think you may be out of luck.

Like
SOLVED Posted: by jarednichols

Try plugging it into power. Often the wifi radio is shut off to preserve battery. If it's on power, it's less likely to turn the radio off and may actually kick it on again.

Like
SOLVED Posted: by davidacland

I would make sure its connected to power and make sure its in range of any wifi network that it is already configured to use. If neither of those work you may be out of luck.

I did wonder if you could plug it into the iTunes library it is synced with but I think that still doesn't work if the device is in a locked state.

Like
SOLVED Posted: by brownbe

We were able to get the code from the student and get in. It seemed the Wi-Fi kicked in as soon as we unlocked the device. It would be nice if there were a way to connect to an administrator computer to unlock the device if Wi-Fi is disabled but I know that would likely never happen.

Like
SOLVED Posted: by bentoms

It's an iOS 7+ or maybe 8 security feature.

Turn off a device connected to wireless, turn it on & do not enter a passcode. You shouldn't connect to wi-fi.

I mentioned it in IRC earlier & had others test it too.

Like
SOLVED Posted: by Simmo

Yeah.. It's actually really annoying, had this issue multiple times where a device had to be wiped because I was unable to get in to it with the user forgetting their passcode and the device not being connected to Wi-Fi

Like
SOLVED Posted: by ssteiner

I've had this problem as well. I found this video and the solution has worked for us so far :http://9to5mac.com/2014/01/10/video-connect-your-ipad-to-the-internet-via-ethernet-cable-with-this-easy-hack/

It's a hack to hardwire your iPad using an ethernet connection. I've already used to to connect and then unlock 3 iPads with Casper. Kind of a pain to set up, but I just leave it set up in my office so it's ready when I need it.

Like
SOLVED Posted: by Simmo

@ssteiner Did you use a router of some description to get it working? I gave it a go and had no luck, but I didn't use a router.

Like
SOLVED Posted: by calumhunter

Ive done this before as well, it works and is good for those times when students/staff can't remember their passcode and you want to be able to reset it via casper.

@Matt.Sim The ethernet connection needs to have DHCP maybe that was your problem?

Like