Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

"iPad is Disabled" bc of passcode, Wi-Fi shuts off

Does anyone have a solution for preventing wi-fi from shutting off when an incorrect passcode disables an iPad? It's very frustrating to have the option in JSS to clear a passcode for an iPad that desperately needs it, but I can't use it because the iPads shut off their wi-fi when they enter that state.

Now the only option is to wipe it, as I can no longer get it to connect to iTunes to clear the passcode. Darn you iOS9!! Although I wonder... was it iOS9 that closed that loophole, or an update to iTunes? Next time I have one of these I'll have to see if I can dust off a computer with iTunes 9 or 10.

Like Comment
SOLVED Posted: 12/18/15 at 8:02 AM by RLR

I don't think it's an IOS thing as I have an iPad 3 on my desk on IOS 9 and that doens't lose wifi connection. It seems to be any models higher then the iPad4.

I found this answer in another thread which I can't find at the moment. I copied it down because I think it will come in use at some point for us. You might need to spend some money to get this to work. Basicly, you're tricking the iPad into having an Ethernet connection. I've not done it myself yet but people say it works:

You'll need
Apple Lightning to USB Camera Adapter (Or 30-pin camera adapter if it's an old iPad)
Apple USB Ethernet Adapter
Powered USB 2.0 Hub (any hub but must be powered)
Ethernet Cable

Plug the USB Ethernet Adapter into the USB hub, then plug the hub's cable that would normally goto your computer into the USB Camera Adapter and plug the USB Camera Adapter into your iPad. Plug a network cable into the ethernet adapter, then plug in the power on USB hub. Plug a network cable into the ethernet adapter (the other end plugged into your network of course) and the iPad should pick up that it has a network connection.

Like
SOLVED Posted: 12/18/15 at 8:03 AM by mpermann

@mhayden have a look at this thread. There is a potential work around for your issue that might work for you.

Like
SOLVED Posted: 12/18/15 at 9:18 AM by mhayden

Thanks - other than the hub I don't have any of that equipment but I'll put in an order for it. Sadly today's student will just get wiped.

Like
SOLVED Posted: 12/18/15 at 11:51 AM by tmagdziasz

The hard wire network does not work with newer iPads or iOS 9 or something... Not sure what the catch is but I have not gotten it to work with all the equipment

Like
SOLVED Posted: 12/18/15 at 5:18 PM by mmcallister

Tested and working with iOS 9.2 on an iPad Air.

Like
SOLVED Posted: 12/30/15 at 8:06 AM by tmagdziasz

can I ask what your setup is? I have an Amazon basics USB 3.0 hub the USB to ethernet and I do not get any internet connection on iOS 9 iPad Air

Like
SOLVED Posted: 12/30/15 at 8:36 AM by adamcodega

Tmagdziasz, can you confirm your setup?

Like
SOLVED Posted: 1/14/16 at 1:39 PM by yyang

Hey All,

I have re-enabled about 15 iPads since November with the exact setup pictured above. (Note: it's not a USB charging hub. It needs to be a USB hub that splits one USB connection into many). The catch is that the USB hub needs to be self-powered with a power adapter. If it draws any power from the iPad at all, it will not work very well. I have found that a larger hub works better than the 4-port hubs because it depends solely on the dedicated power adapter to function.

Once you have the setup connected, go into JSS and send a command to clear the passcode for the particular iPad. It shouldn't take more than a few minutes for the command to get through to the iPad.

There was only one iPad that would not connect, and that one was in airplane mode when it was disabled. I had to wipe and reset that one.

Another thing to note is that the iPad will not show that it has internet connection. I hope this helps a little.

Worked on iPad Air, iOS 9.2.

Like
SOLVED Posted: 5/6/16 at 8:49 AM by timvenchus

Has anyone been able to get this to work with the new Lightning to USB 3 Camera adapter (powered by iPad power adapter) plus a USB to Ethernet adapter? I can get online with an iPad that is already unlocked, but when I try to get online with an iPad that's been disabled it won't connect.

Like
SOLVED Posted: 5/6/16 at 10:15 AM by RLR

If an iPad is disabled you need to wipe it with itunes. The clear passcode command doesn't work for disabled iPads.

Like
SOLVED Posted: 5/9/16 at 12:21 AM by timvenchus

@RLR Even if the iPad doesn't display the "disable" screen, it just shows the regular lock screen (but user can't remember passcode)? This is where I was hoping the Ethernet adapter would allow it to connect to JAMF, but it appears that wifi and ethernet are disabled until the correct passcode is entered.

Like
SOLVED Posted: 5/9/16 at 2:20 AM by St0rMl0rD

@timvenchus no, ethernet will work even if the device is locked with passcode or Touch ID, as the ethernet connection isn't a payload that would be included in the protected area of iOS under the passcode lock.

Like
SOLVED Posted: 5/9/16 at 8:15 AM by timvenchus

Thanks, @St0rMl0rD. Perhaps the Apple USB 3 Camera Adapter USB Ethernet Adapter Power Adapter combo doesn't work for this case then. Unfortunate that Apple's own tools don't do the job =(

Like
SOLVED Posted: 5/26/16 at 4:43 PM by gbatech

I had two iPads that were disabled and would not connect to WiFi. I went by a local Apple Store to see if I could borrow their equipment to unlock the iPad. It worked perfectly using the USB 3 adapter.

If you want to test it yourself, I recommend going by an Apple Store if you have one nearby. They tend to be really helpful. The Genius I worked with was really curious to see if the setup worked and planned to add it to his recovery repertoire.

Like
SOLVED Posted: 5/26/16 at 5:22 PM by Sandy

Dang it!!
I finally got my new USB 3 Camera adapters and am not able to get it to work to wipe passcode from an iPad Air that has dropped off wifi.
Using the diagram Here: https://jamfnation.jamfsoftware.com/discussion.html?id=12444
from @dstranathan and making sure I had the iPad charger 10w, got no connection. Switched back to the old 30 pin and powered USB hub, worked right away....

Like
SOLVED Posted: 8/7/17 at 7:25 PM by Malcolm

I used to use the usb hub, usb ethernet adapter hack for this, but it doesn't seem to work any more, the iPad can be pinged, but for what ever reason the device isn't communicating to the MDM.

I suspect that this has been patched within one of the IOS 10.3 updates.

have you had to do this lately @adamcodega

Like
SOLVED Posted: 9/13/17 at 6:52 PM by tryckman

This has become a real problem for us. I have tested a number of solutions that have worked for us in the past and have had no luck. We have reverted to wiping the iPad.

Like