Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Outlook 2016 incomplete searching

I have a user with a rather extensive amount of locally stored and exchange side email using outlook 2016. Searching email only returns emails prior to 2013, any email after is not returned in a search.

I have reset spotlight, there’s nothing set in privacy in spotlight, any thoughts?

Near as I can tell spotlight is generally working, just outlook specifically won't return any results newer than 2012.

Thanks,

-alex-

Like Comment
Order by:
SOLVED Posted: by tknighton

common problem.

Rebuilding the search index may help

http://www.groovypost.com/howto/rebuild-outlook-2016-search-index/

Like
SOLVED Posted: by djwojo

So how exactly do you perform those windows steps on a mac @tknighton ?

Like
SOLVED Posted: by jbmaruh

Could follow the MS KB for it.
https://support.microsoft.com/en-us/kb/2741535

Though whenever I've had this issue I just wipe Spotlight and let it refresh, but I see you indicated doing that already, and Privacy isn't set, and nothing relevant is disabled in the Search results.

sudo mdutil -E /

Usually only takes a couple minutes for it to start repopulating and searching the entire database. Haven't had one fail after this on me yet, but I also haven't had this on 2016 yet, just 2011.

Worst case is I've seen some techs rebuild their database and that also seems to take care of it when Spotlight caches the new files.

Like
SOLVED Posted: by djwojo

@Kaltsas Your keywords to me were extensive local storage - that is when we run into this issue also. If the user's DB gets over say 5-10gb we start to see these anomalies. Clearing the spotlight cache and re-indexing has worked with a low success rate. The helpdesk has tried uninstalling office - deleting the local database folders - resetting spotlight indexing - then reapplying office. (i don't believe the app uninstall does anything other than buy time for the new index) It usually works, but one user still had a search problem. NOTE: In this case it was a developer who was tinkering with system permissions and we killed it with fire.

A few times when the local mailbox structure was what we consider insane (20gb+) we had to rebuild the OS X user profile. I have an open case with Microsoft about it and they are just as puzzled as to what could "corrupt" searching even after a rebuild and reinstall. With apple of course saying "It's MS's fault."

Short story TLDR: Apologies i don't have a concrete answer, but it seems correlated to the size of the local "DB."

For reference: https://support.microsoft.com/en-us/kb/2741535

Like
SOLVED Posted: by Kaltsas

Thank you for the responses. I didn't mention it in my initial post but I had followed KB 2741535 when I went out to investigate (this was originally reported by desktop, I don't generally interact with end users). I have some other mdimport things I am going to try before going nuclear and rebuilding the whole user profile.

In regards to the storage use, we do not give end users a lot of primary mailbox space and have no plans to enable exchange online archiving. Thus there are many users (Windows and Mac) that have very extensive collections of local mail. Personally I clean out any email older than a year to an archive with mail steward. I have broached enterprise archiving (and client backups for that matter) in the past to no avail. I am not convinced even the most modern of mail applications really can handle the volume of email some people tend to store. And why should they, old email is unlikely to be referenced frequently. While just deleting it seems inappropriate with modern storage capacities, storing 15 year old email in your primary mailbox seems just as inappropriate. But alas, large, mature organizations don't seem to be in any hurry to update processes and procedures to meet modern needs.

But ya'll got me on my soapbox, I'll report back a yis or nis if I'm able to cajole it back to search ability without going nuclear.

Like
SOLVED Posted: by djwojo

So much agreement.

Like
SOLVED Posted: by casper100

In cases of Spotlight not working at all (not in the OP's description, I know) OR Outlook returns no or partial results AND resetting Spotlight via the GUI or via the Terminal one-liner described above does not help, I have had success with this sledgehammer:

sudo mdutil -i off /
sudo rm -rf /.Spotlight*
sudo rm -rf /.metadata_never_index

REBOOT the computer NOW

sudo mdutil -i on /
sudo mdutil -E

Like
SOLVED Posted: by tnielsen

I'd like to add my frustration to this problem that it seems to RETURN after awhile. I have no permanent fix for this although the comment above may work... only time will tell.

Like
SOLVED Posted: by mhamlin

This issue appears to be fixed with the new 15.19.1 update, though it's not addressed in the release notes.

I've tested this on a couple computers here and searching is complete and no longer displays "no results."

https://support.microsoft.com/en-us/kb/3134241

Like
SOLVED Posted: by jamessnow

Hello
have you checked whether your Windows Search Service is Started or not,
what about the resetting and rebuilding Outlook Index.
If you rectify the above point then you would definitely get rid of Outlook search Issue.
For detailed steps do refer this blog https://sysinfotools.com/blog/resolved-fix-outlook-search-problem/

Like
SOLVED Posted: by sebastiannz

Hi all.

I have put a script together based on the MS support article here. It works really well as it doesn't require the entire spotlight index being dumped so the user doesn't have to put up with hours of spotlight being spotty while it rebuilds the entire index.

The issue I have though, when executing from Self Service, is if the user's Outlook database is large then the Self Service application will crash. From what I can tell it seems the Self Service application basically times out because the command takes too long to finish executing.

I was wondering if there was a way of getting self service to run this in the background somehow. Does anyone have any ideas on a better way to accomplish this?

#!/bin/bash
currentUser=$( ls -l /dev/console | cut -d " " -f4 )
sudo -u $currentUser mdimport -g "/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter" -d1 /Users/$currentUser/Library/Group\ Containers/UBF8T346G9.Office/Outlook/Outlook\ 15\ Profiles/Main\ Profile
/usr/sbin/jamf displayMessage -message "The Serach index is being rebuilt for your Outlook account. It may take a up to an hour to completely reindex entire mailbox"
exit 0
Like
SOLVED Posted: by sebastiannz

Just a follow up to the above. When I woke up this morning the answer seemed to just come to me. I have made a second Policy and Script which tells jamf to run the above script with /dev/null and nohup and it works a treat.

#!/bin/bash
nohup jamf policy -id [id of the above policy] > /dev/null 2>&1 &
exit 0

The policy that contains this script is what the end-user sees in Self-Service, it then runs my original policy detached from the self-service application.

I must admit, it feels a little messy, but if anyone has any ideas on how this could be made more efficient I'd love to hear your suggestions. Otherwise, the above seems to work really well.

Like