Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Safari 10 not opening on El Capitan?

Since the release of the Safari 10 update, we've encountered a strange issue where a small handful of clients will no longer open the browser. Nothing in the logs and not even a single bounce in the dock when clicked. It occurs under all users on the affected machine and when opened via the Terminal, all that's returned is "LSOpenURLsWithRole() failed with error -10699 for the file /Applications/Safari.app"

What's even stranger is Safari can be opened by Show Package Contents on Safari.app then opening the executable within the Contents/MacOS folder.

Anyone have any ideas?

Like Comment
Order by:
SOLVED Posted: 9/30/16 at 2:46 PM by maser

Is this on 10.11? A couple of people here resolved it by reinstalling the recent 10.11 security update. YMMV...

Like
SOLVED Posted: 9/30/16 at 7:32 PM by jphillips

Unfortunately for us, reinstalling the security update did not fix any of the machines affected with this. However, upgrading to Sierra seems to fix.

Like
SOLVED Posted: 10/1/16 at 9:30 PM by mikeh

I've been able to fix the problems by installing a copy of the Safari 10 installer that was downloaded to a system but not yet installed. Find the downloaded installer in /Library/Updates.

Like
SOLVED Posted: 10/3/16 at 6:47 AM by VT-Vincent

A reinstall ended up fixing it for my clients, if you need the download and don't want to hunt down a machine that hasn't received it yet, you can download it from Apple here:

http://swcdn.apple.com/content/downloads/13/52/031-78814/r747w78fqi2jru2xuiihjhnedprlwz1ubg/Safari10.0ElCapitan.pkg

Like
SOLVED Posted: 10/14/16 at 3:46 PM by krwright

Thanks, all - that just fixed the issue for me, as well.

Like
SOLVED Posted: 12/1/16 at 12:01 PM by Kyuubi

This just happened to me. The fix offered by @mikeh worked. Its actually what Apple Support had me do. My question is: why is this happening? And why isn't it happening to everyone in the environment? Hopefully Apple with come up with a reason.

Like
SOLVED Posted: 12/1/16 at 12:13 PM by VT-Vincent

I literally just received a call about this reappearing 5 minutes before your reply... I ended up doing the same thing as last time, but needed Safari 10.0.1:

http://swcdn.apple.com/content/downloads/44/57/031-81873/b7woxaez0lftqe660ikhdui2cmzcuktqmo/Safari10.0.1ElCapitan.pkg

Like
SOLVED Posted: 12/13/16 at 5:31 AM by psg_casper

Thanks for this solution, it helps a lot. But how did you find the downloadlink at the swcdn-Site of Apple? I tried to search but it failed. For the future it would be very helpful to find there some downloads of apple software. Thanks in advance for helping

Like
SOLVED Posted: 12/13/16 at 6:33 AM by VT-Vincent

Apple doesn't provide those directly on Apple.com anymore, you can find them in the software update catalogs:

https://gist.github.com/geoff-codes/c7b38d695af39c4e1535

Like