Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

TI-SmartView CE Emulator

I recently started testing some of our existing software on the latest version of macOS Sierra (10.12.3) and ran into an issue with the TI-SmartView CE emulator software for Mac that was a result of a change Texas Instruments had made to the software installer that wasn't communicated and is one somewhat buried line in their software installation and activation knowledge base article. See the details below.

The Problem

When TI-SmartView CE is installed via its install PKG, a file gets created in /Library/Application Support/TI-SmartView CE 84/res/. This file was essentially a template in order to automatically activate a perpetual serial number when the software was launched for the first time. As a result, you could run the TI-SmartView PKG installer and then install a separately packaged file to this directory so that when a user launched the application for the first time it became activated.

However, in the most recent version of the software while the file still gets created through the installer in the directory specified above, the PKG installer as part of its install process actively looks for a file in the same directory as the PKG installer.

The Solution

Rather than copy the file to the JSS's default copy and install location /Library/Application Support/JAMF/Downloads and remove it afterward, I created a PKG installer in Composer and put both the standard TI-SmartView CE install PKG and the file in /private/tmp/

I created a postinstall script to log the install and remove both files afterward.

## postinstall


writelog () {
    /bin/echo $(date) "${1}" >> "$LOG"

removeallfiles () {
    rm "$INSTALLER"
    if [ $? = 0 ]; then
        writelog "TI-SmartView installer deletion successful!"
        writelog "TI-SmartView installer deletion failed."

    rm "$LICENSE"
    if [ $? = 0 ]; then
        writelog "TI-SmartView license deletion successful!"
        writelog "TI-SmartView license deletion failed."

if [ -f "$INSTALLER" ] && [ -f "$LICENSE" ]; then
    writelog "CHECK: TI-SmartView installer and deployment.properities detected. Installing ..."

    sudo installer -pkg "$INSTALLER" -target /

    if [ $? = 0 ]; then
        writelog "TI-SmartView installation successful!"
        writelog "TI-SmartView installation failed."
        exit 1
    writelog "ERROR: TI-SmartView installer and/or file not detected."
    exit 1


Hope this is helpful for other people who use the software as well.

Like Comment
SOLVED Posted: by pitcherj


Thanks for this!

Just ran into this particular issue, only thing is that the /Library/Logs/TMSTech/ directory didn't exist.

Decided to just dump it into /Library/Logs, but could have probably re-worked the script to create the directory structure too.

Thanks again!