Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

TeamViewer deployment issues: Accessibility Permissions

We have TeamViewer deployed throughout our company via auto installing Policy from Jamf. Ever since the upgrade to Mojave, new installs of the TeamViewer host package get a prompt to grant accessibility permissions, which require Admin credentials. Our employees have local Standard User accounts, so they are not able to grant the permission.

We packaged up the TeamViewer installer via Composer, and even recorded the Permissions granting part after we received the prompt. Folder Permission set to:

Owner: root(0)
Group: wheel(0)
Mode 775

From Composer, created as a DMG and uploaded to Jamf. Download+Install initiated by Jamf Self Service policy.

Anyone know a workaround on how to get the Mac to grant access to TeamViewer automatically?

Like Comment
Order by:
SOLVED Posted: by sshort

@kcsantos If the Macs are on Mojave you can use a PPPC profile to whitelist this so your users won't have approval issues. Check out the one I made.

Like
SOLVED Posted: by kcsantos

I created a PPPC profile via the PPPC Utility. Here are my settings I have enabled for TeamViewer. Am I doing something wrong?

I did the same for the TeamViewer_Desktop

Like
SOLVED Posted: by kcsantos

Ugggh... super noob mistake. I figured it out. I needed to do the settings posted in the previous picture for both TeamViewerHost and TeamViewer_Desktop. I initially assumed the settings carried to everything in that list automatically.

But it's working now. For those who are reading, just note the applications don't appear in the System Preferences>Security and Privacy>Accessibility screen after the profile allows it to go through.

Like
SOLVED Posted: by thenikkiwhite

Heya... did you ever get this to work appropriately? I have been trying to use PPPC with TeamViewer and no matter what, I can't get it to work. I called TeamViewer and they said this isn't possible... you have to approve it on every machine manually.

Like
SOLVED Posted: by scottb

@thenikkiwhite - did you try what @sshort posted above?

Like
SOLVED Posted: by thenikkiwhite

yes, i tried it. it did not work for me... not sure if it matters but we are running the tensor version and not the QS version.

Like