Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Deploying Xcode in 2019

Is anyone deploying Xcode through the 'Mac App Store Apps' option with any success?

Our one app development class uses Xcode on the computers then tests on their iPads so I need to make sure the versions match for this to work. Previously I had been downloading Xcode and deploying manually but this is somewhat time consuming. Then if the iPad app updates that causes issues until I can get the computer app updated again.

When trying to install Xcode from the App Store through Self Service it fails, but I'm not able to find anything in the logs about why it fails. When trying to install it this way with Xcode already installed, the app itself opens but it doesn't seem to be updating to the latest version.

Anyone else having similar issues? I've deployed plenty of iPad apps this way without issue so I can't imagine it's that different.

Like Comment
Order by:
SOLVED Posted: by tak10

If Xcode was manually installed on the computer previously, Mac App Store Apps install option will only open the Xcode application. You will need to remove the app (in this case Xcode) and re-install using VPP / Mac App Store Apps deployment. Once the VPP deployed Xcode is installed on the computer, it should automatically maintain to the latest version going forward as long as you specifically set it up to update automatically.

I've had to follow this procedure for moving package based deployment to VPP / Mac App Store based deployment with multiple apps.

Like
SOLVED Posted: by chris.miller

To build on what @tak10 said you can push out a terminal command to remove XCode and then it should be available to "reinstall" via self service. I've seen this with other apps just like he mentioned and this workflow seems to do the trick for us.

rm -rf /Applications/Xcode.app
Like
SOLVED Posted: by AdamBritt

Sorry for the late replies. Finally having some time to sit down and mess with this some more.

So for future record if anyone else is running into the same issue:

I logged into the VPP store and got licenses for Xcode. Then in JSS, I went into the "Mac App Store Apps" option to add Xcode. Under the VPP tab there is a checkbox for 'Assign VPP Content Assign VPP content to computers with macOS 10.11 or later" that I just saw the other day which allows free apps to be assigned to computers and not users. I believe this is the correct way to deploy free apps from the Mac App Store to the computers.

The issue I'm currently running into is when installing Xcode this way through Self Service it is taking a long time on every computer, but the license seems to be available correctly. I found out our caching server is full so we're working on that which will hopefully help once one download goes through correctly.

The other issue I'm having is impatient teachers, but I don't think you guys have an easy fix for those. I think I need to figure out how to lock down iPad app updates, maybe just for Xcode, so that they don't get the version out of sync until I can get Xcode managed and automatically updated on the Macs.

Like
SOLVED Posted: by Fattic

@tak10 Do you know if installing it with VPP also installs the command line tools?

Like
SOLVED Posted: by AdamBritt

That I don't, sorry. It's been a while since I implemented these, but rtrouton has an Xcode post install script or package you can use here: https://github.com/rtrouton/rtrouton_scripts/tree/master/rtrouton_scripts/xcode_post_install_actions I don't remember if this included the command line tools, but I've been using it since I first deployed Xcode and haven't heard of anything missing from my users.

Like
SOLVED Posted: by mediacollege

i tried building an Xcode 10.2.1 package with the script from rtrouton, but it seems the script doesnt run. xcode keeps asking to install additional content. when the script is run manually it installs without issues.. Do you guys expericence the same problems?

Like
SOLVED Posted: by stephaniemm77

anyone solve this? looking to do the same thing

Like
SOLVED Posted: by SCADtom

I have been able to package all of the post install stuff and successfully deploy it, but, each user is still prompted to install the extras that are already there.

Like
SOLVED Posted: by larry_barrett

If your Mac is setup with stock energy settings it will go to sleep before the initial installation can complete (on my network anyways). Xcode is like 8 GB or something. Change the setting for Turn Display Off to more than the stock 15 min (again, depends on how fast your network can deliver it). I failed 3x, changed the energy setting and it worked right away.

Like
SOLVED Posted: by AdamBritt

That's what I ended up doing. I was running out of time so I manually started my package from Self Service, but I did have to change the energy settings to prevent the computers from going to sleep while Xcode installs. I had to make an admin account for the class using Xcode for when it asks to install something during the initial launch and just in case something else would come up. Once Xcode updates I will report back if the managed app feature keeps it up to date automatically or not.

Like