Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Install books to iOS devices - silent install?

Hi all - I am attempting to install free Bookstore books to iOS devices but although they appear for the user, can't get them to actually install (download).
I have added the books in Users>eBooks and scoped to users
I have checked the checkbox in Users>VPP Assignments>eBooks and scoped to users. This shows that licences are available and assigned.
Users are signed in to iTunes/Bookstore on devices

The books appear for the user but have a cloud symbol requiring the user to tap the book to download.

What do I need to do to ensure the books download automatically for all users?

Many thanks

Like Comment
Order by:
SOLVED Posted: by cdenesha

In Users -> eBooks, Is the Distribution Method = Install Automatically?

Like
SOLVED Posted: by thirdspace

So - after a bit more experimenting - books silently download to some devices but not others, where they appear with the cloud. There is no difference between the state of each iPad. Annoyingly inconsistent or some other factor I am not considering?

Like
SOLVED Posted: by thirdspace

@cdenesha Indeed it is!

Like
SOLVED Posted: by bcampbell

Did you check that the devices that won't install the book have enough local storage space? I've had that issue in the past (as one of our iBooks is a large textbook), and the install failed without an obvious alert.

I'd also check for and clear any failed or pending management commands. While I'm generally a fan of JAMF Pro and find it pretty reliable, I sometimes have issues where apps or books won't install until after I go through a standard set of steps that include restarting the iPad, clearing "stuck" or failed commands, then reissuing an inventory to get JAMF to try again. Sometimes I feel like I should be waiving a lucky rabbit's foot as I'm not always clear when was causing it to be stuck to begin with, but it almost always gets resolved after this (and some hand waving for good measure). (I suspect the issue sometimes just lies with Apple not always passing management commands through their servers perfectly.)

Like
SOLVED Posted: by jcarr

Are your users using Managed Apple ID or personal Apple ID? If personal, have they accepted the VPP invitation from your org? If managed, have you selected the option to "Automatically register with VPP if users have Managed Apple IDs?"

From the Jamf Pro admin guide: Apple's Volume Purchasing User Registration

Like