Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

Latest Version of Google Chrome Issues with JSS

Currently on

JAMF Pro 10.4.0
&
JAMF Pro 10.8.0
&
JAMF Pro 10.10.0

All our JSS's have an issue with what appears to be a Google Chrome issue.

Whenever we edit or create a policy and add/remove packages, we either get erratic behavior. Adding packages to policies don't add and end in a spinning circle forever (see attached).

We narrowed it down to this version of Google Chrome on both Mac and Windows.
Version 75.0.3770.90

Logging.html returns a strange issue (see attached)

Like Comment
Order by:
SOLVED Posted: by Aaron

Oh! And I thought it was just me. I haven't got around to clearing the browser cache to see if that fixes the issue, as I have too much open...

Like
SOLVED Posted: by bsuggett

This should be more easy to find, but here is the links...

JAMFPro Known Issues

PI-007099 When using Google Chrome release 75.0.3770.80, adding scripts or packages to policies prevents you from saving or cancelling the policy. Workaround: Use a different browser.

Like
SOLVED Posted: by Ecco_Luke

I've also had this! I only use Chrome for work so this is really annoying.

I guess it'll also affect the current dev preview of Edge on Mac (which is excellent if anyone is wondering) as it's basically the same browser.

Like
SOLVED Posted: by RJH

Also seeing this on Chrome 75.0.3770.100.

Confirming the original post, looking through the JSS log you see some really strange errors
2019-06-24 14:39:08,873 [ERROR] [Thread-5 ] [HTMLController ] - Exception processing HTMLResponse: java.lang.NullPointerException at java.lang.String$CaseInsensitiveComparator.compare(Unknown Source) at java.lang.String$CaseInsensitiveComparator.compare(Unknown Source) at java.lang.String.compareToIgnoreCase(Unknown Source) at com.jamfsoftware.jss.objects.policy.PolicyHelper$10.compare(PolicyHelper.java:1536) at com.jamfsoftware.jss.objects.policy.PolicyHelper$10.compare(PolicyHelper.java:1533) at java.util.TimSort.countRunAndMakeAscending(Unknown Source) at java.util.TimSort.sort(Unknown Source) at java.util.Arrays.sort(Unknown Source) at java.util.ArrayList.sort(Unknown Source) at java.util.Collections.sort(Unknown Source)

Is there a planned fix for this ? Has it been logged to Google Chrome devs, or is it an issue on the JSS side of things - anyone know ?

Like
SOLVED Posted: by allanp81

Seeing this as well. Works fine in Edge (MS Edge, not Chromium Edge) but it's really laggy in comparison.

Like
SOLVED Posted: by cnagy

Chrome (Version 75.0.3770.100) has the same behaviour on macOS (with JAMF Pro 10.12). Really annoying, Safari works as a workaround.
I hope it will get fixed soon.

Like
SOLVED Posted: by echave

Still a thing with Chrome version 75.0.3770.142 (Official Build) (64-bit). Issue reproduced after clearing caches and in Incognito mode. Issue reproduced on first install, not signed in to Chrome sync and with no extensions.
Safari works.

Like
SOLVED Posted: by chris.kemp

<expletive><expletive><expletive>!!!

Wish I'd seen this yesterday afternoon...at least now I know what's going on with the policy I'm trying to create.

Like
SOLVED Posted: by chrisdaggett

This applies to all Chromium browsers as well (IE Brave). Still exists with all latest versions. Very frustrating.

Like
SOLVED Posted: by RLR

Seeing this also. Have to switch to Firefox if I want to make policy changes.

Like
SOLVED Posted: by allanp81

Edge Chromium as well (but obviously it's now Chromium based so not surprising).

Like
SOLVED Posted: by bsuggett

Dear All,

This issue according to JAMF Pro's 10.14.0 release notes has been resolved.
JAMF Pro 10.14.0 Release Notes

[PI-007099] Fixed an issue that prevented administrators from saving or canceling a policy when adding scripts or packages to the policy and using Google Chrome version 75.0.3770.80.

Like