Skip to main content
Jamf Nation, hosted by Jamf, is a knowledgeable community of Apple-focused admins and Jamf users. Join us in person at the ninth annual Jamf Nation User Conference (JNUC) this November for three days of learning, laughter and IT love.

ZScaler App Deployment

We have signed on with ZScaler and they have provided and .app installer. I have used Composer to convert it to .pkg and uploaded it to our repository. When I setup a policy to install the app, I get a log that states it was successful but ZScaler app is not installed on the target machines. Has anyone else run into this issue and what did you do to get it resolved?

Thanks,
Wil

Like Comment
Order by:
SOLVED Posted: by Travid

Using Composer I put the Zscaler-osx-x.x.x-installer.app in the /Applications/Utilities folder then added a postinstall script that has

/bin/sh /Applications/Utilities/Zscaler-osx-1.5.1.5-installer.app/Contents/MacOS/installbuilder.sh

in it.

Like
SOLVED Posted: by rtrouton

I built Zscaler AutoPkg recipes. More information on how to use them to build a Zscaler installer package is available via the link below:

https://derflounder.wordpress.com/2019/07/26/building-customized-postinstall-scripts-for-autopkg-recipes/

Like