Skip to main content
Jamf Nation, hosted by Jamf, is a dynamic and knowledgeable community of Apple-focused IT admins and Jamf Pro users. Join us in person, in October, for the annual Jamf Nation User Conference (JNUC) to discover new and better ways to manage Apple devices.
CCA Badge CMA Badge

Computer names not being set at imaging

I'm having a curious issue where machines being imaged aren't having their names applied. These machines haven't been imaged or reconned by the JSS in the past and if I add them to the inventory manually first they get named correctly.

Where I encounter the issue is when I try to image a new machine, I enter its name into Casper imaging, the imaging logs say the computer name was set but the machines name ends up being blank.

I haven't dug too deep yet but I wondered if anyone else had encountered this?

Like Comment
SOLVED Posted: 3/18/12 at 3:23 AM by evarona
but the machines name ends up being blank.

Which name? LocalHost, Host or Computer?

I've only seen this once. I've recently been having issues with using images from an MBP on an MBA (en0/en1 are getting "mixed up"). One suggestion given to me was to delete some of the network specific files in /Library/Preferences/SystemConfiguration. When I deleted preferences.plist and NetworkInterfaces.plist, I ended up with machines with no name set for any of the three. Are you deleting these from the image you're laying down?

The other thing I'd check is your DNS config. When we're having problems with DNS, the LocalHostName seems to either be set incorrectly or not at all which caused AD bind issues for us at one point.

HTH. Cheers

CCA Badge CMA Badge
SOLVED Posted: 3/18/12 at 4:27 AM by curullij

Hi Emil,

I'll have to check when I'm back in the office tomorrow but I'm pretty sure that all three are blank. I created the image on a MB and am imaging MB's but I have had that issue with the network interfaces getting mixed up using a MBA image.

I have deleted /Library/Preferences/SystemConfiguration/ from the imaging I'm using. I can see how a DNS issue could cause issues with the Localhost name but as both names are blank, and using a different imaging system (deploy studio) has no issues I don't think DNS will be the cause of our issue.

Are you suggesting to leave the SystemConfiguration folder in the image?


SOLVED Posted: 3/19/12 at 2:05 PM by tsd25108

I was having some issues with this when I recently started to move to 10.7. We ended up having to delete the auto run data from the JSS about that computer even though we really don't mess with auto run. We also had to make sure we were choosing a configuration that had the management user inputted.

SOLVED Posted: 3/29/12 at 5:39 PM by briangoldstein

Do you have apostrophes in the names? With my 8.43 install apostrophes cause the hostname to be blank, the name in the sharing sys pref to be blank, and the name in the JSS to be "No Name". I have an open bug ticket (dev ID D-002592) with JAMF regarding this.

SOLVED Posted: 4/4/12 at 9:17 AM by msardes

I am getting this error

Computer Deleted (ID: -1) Wednesday, March 28 2012 at 10:16 AM .

It properly images the machine and names it however it deletes it from the Casper inventory and I have to do a recon to re add the machine.

CCA Badge CMA Badge
SOLVED Posted: 4/9/12 at 10:35 AM by PhilMaul

I was getting this error "Computer Deleted (ID: -1)" with version 8.43, I have upgraded to 8.51 and now am no longer getting an entry in the Casper Imaging Logs at all, also the computer isn't getting added to inventory at image time. A Recon after the fact does add the machine to inventory.

CCT Badge CCA Badge
SOLVED Posted: 9/11/12 at 10:43 AM by leegalan

I am also having this same issue. Were you ever able to get a resolution for it? I'm using version 8.6.


CCA Badge CMA Badge
SOLVED Posted: 8/21/13 at 11:39 PM by curullij

I know it's a bit late, but I did get it working by implementing this script. It's in the imaging workflow to run after a machine has been imaged. It picks up those few machines who sometimes don't have a name. I also use it to keep the names of the machines updated. Our students have admin rights as so, regularly change their machine names. This sets them back :)

NAME=grep "Binding" /var/log/jamf.log | tail -1 | awk '/Binding/ {print $5}'\
/usr/sbin/jamf setComputerName -target / -name "$NAME"
jamf recon

SOLVED Posted: 8/22/13 at 5:21 AM by jeremy.spolander

Have seen a few times where a policy can knock out the name but ticking the advanced option to reset name from jss on the problem policy sorts that out.