Skip to main content
Jamf Nation, hosted by Jamf, is the largest Apple IT management community in the world. Dialog with your fellow IT professionals, gain insight about Apple device deployments, share best practices and bounce ideas off each other. Join the conversation.

Making Language Chooser run at first boot

Has anybody figured out how to get Language Chooser to run at first boot?
if I make my image from a Install OS X.app it seems to assume that since i ran that App in English that is the language I will want everybody to use, and well my customers tend to be Global.

I can make it run, but it runs on top of setup assistant and well its ugly and can be problematic if people start clicking on setup assistant before language chooser appears.

Any ideas would be greatly appreciated.

Like Comment
Order by:
SOLVED Posted: 5/1/13 at 3:01 PM by nessts

Well I guess in case anybody else ever cares about this.
the answer is:
touch /private/var/db/.RunLanguageChooserToo
and yes i spelled that correctly.

Like
SOLVED Posted: 5/1/13 at 3:04 PM by jhbush1973

nessts, could you elaborate a bit more how you are using this and what the deployment looks like?

Like
SOLVED Posted: 5/1/13 at 3:30 PM by nessts

I make a base image from the Install OS x.app, to a blank disk, then i let it reboot and do its install thing.
then when it goes to boot the first time, i netboot it and make an image of that disk, its similar to what instaDMG does, i just do it on a physical disk, i also capture the recovery partition as well.
in this mode the first boot does not ask for language because its assuming since i used english when i ran the installer i must always want to use English. my images are global i have users in many countries so its preferable for the users to get to choose what language the computer is in. touching that file allows Language Chooser to run as it would if the system came from the factory.

Like
SOLVED Posted: 9/26/13 at 10:31 AM by nessts

fyi
touch /private/var/db/.RunLanguageChooserToo

Like
SOLVED Posted: 10/10/16 at 7:56 AM by makander

@nessts, are you still doing this in 10.11 and 10.12?

Like